View Issue Details

IDProjectCategoryView StatusLast Update
0014773SCLo[All Projects] generalpublic2019-01-08 17:26
Reportertsondergaard 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Platformx86_64OSCentOSOS Version7.4.1708
Summary0014773: Fetching repodata/repomd.xml for centos-sclo-rh-source returns HTTP Error 404 foilingyum-builddep
Descriptionyum-builddep automatically enables all source repos and the centos-sclo-rh-source repo from centos-release-scl-rh has a repo URL that is currently empty:

http://vault.centos.org/centos/7/sclo/Source/rh/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
To address this issue please refer to the below knowledge base article

https://access.redhat.com/articles/1320623

If above article doesn't help to resolve this issue please create a bug on https://bugs.centos.org/

failure: repodata/repomd.xml from centos-sclo-rh-source: [Errno 256] No more mirrors to try.
http://vault.centos.org/centos/7/sclo/Source/rh/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
make: *** [Makefile:14: rpm-el7] Error 1
Steps To Reproducedocker run -ti --rm centos:7.4.1807 bash
yum install -y centos-release-scl-rh
yum-builddep -y whatever.spec
Additional InformationSeems to be a fresh variant of this resolved issue for CentOS 6: https://bugs.centos.org/view.php?id=13125
TagsNo tags attached.

Relationships

duplicate of 0015606 feedbackJohnnyHughes SCLo source repository does not exist for CentOS 7.6.1810 

Activities

tsondergaard

tsondergaard

2018-05-11 22:33

reporter   ~0031776

In the steps to reproduce the yum install line should also install yum-utils to obtain yum-builddep, so:

yum install -y centos-release-scl-rh yum-utils
craig2ndq

craig2ndq

2018-12-21 02:21

reporter   ~0033413

I see the same issue.

```
http://vault.centos.org/centos/7/sclo/Source/rh/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
```

It looks like http://vault.centos.org/centos/7.5.1804/sclo/Source/ has a /rh/ directory but http://vault.centos.org/centos/7.6.1810/sclo/Source/ does not, it only has /sclo/ . http://vault.centos.org/centos/7/ now points to /7.6.1810/ so the expected /rh/ dir is missing.

`yum-builddep` enables all repos, including the repos installed by the `centos-release-scl` package from EPEL; see http://mirror.centos.org/centos/7/extras/x86_64/Packages/ where there are packages

```
[ ] centos-release-scl-2-2.el7.centos.noarch.rpm 2016-05-23 15:47 12K
[ ] centos-release-scl-rh-2-2.el7.centos.noarch.rpm 2016-05-23 15:47 12K
```

unpacking the two rpms, I see

```
centos-release-scl-2-2.el7/etc/yum.repos.d/CentOS-SCLo-scl.repo
centos-release-scl-rh-2-2.el7/etc/yum.repos.d/CentOS-SCLo-scl-rh.repo
```

The `centos-release-scl` depends on `centos-release-scl-rh`:

```
$ rpm -qp --requires centos-release-scl-2-2.el7.centos.noarch.rpm|grep centos
centos-release-scl-rh
config(centos-release-scl) = 2-2.el7.centos
```

so we get

```
---> Package centos-release-scl.noarch 0:2-2.el7.centos will be installed
--> Processing Dependency: centos-release-scl-rh for package: centos-release-scl-2-2.el7.centos.noarch
```

then yum-builddep enables the busted repo.

Definitely a CentOS bug here.
craig2ndq

craig2ndq

2018-12-21 02:26

reporter   ~0033414

To fix this, CentOS needs to drop the dependency of centos-release-scl on centos-release-scl-rh or reinstate the /rh/ directory as an empty repo. Preferably both.

To work around it, users should be able to delete the contents of /etc/yum.repos.d/CentOS-SCLo-scl-rh.repo or remove the file. Marking the repos disabled is not sufficient, as yum-builddep overrides it.

I think an explicit --disablerepo=centos-sclo-rh-source might do the trick too.
craig2ndq

craig2ndq

2018-12-21 02:49

reporter   ~0033415

None of these workarounds are particularly practical when building packages within containers etc, though, where the invoker doesn't control the yum-builddep run directly.

I'm working around it for now by not installing centos-release-scl and instead copying the ./etc/yum.repos.d/CentOS-SCLo-scl.repo and ./etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-SIG-SCLo files directly.
cojoco

cojoco

2019-01-07 21:21

reporter   ~0033532

I just ran into this as well. I used the workaround of removing /etc/yum.repos.d/CentOS-SCLo-scl-rh.repo, and was then able to use yum-builddep without running into this bug.

Issue History

Date Modified Username Field Change
2018-05-11 22:31 tsondergaard New Issue
2018-05-11 22:33 tsondergaard Note Added: 0031776
2018-12-21 02:21 craig2ndq Note Added: 0033413
2018-12-21 02:26 craig2ndq Note Added: 0033414
2018-12-21 02:49 craig2ndq Note Added: 0033415
2019-01-07 21:21 cojoco Note Added: 0033532
2019-01-08 17:26 bstinson Relationship added duplicate of 0015606
2019-01-08 17:26 bstinson Status new => closed
2019-01-08 17:26 bstinson Resolution open => duplicate