View Issue Details

IDProjectCategoryView StatusLast Update
0014895CentOS-7rsyslogpublic2018-11-05 14:52
Reporterthalunil 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionreopened 
Product Version 
Target VersionFixed in Version 
Summary0014895: rsyslog 8.24.0 tcp transport broken
DescriptionWith rsyslog 8.24.0 the TCP syslog transport is no longer working.
UDP syslog transport works flawlessly.
Steps To Reproducein /etc/rsyslog.conf there is
*.* @@host:514

-------------------------
When starting up in debug mode:

8260.340282517:main Q:Reg/w0 : ACTION 10 [builtin:omfwd:@@host:514;]
8260.340288440:main Q:Reg/w0 : executing action 10
8260.340291255:main Q:Reg/w0 : action 'action 10': called, logging to builtin:omfwd (susp 0/0, direct q 1)
8260.340298689:main Q:Reg/w0 : action 'action 10': is transactional - executing in commit phase
8260.340301546:main Q:Reg/w0 : wti 0x55fb9d02b3f0: we need to create a new action worker instance for action 10
8260.340316028:main Q:Reg/w0 : DDDD: createWrkrInstance: pWrkrData 0x7fe588002500
8260.340319830:main Q:Reg/w0 : wti 0x55fb9d02b3f0: created action worker instance 1 for action 10
8260.340322619:main Q:Reg/w0 : omfwd: beginTransaction
8260.340325159:main Q:Reg/w0 : TCPSendInit CREATE
8260.340329921:main Q:Reg/w0 : caller requested object 'nsd_ptcp', not found (iRet -3003)
8260.340359124:main Q:Reg/w0 : Requested to load module 'lmnsd_ptcp'
8260.340364399:main Q:Reg/w0 : loading module '/usr/lib64/rsyslog/lmnsd_ptcp.so'
8260.340542516:main Q:Reg/w0 : source file nsd_ptcp.c requested reference for module 'lmnetstrms', reference count now 3
8260.340558476:main Q:Reg/w0 : module lmnsd_ptcp of type 2 being loaded (keepType=0).
8260.340561910:main Q:Reg/w0 : entry point 'isCompatibleWithFeature' not present in module
8260.340564983:main Q:Reg/w0 : entry point 'setModCnf' not present in module
8260.340567721:main Q:Reg/w0 : entry point 'getModCnfName' not present in module
8260.340570395:main Q:Reg/w0 : entry point 'beginCnfLoad' not present in module
8260.340574351:main Q:Reg/w0 : source file netstrms.c requested reference for module 'lmnsd_ptcp', reference count now 1
-------------------------
with udp destination the destination syslog host receives the message

8175.238184222:main Q:Reg/w0 : ACTION 10 [builtin:omfwd:@host:514]
8175.238190660:main Q:Reg/w0 : executing action 10
8175.238193683:main Q:Reg/w0 : action 'action 10': called, logging to builtin:omfwd (susp 0/0, direct q 1)
8175.238201259:main Q:Reg/w0 : action 'action 10': is transactional - executing in commit phase
8175.238204251:main Q:Reg/w0 : wti 0x5593ec8b8270: we need to create a new action worker instance for action 10
8175.238224142:main Q:Reg/w0 : DDDD: createWrkrInstance: pWrkrData 0x7fd95c002500
8175.238227477:main Q:Reg/w0 : wti 0x5593ec8b8270: created action worker instance 1 for action 10
8175.238230794:main Q:Reg/w0 : omfwd: beginTransaction
8175.238713160:main Q:Reg/w0 : syslog.uibk.ac.at found, resuming.
8175.239198216:main Q:Reg/w0 : socket 6, actual os socket rcvbuf size 212992
8175.239206519:main Q:Reg/w0 : omfwd: doTryResume syslog.uibk.ac.at iRet 0
8175.239209920:main Q:Reg/w0 : Action 10 transitioned to state: itx
TagsNo tags attached.
abrt_hash
URL

Activities

gkraft4

gkraft4

2018-11-02 18:36

reporter   ~0033055

if I update from 8.24.0 to 8.29.0, then I still see the same issue.

systemctl stop rsyslog
yum autoremove rsyslog
cd /etc/yum.repos.d/
wget http://rpms.adiscon.com/v8-stable/rsyslog.repo
yum install rsyslog-8.29.0
systemctl start syslog
tigalch

tigalch

2018-11-05 06:30

manager   ~0033072

First, we do not support packages other than those we ship (so no 8.29.0)
Second, please report this issue to RedHat at their bugzilla. Once/If RH fixes it, CentOS will inherit the fix (and please also cross reference here). Thanks
arrfab

arrfab

2018-11-05 06:53

administrator   ~0033074

closing as not a centos package
arrfab

arrfab

2018-11-05 06:59

administrator   ~0033075

Last edited: 2018-11-05 07:04

View 2 revisions

Can you reproduce on a base centos 7 install and so with rsyslog-8.24.0-16.el7_5.4.x86_64 (current) ?
As we have that working in the CentOS Infra (using also TLS) and it works just fine .. so remote logging using TCP as transport works

thalunil

thalunil

2018-11-05 14:51

reporter   ~0033082

Hi - i am unable to reproduce today my former Bug report June 2018.
Therefore please close this bug report.

thanks!
tigalch

tigalch

2018-11-05 14:52

manager   ~0033083

Closing per reporters feedback

Issue History

Date Modified Username Field Change
2018-06-01 13:04 thalunil New Issue
2018-11-02 18:36 gkraft4 Note Added: 0033055
2018-11-05 06:30 tigalch Note Added: 0033072
2018-11-05 06:53 arrfab Status new => closed
2018-11-05 06:53 arrfab Resolution open => no change required
2018-11-05 06:53 arrfab Note Added: 0033074
2018-11-05 06:59 arrfab Status closed => feedback
2018-11-05 06:59 arrfab Resolution no change required => reopened
2018-11-05 06:59 arrfab Note Added: 0033075
2018-11-05 07:04 arrfab Note Edited: 0033075 View Revisions
2018-11-05 14:51 thalunil Note Added: 0033082
2018-11-05 14:51 thalunil Status feedback => assigned
2018-11-05 14:52 tigalch Status assigned => closed
2018-11-05 14:52 tigalch Note Added: 0033083