View Issue Details

IDProjectCategoryView StatusLast Update
0014907Buildsyscommunity buildsyspublic2018-08-01 07:13
Reporterndevos 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Summary0014907: %{dist} macro in core7-extras-common-el7.centos buildroot misses .centos extension
DescriptionIt seems that the %{?dist} macro in the core7-extras-common-el7.centos buildroot expands to ".el7". This causes the build failure copied in "additional information".

A workaround for building the package is to add the .centos extension in the .spec. But this is not required for the core6-extras-common-el6.centos variation.
Additional Information$ cbs \
> build core7-extras-common-el7.centos \
> centos-release-gluster41-0.9-1.el7.centos.src.rpm
Uploading srpm: centos-release-gluster41-0.9-1.el7.centos.src.rpm
[====================================] 100% 00:00:00 7.96 KiB 15.21 KiB/sec
Created task: 441718
Task info: https://cbs.centos.org/koji/taskinfo?taskID=441718
Watching tasks (this may be safely interrupted)...
441718 build (core7-extras-common-el7.centos, centos-release-gluster41-0.9-1.el7.centos.src.rpm): open (ppc64le-02.cbs.centos.org)
  441719 buildArch (centos-release-gluster41-0.9-1.el7.centos.src.rpm, x86_64): free
  441719 buildArch (centos-release-gluster41-0.9-1.el7.centos.src.rpm, x86_64): free -> open (x86_64-4.cbs.centos.org)
  441719 buildArch (centos-release-gluster41-0.9-1.el7.centos.src.rpm, x86_64): open (x86_64-4.cbs.centos.org) -> closed
  0 free 1 open 1 done 0 failed
441718 build (core7-extras-common-el7.centos, centos-release-gluster41-0.9-1.el7.centos.src.rpm): open (ppc64le-02.cbs.centos.org) -> FAILED: GenericError: Unable to complete build: release mismatch (build: 1.el7.centos, rpm: 1.el7)
  0 free 0 open 1 done 1 failed
TagsNo tags attached.

Activities

alphacc

alphacc

2018-06-06 07:07

developer   ~0032019

Hi Niels,

thanks fro reporting I am checking.

--
Thomas.
alphacc

alphacc

2018-06-06 12:15

developer   ~0032020

It should be fixed.

Would you be kind to resend the rpm without .centos ?

thanks.
ndevos

ndevos

2018-06-06 12:50

reporter   ~0032022

I did a scratch build, but the resulting RPM does not have .centos in its name: https://cbs.centos.org/koji/taskinfo?taskID=442709
gfidente

gfidente

2018-07-18 11:12

reporter   ~0032300

I have hit the same issue in http://cbs.centos.org/koji/taskinfo?taskID=483309

src.rpm was built with: rpmbuild -bs --define "_sourcedir $PWD" --define "_srcrpmdir $PWD" --define "dist .el7.centos" centos-release-ceph-luminous.spec
gfidente

gfidente

2018-07-20 13:10

reporter   ~0032326

Probably related to https://bugs.centos.org/view.php?id=14955 ?
alphacc

alphacc

2018-07-20 13:43

developer   ~0032327

I have a fix I need to deploy it. I'll try to work on it this week-end.
alphacc

alphacc

2018-07-27 11:13

developer   ~0032371

I finally had time to fix it. I relaunched the gluster41 build to validate that it works. Please confirm that everything is fine on your side.
ndevos

ndevos

2018-07-31 13:46

reporter   ~0032407

Great, this works for me too now, thanks!

New build at https://cbs.centos.org/koji/taskinfo?taskID=499844 was ok :)
alphacc

alphacc

2018-08-01 07:13

developer   ~0032413

Thanks for the feedback, closing this issue.

Issue History

Date Modified Username Field Change
2018-06-05 16:35 ndevos New Issue
2018-06-06 07:07 alphacc Note Added: 0032019
2018-06-06 12:15 alphacc Note Added: 0032020
2018-06-06 12:50 ndevos Note Added: 0032022
2018-07-18 11:12 gfidente Note Added: 0032300
2018-07-20 13:10 gfidente Note Added: 0032326
2018-07-20 13:43 alphacc Note Added: 0032327
2018-07-27 11:13 alphacc Note Added: 0032371
2018-07-31 13:46 ndevos Note Added: 0032407
2018-08-01 07:13 alphacc Status new => resolved
2018-08-01 07:13 alphacc Resolution open => fixed
2018-08-01 07:13 alphacc Note Added: 0032413