View Issue Details

IDProjectCategoryView StatusLast Update
0014955CentOS-7centos-releasepublic2018-06-28 20:13
Reporteriwienand 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionno change required 
Product Version7.5.1804 
Target VersionFixed in Version 
Summary0014955: /etc/rpm/macros.dist has "%dist .el7"
DescriptionIn centos-release-7-5.1804.el7.centos.2.x86_64 the file /etc/rpm/macros.dist sets dist to just ".el7"

---
-bash-4.2# rpm -qa | grep centos-release
centos-release-7-5.1804.el7.centos.2.x86_64
-bash-4.2# cat /etc/rpm/macros.dist | grep dist
# dist macros.
%dist .el7
---

I've noticed because my packages have started coming out with different names

It was "el7.centos" in the original package [1], the different one in updates is [2]

This may be correct behaviour and the original a bug? Anyway, I thought I'd report this so we can mark it one way or the other. Thanks

[1] http://mirror.centos.org/centos/7/os/x86_64/Packages/centos-release-7-5.1804.el7.centos.x86_64.rpm
[2] http://mirror.centos.org/centos/7/updates/x86_64/Packages/centos-release-7-5.1804.el7.centos.2.x86_64.rpm
TagsNo tags attached.
abrt_hash
URL

Activities

JohnnyHughes

JohnnyHughes

2018-06-15 10:20

administrator   ~0032093

Last edited: 2018-06-15 10:51

View 5 revisions

.el7.centos is used by the CentOS team to denote packages that are modified by the CentOS team.

.e7 is used by Red Hat as the default dist as RHEL. We should have been using .el7.

You can (and likely should) define a dist when you build packages. We do on all our builders.

Specifically, centos-release in the past decided to use the dist we included in on the RPM itself as the default dist for the distro .. but as we are now doing different centos-releases for all the diferent arches, and as the all need different versions (because they have different signing keys), we were using .el7.centos..i (for i386) , .el7.centos.a (for aarch64), ans .el7.centos.p (for ppc). So, we shifted the default dist in all the macros for all arches to .el7 .. which is what we use to denote a non-modified, normally built package.

if you would like to define a dist to be whatever you want .. you can use this in your .macros file:

%dist .el7.centos

OR with rpmbuild:

rpmbuild --define 'dist .el7.centos' <other options>

OR with mock:

mock -D "dist .el7.centos" <other options>

We should have been using .el7 all along:
https://serverfault.com/questions/688485/rpm-dist-tag-not-behaving-as-documented

iwienand

iwienand

2018-06-15 22:41

reporter   ~0032096

Thanks for the details. Setting a dist is certainly a possibility. I'm not too concerned, we just infrequently build some rpms in a CI environment, and the name changed when we updated the builders, so wanted to understand if we'd messed something up :)
seemethere

seemethere

2018-06-28 19:09

reporter   ~0032150

I noticed this as well, verified that it's been like that since 2014:

https://gist.github.com/seemethere/7fde5973d54355ed4690652d8a51829d

Is there a timeline on this getting resolved?
TrevorH

TrevorH

2018-06-28 20:12

manager   ~0032151

This IS the resolution. It should not have been .el7.centos. in the first place.

Issue History

Date Modified Username Field Change
2018-06-15 06:26 iwienand New Issue
2018-06-15 10:20 JohnnyHughes Note Added: 0032093
2018-06-15 10:48 JohnnyHughes Note Edited: 0032093 View Revisions
2018-06-15 10:49 JohnnyHughes Note Edited: 0032093 View Revisions
2018-06-15 10:49 JohnnyHughes Note Edited: 0032093 View Revisions
2018-06-15 10:51 JohnnyHughes Note Edited: 0032093 View Revisions
2018-06-15 10:52 JohnnyHughes Status new => feedback
2018-06-15 22:41 iwienand Note Added: 0032096
2018-06-15 22:41 iwienand Status feedback => assigned
2018-06-28 19:09 seemethere Note Added: 0032150
2018-06-28 20:12 TrevorH Note Added: 0032151
2018-06-28 20:13 TrevorH Status assigned => closed
2018-06-28 20:13 TrevorH Resolution open => no change required