View Issue Details

IDProjectCategoryView StatusLast Update
0014985CentOS-7selinux-policypublic2018-12-06 09:03
ReporterIHPG 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
PlatformOSOS Version7
Product Version 
Target VersionFixed in Version 
Summary0014985: SELinux is preventing /usr/libexec/geoclue from 'read' accesses on the file cgroup.
DescriptionDescription of problem:
When i login using xrdp.
SELinux is preventing /usr/libexec/geoclue from 'read' accesses on the file cgroup.

***** Plugin catchall (100. confidence) suggests **************************

If you believe that geoclue should be allowed read access on the cgroup file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'geoclue' --raw | audit2allow -M my-geoclue
# semodule -i my-geoclue.pp

Additional Information:
Source Context system_u:system_r:geoclue_t:s0
Target Context system_u:system_r:unconfined_service_t:s0
Target Objects cgroup [ file ]
Source geoclue
Source Path /usr/libexec/geoclue
Port <Unknown>
Host (removed)
Source RPM Packages
Target RPM Packages
Policy RPM selinux-policy-3.13.1-192.el7_5.3.noarch
Selinux Enabled True
Policy Type targeted
Enforcing Mode Enforcing
Host Name (removed)
Platform Linux (removed) 3.10.0-862.3.3.el7.x86_64 #1 SMP
                              Fri Jun 15 04:15:27 UTC 2018 x86_64 x86_64
Alert Count 6
First Seen 2018-06-25 17:06:04 +03
Last Seen 2018-06-25 18:05:43 +03
Local ID 9277293b-4539-4246-ab5a-112bb876095a

Raw Audit Messages
type=AVC msg=audit(1529939143.522:922): avc: denied { read } for pid=2808 comm="geoclue" name="cgroup" dev="proc" ino=279632 scontext=system_u:system_r:geoclue_t:s0 tcontext=system_u:system_r:unconfined_service_t:s0 tclass=file


Hash: geoclue,geoclue_t,unconfined_service_t,file,read

Version-Release number of selected component:
selinux-policy-3.13.1-192.el7_5.3.noarch
Additional Informationreporter: libreport-2.1.11.1
hashmarkername: setroubleshoot
kernel: 3.10.0-862.3.3.el7.x86_64
reproducible: Not sure how to reproduce the problem
type: libreport
TagsNo tags attached.
abrt_hashd406e3895e93de9e36fe8093fd011bb5f530510a479e340b282f183155cfa57a
URL

Activities

smr

smr

2018-12-06 08:48

reporter   ~0033239

Seems to be gone in CentOS 7.6 (1810).
gerdesas

gerdesas

2018-12-06 09:02

manager   ~0033240

Thank you for the report. I am going to close out this ticket.

Issue History

Date Modified Username Field Change
2018-06-26 09:11 IHPG New Issue
2018-12-06 08:48 smr Note Added: 0033239
2018-12-06 09:02 gerdesas Note Added: 0033240
2018-12-06 09:02 gerdesas Status new => resolved
2018-12-06 09:02 gerdesas Resolution open => fixed
2018-12-06 09:03 gerdesas Status resolved => closed