View Issue Details

IDProjectCategoryView StatusLast Update
0015104CentOS-7yumpublic2018-07-26 15:58
Reporterlhacorreia 
PriorityhighSeverityblockReproducibilityalways
Status newResolutionopen 
Product Version7.5.1804 
Target VersionFixed in Version 
Summary0015104: Cannot find a valid baseurl for repo
DescriptionCurrently, I am using the Centos 7.5 / 1804 version and can not update the system using yum. This is the first time I have problems with yum and I can not find the solution or the reason for this occurrence. In addition, the system report is vague and innocuous.
Steps To Reproduce# yum update
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile


 One of the configured repositories failed (Unknown),
 and yum doesn't have enough cached data to continue. At this point the only
 safe thing yum can do is fail. There are a few ways to work "fix" this:

     1. Contact the upstream for the repository and get them to fix the problem.

     2. Reconfigure the baseurl/etc. for the repository, to point to a working
        upstream. This is most often useful if you are using a newer
        distribution release than is supported by the repository (and the
        packages for the previous distribution release still work).

     3. Run the command with the repository temporarily disabled
            yum --disablerepo=<repoid> ...

     4. Disable the repository permanently, so yum won't use it by default. Yum
        will then just ignore the repository until you permanently enable it
        again or use --enablerepo for temporary usage:

            yum-config-manager --disable <repoid>
        or
            subscription-manager repos --disable=<repoid>

     5. Configure the failing repository to be skipped, if it is unavailable.
        Note that yum will try to contact the repo. when it runs most commands,
        so will have to try and fail each time (and thus. yum will be be much
        slower). If it is a very temporary problem though, this is often a nice
        compromise:

            yum-config-manager --save --setopt=<repoid>.skip_if_unavailable=true

Cannot find a valid baseurl for repo: base/$releasever/x86_64

Tagsrepo
abrt_hash
URL

Activities

lhacorreia

lhacorreia

2018-07-26 15:42

reporter   ~0032364

O papel do agente credenciado é vender os cartões e efetuar as cargas que serão aprovadas pelo Banco Rendimento. Todas as cargas e vendas possuem sistema de compliance seguindo normas do Banco Rendimento e Banco Central. Todos os agentes são credenciados pelo Banco Central para operar câmbio.
615/5000
I found the solution to my problem, but the suggestion in the forums of www.centos.org is to change the / etc / yum / vars / releasever:
echo 7 > / etc / yum / vars / releasever

This fixes the problem, but does not redirect the repository to 7.5.1804. When I change the releasever to 7.5.1804 the error returns.
TrevorH

TrevorH

2018-07-26 15:57

manager   ~0032365

Last edited: 2018-07-26 15:58

View 2 revisions

You should not change or hard code the releasever - in fact there should be no /etc/yum/vars/releasever file at all as yum already determines this from the version of the centos-release package.

The correct solution for your case is more likely to be to edit /etc/yum/vars/contentdir and change 'altarch' to 'centos' (no quotes) which is a known bug in the initial 7.5 centos-release package (subsequently fixed already).

Issue History

Date Modified Username Field Change
2018-07-25 22:15 lhacorreia New Issue
2018-07-25 22:15 lhacorreia Tag Attached: repo
2018-07-26 15:42 lhacorreia Note Added: 0032364
2018-07-26 15:57 TrevorH Note Added: 0032365
2018-07-26 15:58 TrevorH Note Edited: 0032365 View Revisions