View Issue Details

IDProjectCategoryView StatusLast Update
0015185BuildsysCi.centos.org Ecosystem Testingpublic2018-08-16 12:17
Reporterjmelis 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Summary0015185: Duffy says insufficient nodes in READY state
DescriptionDuffy is currently not handing out any nodes.

[devtools@slave04 ~]$ curl -vs "http://admin.ci.centos.org:8080/Node/get?key=$DUFFY_KEY"; echo
* About to connect() to admin.ci.centos.org port 8080 (#0)
* Trying 172.19.0.12...
* Connected to admin.ci.centos.org (172.19.0.12) port 8080 (#0)
> GET /Node/get?key=REDACTED HTTP/1.1
> User-Agent: curl/7.29.0
> Host: admin.ci.centos.org:8080
> Accept: */*
>
* HTTP 1.0, assume close after body
< HTTP/1.0 200 OK
< Content-Type: text/html; charset=utf-8
< Content-Length: 33
< Server: Werkzeug/0.14.1 Python/2.7.5
< Date: Thu, 16 Aug 2018 11:20:11 GMT
<
* Closing connection 0
Insufficient Nodes in READY State
Steps To Reproducecurl -vs "http://admin.ci.centos.org:8080/Node/get?key=$DUFFY_KEY
TagsNo tags attached.

Activities

arrfab

arrfab

2018-08-16 12:17

administrator   ~0032501

Now resolved but I'll sync with Brian about a fix for the race condition that is the root cause for this particular outage

Issue History

Date Modified Username Field Change
2018-08-16 11:23 jmelis New Issue
2018-08-16 12:17 arrfab Status new => resolved
2018-08-16 12:17 arrfab Resolution open => fixed
2018-08-16 12:17 arrfab Note Added: 0032501