View Issue Details

IDProjectCategoryView StatusLast Update
0015201CentOS-6firefoxpublic2019-09-04 05:53
Reporterisalsberg Assigned To 
Status resolvedResolutionno change required 
Product Version6.10 
Summary0015201: firefox 60.1 x86_64 killed by signal 11 (SIGSEGV)
DescriptionStarting a firefox instance From a VNC window (DISPLAY different than :0.0) it's always terminated.

I tried to start firefox from the launch panel and from the command line with the same results: killed by signal 11.

This happens with both: 60.1.0-5 and 60.1.0-6 versions.

Nevertheless, if you try to start firefox from the console ( (DISPLAY=:0.0) it works. The problem ONLY happens when you are in a VNC windows.

I downgraded firefox t0 version 52.8.0-1 and it works just fine from the Console or from a VNC window, so it is an issue related with version 60 (Quantum).
Steps To ReproduceOpen a VNC windows with gnome defaults.

Click on the firefox icon from the launch panel .

The same happens if you open a terminal and type firefox on the command line to execute the browser: you get the "Terminated" message.

NOTE: Do not try to replicate it from the console, because it works fine from there.
            The test must be executed from a VNC window.
Additional InformationI have kernel version: Linux CentOS6.localdomain 2.6.32-754.3.5.el6.x86_64 #1 SMP Tue Aug 14 20:46:41 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

I have tigervnc-server-1.1.0-24.el6.x86_64 installed as VNC Server




2018-08-22 03:51


ff error.png (109,280 bytes)   
ff error.png (109,280 bytes)   


2019-08-31 04:14

reporter   ~0035048

It was a Parallels issue, not CentOS.

This only happens with Parallels virtual machines running CentOS.

With CentOS running on Hyper-V or AWS Virtual machine environments, Firefox works just fine in VNC sessions.

So please, close this ticket.


2019-09-04 05:53

manager   ~0035063

Marking as solved per reporters feedback.

Issue History

Date Modified Username Field Change
2018-08-22 03:51 isalsberg New Issue
2018-08-22 03:51 isalsberg File Added: ff error.png
2018-08-22 03:51 isalsberg Tag Attached: firefox
2019-08-31 04:14 isalsberg Note Added: 0035048
2019-09-04 05:53 tigalch Status new => resolved
2019-09-04 05:53 tigalch Resolution open => no change required
2019-09-04 05:53 tigalch Note Added: 0035063