View Issue Details

IDProjectCategoryView StatusLast Update
0015438CentOS-7[All Projects] generalpublic2018-11-04 22:05
ReporterSylvainBoilard 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionwon't fix 
Product Version7.5.1804 
Target VersionFixed in Version 
Summary0015438: Package glfw-devel from EPEL does not depend on other package to provide OpenGL headers.
DescriptionHi,

Installing package glfw-devel from EPEL without pre-existing OpenGL headers makes the GLFW headers unusable.

It seems that the issue is caused by the package not depending on mesa-libGL-devel which provides the `gl.h` header needed in the `glfw3.h` file.

Cheers.
Steps To ReproduceOn a fresh CentOS 7 installation :

$ sudo yum install -y glfw-devel gcc
[...]
$ echo "#include <GLFW/glfw3.h>" > test.c
$ gcc -c test.c
In file included from test.c:1:0:
/usr/include/GLFW/glfw3.h:171:21: fatal error: GL/gl.h: No such file or directory
   #include <GL/gl.h>
                     ^
compilation terminated.
$ sudo yum install -y mesa-libGL-devel
[...]
$ gcc -c test.c
$ echo $?
0
TagsNo tags attached.
abrt_hash
URL

Activities

TrevorH

TrevorH

2018-11-04 22:05

manager   ~0033067

Sorry, wrong bug tracker. This is for CentOS bugs and EPEL uses bugzilla.redhat.com under the "Fedora EPEL" section.

Issue History

Date Modified Username Field Change
2018-11-04 21:58 SylvainBoilard New Issue
2018-11-04 22:05 TrevorH Status new => closed
2018-11-04 22:05 TrevorH Resolution open => won't fix
2018-11-04 22:05 TrevorH Note Added: 0033067