View Issue Details

IDProjectCategoryView StatusLast Update
0015477CentOS-7sane-backendspublic2018-11-28 23:01
Reportersomeotherguy 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
Product Version7.5.1804 
Target VersionFixed in Version 
Summary0015477: scanimage -L fails with Canon CanoScan N1240U
Descriptionsane-find-scanner finds scanner no problem. Running scanimage - L after rebooting the server detects the scanner, but debugging yields a "scanner not ready!!!" message, and the scanner can not be used. Re-running scanimage - L a second or subsequent time fails to detect the scanner at all.
Steps To Reproduceconnect Canon CanoScan N1240U scanner to a USB port, run scanimage -L
Additional InformationSearching the internet has come up with a post of a similar problem with this scanner with a different version of Linux:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=774333
from that thread:
"I've encountered similar on an up to date Jessie system: Canon
CanoScan N1240U/LiDE30 seen by sane-find-scanner but not recognized
at all by scanimage -L. Manually upgraded libsane, libsane-common
and sane-utils 1.0.24-3 to the 1.0.25-git20150210-utopic0 from
https://bugs.launchpad.net/~rolfbensch/+archive/ubuntu/sane-git/+build/6962214
and was able to use the scanner normally thereafter."

The Centos repository contains sane 1.0.24. The sane website lists 1.0.27 as the current stable version. How about updating the centos repository version?
TagsNo tags attached.
abrt_hash
URL

Activities

toracat

toracat

2018-11-21 18:38

manager   ~0033137

CentOS builds from upstream (RHEL) sources without code modifications. You'd need to file a request upstream to have changes made, so CentOS can pick them up.

RHEL 8 beta that has just been released has 1.0.27. It is publicly available. You may want to give it a try.
toracat

toracat

2018-11-22 19:41

manager   ~0033139

I have built, for my own use, sane-backends-1.0.27 on EL 7.6. You are welcome to give it a try. It works for me (LIDE 110). There is absolutely no warranty or guarantee or anything.

http://toracat.org/attic/misc/sane-backends/
someotherguy

someotherguy

2018-11-22 21:24

reporter   ~0033140

Most recently, following a recommendation received after posting a plea for help on the sane developer mailing list, I found that if I run "export SANE_WORKAROUND_USB=1" after rebooting my server, scanimage -L it will still fail the first time I run it, giving the debugging error "Scanner not ready!!!", but on subsequent attempts scanimage appears to work. Not an ideal situation, but I can live with it until a more recent version of sane-backends filters down into the Centos repository. Being a Linux newbie, running "yum install" and/or "yum update" is about the limit of my linux expertise.
toracat

toracat

2018-11-22 21:56

manager   ~0033141

OK, if you decided to wait, CentOS-8, which should come with 1.0.27, will be 7-8 months away.

By the way, installing the packages I offered is nothing but running "yum install". Download all rpm files into a directory and run:

yum localinstall *rpm
toracat

toracat

2018-11-28 23:01

manager   ~0033169

Expected to be fixed in EL 8. Will visit the issue once it is released. Closing the ticket for now.

Issue History

Date Modified Username Field Change
2018-11-20 04:01 someotherguy New Issue
2018-11-21 18:38 toracat Note Added: 0033137
2018-11-22 19:41 toracat Note Added: 0033139
2018-11-22 19:41 toracat Status new => assigned
2018-11-22 21:24 someotherguy Note Added: 0033140
2018-11-22 21:56 toracat Note Added: 0033141
2018-11-28 23:01 toracat Status assigned => resolved
2018-11-28 23:01 toracat Resolution open => no change required
2018-11-28 23:01 toracat Note Added: 0033169