View Issue Details

IDProjectCategoryView StatusLast Update
0015484CentOS-7selinux-policypublic2018-12-03 11:04
PrioritynormalSeverityminorReproducibilityhave not tried
Status newResolutionopen 
PlatformOSOS Version7
Product Version 
Target VersionFixed in Version 
Summary0015484: SELinux is preventing /usr/libexec/ibus-x11 from 'setattr' accesses on the directory cache.
DescriptionDescription of problem:
entered (as su) yum update --disablerepo=c7-media
SELinux is preventing /usr/libexec/ibus-x11 from 'setattr' accesses on the directory cache.

***** Plugin catchall (100. confidence) suggests **************************

If you believe that ibus-x11 should be allowed setattr access on the cache directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
allow this access for now by executing:
# ausearch -c 'ibus-x11' --raw | audit2allow -M my-ibusx11
# semodule -i my-ibusx11.pp

Additional Information:
Source Context system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context system_u:object_r:lib_t:s0
Target Objects cache [ dir ]
Source ibus-x11
Source Path /usr/libexec/ibus-x11
Port <Unknown>
Host (removed)
Source RPM Packages ibus-1.5.17-2.el7.x86_64
Target RPM Packages
Policy RPM selinux-policy-3.13.1-192.el7_5.6.noarch
Selinux Enabled True
Policy Type targeted
Enforcing Mode Enforcing
Host Name (removed)
Platform Linux (removed) 3.10.0-862.11.6.el7.x86_64 #1 SMP
                              Tue Aug 14 21:49:04 UTC 2018 x86_64 x86_64
Alert Count 47
First Seen 2018-11-22 14:03:02 EST
Last Seen 2018-11-22 14:05:21 EST
Local ID 939cac64-a520-43eb-9c28-e444e0635b4a

Raw Audit Messages
type=AVC msg=audit(1542913521.450:663): avc: denied { setattr } for pid=5628 comm="ibus-x11" name="cache" dev="dm-0" ino=33617201 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:lib_t:s0 tclass=dir

type=SYSCALL msg=audit(1542913521.450:663): arch=x86_64 syscall=chmod success=no exit=EACCES a0=10c6e70 a1=1ed a2=10c6e89 a3=1 items=0 ppid=1 pid=5628 auid=4294967295 uid=42 gid=42 euid=42 suid=42 fsuid=42 egid=42 sgid=42 fsgid=42 tty=(none) ses=4294967295 comm=ibus-x11 exe=/usr/libexec/ibus-x11 subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)

Hash: ibus-x11,xdm_t,lib_t,dir,setattr

Version-Release number of selected component:
Additional Informationreporter: libreport-
hashmarkername: setroubleshoot
kernel: 3.10.0-862.11.6.el7.x86_64
reproducible: Not sure how to reproduce the problem
type: libreport
TagsNo tags attached.




2018-12-03 11:04

reporter   ~0033195

Another user experienced a similar problem:

I ran Software Update and it popped up.

reporter: libreport-
hashmarkername: setroubleshoot
kernel: 3.10.0-862.14.4.el7.x86_64
package: selinux-policy-3.13.1-192.el7_5.6.noarch
reason: SELinux is preventing /usr/libexec/ibus-x11 from 'setattr' accesses on the directory cache.
reproducible: Not sure how to reproduce the problem
type: libreport

Issue History

Date Modified Username Field Change
2018-11-22 19:37 pdking77 New Issue
2018-12-03 11:04 atze Note Added: 0033195