View Issue Details

IDProjectCategoryView StatusLast Update
0015508CentOS-7selinux-policypublic2018-12-02 17:42
ReporterHACTL2007 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionwon't fix 
PlatformOSOS Version7
Product Version 
Target VersionFixed in Version 
Summary0015508: SELinux is preventing /usr/bin/python2.7 from 'read' accesses on the directory /var/crash/127.0.0.1-2018-09-28-15:15:40.
DescriptionDescription of problem:
SELinux is preventing /usr/bin/python2.7 from 'read' accesses on the directory /var/crash/127.0.0.1-2018-09-28-15:15:40.

***** Plugin catchall_labels (83.8 confidence) suggests *******************

If you want to allow python2.7 to have read access on the 127.0.0.1-2018-09-28-15:15:40 directory
Then you need to change the label on /var/crash/127.0.0.1-2018-09-28-15:15:40
Do
# semanage fcontext -a -t FILE_TYPE '/var/crash/127.0.0.1-2018-09-28-15:15:40'
where FILE_TYPE is one of the following: NetworkManager_etc_rw_t, NetworkManager_etc_t, abrt_etc_t, abrt_tmp_t, abrt_upload_watch_tmp_t, abrt_var_cache_t, abrt_var_log_t, abrt_var_run_t, aiccu_etc_t, alsa_etc_rw_t, anon_inodefs_t, antivirus_conf_t, asterisk_etc_t, autofs_t, bin_t, binfmt_misc_fs_t, bitlbee_conf_t, bluetooth_conf_t, boot_t, bootloader_etc_t, capifs_t, cephfs_t, cert_t, cgconfig_etc_t, cgroup_t, cgrules_etc_t, cifs_t, cluster_conf_t, cobbler_etc_t, condor_conf_t, container_config_t, container_file_t, couchdb_conf_t, courier_etc_t, cpucontrol_conf_t, cupsd_etc_t, cupsd_rw_etc_t, dbusd_etc_t, ddclient_etc_t, debugfs_t, device_t, devpts_t, dhcp_etc_t, dictd_etc_t, dnsmasq_etc_t, dosfs_t, dovecot_etc_t, ecryptfs_t, efivarfs_t, etc_mail_t, etc_runtime_t, etc_t, exports_t, fetchmail_etc_t, file_context_t, fingerd_etc_t, firewalld_etc_rw_t, firstboot_etc_t, fonts_cache_t, fonts_t, ftpd_etc_t, fusefs_t, gconf_etc_t, gdomap_conf_t, getty_etc_t, gpm_conf_t, hddtemp_etc_t, hostname_etc_t, httpd_config_t, httpd_modules_t, hugetlbfs_t, innd_etc_t, irc_conf_t, irssi_etc_t, iso9660_t, kdump_crash_t, kdump_etc_t, kmscon_conf_t, krb5_conf_t, krb5kdc_conf_t, l2tp_conf_t, lib_t, likewise_etc_t, lircd_etc_t, locale_t, lvm_etc_t, machineid_t, man_cache_t, man_t, mcelog_etc_t, mdadm_conf_t, minidlna_conf_t, minissdpd_conf_t, mnt_t, mock_etc_t, mock_var_lib_t, modules_conf_t, modules_object_t, mozilla_conf_t, mpd_etc_t, mplayer_etc_t, mrtg_etc_t, mscan_etc_t, munin_etc_t, mysqld_etc_t, nagios_etc_t, named_conf_t, net_conf_t, nfs_t, nfsd_fs_t, nrpe_etc_t, nscd_var_run_t, nslcd_conf_t, ntop_etc_t, ntp_conf_t, nut_conf_t, onload_fs_t, opendnssec_conf_t, openvpn_etc_rw_t, openvpn_etc_t, openvswitch_rw_t, oracleasm_conf_t, oracleasmfs_t, pads_config_t, pegasus_conf_t, pingd_etc_t, piranha_etc_rw_t, piranha_web_conf_t, polipo_etc_t, portreserve_etc_t, postfix_etc_t, postfix_postdrop_t, postgresql_etc_t, postgrey_etc_t, pppd_etc_t, prelude_correlator_config_t, printconf_t, proc_t, psad_etc_t, pstore_t, ptal_etc_t, public_content_rw_t, public_content_t, puppet_etc_t, qmail_etc_t, radiusd_etc_t, radvd_etc_t, ramfs_t, redis_conf_t, removable_t, rhnsd_conf_t, root_t, rpc_pipefs_t, rpm_var_cache_t, rpm_var_lib_t, rpm_var_run_t, rsync_etc_t, samba_etc_t, sanlock_conf_t, security_t, shell_exec_t, shorewall_etc_t, slapd_etc_t, snapperd_conf_t, snort_etc_t, soundd_etc_t, spamd_etc_t, spufs_t, squid_conf_t, src_t, sssd_conf_t, sssd_public_t, stunnel_etc_t, svc_conf_t, sysfs_t, syslog_conf_t, syslogd_var_run_t, system_conf_t, system_db_t, systemd_hwdb_etc_t, sysv_t, textrel_shlib_t, tftpd_etc_t, tmp_t, tmpfs_t, tor_etc_t, tuned_etc_t, tuned_rw_etc_t, udev_etc_t, udev_var_run_t, ulogd_etc_t, usbfs_t, userhelper_conf_t, usr_t, var_lib_t, var_log_t, var_run_t, var_spool_t, var_t, varnishd_etc_t, virt_etc_t, virtlogd_etc_t, vmblock_t, vmware_sys_conf_t, vxfs_t, webalizer_etc_t, xdm_etc_t, xdm_rw_etc_t, xenfs_t, xserver_etc_t, ypserv_conf_t, zarafa_etc_t, zebra_conf_t.
Then execute:
restorecon -v '/var/crash/127.0.0.1-2018-09-28-15:15:40'


***** Plugin catchall (17.1 confidence) suggests **************************

If you believe that python2.7 should be allowed read access on the 127.0.0.1-2018-09-28-15:15:40 directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'abrt-harvest-vm' --raw | audit2allow -M my-abrtharvestvm
# semodule -i my-abrtharvestvm.pp

Additional Information:
Source Context system_u:system_r:abrt_t:s0-s0:c0.c1023
Target Context system_u:object_r:unlabeled_t:s0
Target Objects /var/crash/127.0.0.1-2018-09-28-15:15:40 [ dir ]
Source abrt-harvest-vm
Source Path /usr/bin/python2.7
Port <Unknown>
Host (removed)
Source RPM Packages python-2.7.5-69.el7_5.x86_64
Target RPM Packages
Policy RPM selinux-policy-3.13.1-192.el7_5.6.noarch
Selinux Enabled True
Policy Type targeted
Enforcing Mode Enforcing
Host Name (removed)
Platform Linux (removed) 3.10.0-862.14.4.el7.x86_64 #1 SMP
                              Wed Sep 26 15:12:11 UTC 2018 x86_64 x86_64
Alert Count 36
First Seen 2018-09-20 11:03:24 HKT
Last Seen 2018-11-30 14:01:01 HKT
Local ID 1377cdb6-941f-4a19-b7eb-81748a03fb53

Raw Audit Messages
type=AVC msg=audit(1543557661.404:137): avc: denied { read } for pid=2289 comm="abrt-harvest-vm" name="127.0.0.1-2018-09-28-15:15:40" dev="dm-5" ino=12508 scontext=system_u:system_r:abrt_t:s0-s0:c0.c1023 tcontext=system_u:object_r:unlabeled_t:s0 tclass=dir


type=SYSCALL msg=audit(1543557661.404:137): arch=x86_64 syscall=openat success=no exit=EACCES a0=ffffffffffffff9c a1=101d400 a2=90800 a3=0 items=0 ppid=1 pid=2289 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=abrt-harvest-vm exe=/usr/bin/python2.7 subj=system_u:system_r:abrt_t:s0-s0:c0.c1023 key=(null)

Hash: abrt-harvest-vm,abrt_t,unlabeled_t,dir,read

Version-Release number of selected component:
selinux-policy-3.13.1-192.el7_5.6.noarch
Additional Informationreporter: libreport-2.1.11.1
hashmarkername: setroubleshoot
kernel: 3.10.0-862.14.4.el7.x86_64
reproducible: Not sure how to reproduce the problem
type: libreport
TagsNo tags attached.
abrt_hash32b7fca161898952981a306a608704e55b3fe95eb6326cbb518c5c2a74396be9
URL

Activities

TrevorH

TrevorH

2018-12-02 17:42

manager   ~0033190

This is not a bug. Your filesystem is mislabeled. Nothing should have context of

 Target Context system_u:object_r:unlabeled_t:s0

You need to fix that. Usually this is done by `touch /.autorelabel;reboot`

Issue History

Date Modified Username Field Change
2018-12-02 17:34 HACTL2007 New Issue
2018-12-02 17:42 TrevorH Status new => closed
2018-12-02 17:42 TrevorH Resolution open => won't fix
2018-12-02 17:42 TrevorH Note Added: 0033190