View Issue Details

IDProjectCategoryView StatusLast Update
0015520CentOS-7dos2unixpublic2018-12-04 05:10
ReporterNo Sir 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionno change required 
Product Version7.5.1804 
Target VersionFixed in Version 
Summary0015520: version of dos2unix doesnt support --info / -i option
DescriptionCan Someone please update the dos2unix package shipped in CentOS 7 to something that's at least from the last 4 years?

The current version 6.0.3 does not even support the --info option. Support for this in dos2unix was added in version 7.1 back in October of 2014.

Their Changelog:

2014-10-06: Version 7.1

  * New: Option -i, --info to print file information.
    This new option prints number of DOS, Unix, and Mac line breaks, the byte
    order mark, and if the file is text or binary. And it can print the names
    of files that would be converted.

As a sysadmin who often has to write scripts, I was very disappointed to find such an old version shipped with what is the "latest" version of CentOS (at the time of writing this).

The current version is so old, I cant even use the --info command line parameter, ridiculous.

Please for the love of god, stop clinging onto crusty versions of software. Please update this package.
TagsNo tags attached.
abrt_hash
URL

Activities

jrd

jrd

2018-12-04 05:09

manager   ~0033201

CentOS is a one-to-one rebuild of the upstream RHEL public sources. Requests for updates of platform contents need to be made to RH via https://bugzilla.redhat.com. If RH updates the package we will inherit those updates. As this is not a bug I am closing this ticket out.

Issue History

Date Modified Username Field Change
2018-12-04 04:44 No Sir New Issue
2018-12-04 05:09 jrd Note Added: 0033201
2018-12-04 05:10 jrd Status new => closed
2018-12-04 05:10 jrd Resolution open => no change required