View Issue Details

IDProjectCategoryView StatusLast Update
0015605CentOS-7glusterfspublic2018-12-18 10:10
Reportervolnei 
PriorityhighSeveritymajorReproducibilityalways
Status newResolutionopen 
Product Version7.5.1804 
Target VersionFixed in Version 
Summary0015605: cannot upgrade to new version of glusterfs - CentOS Linux release 7.6.1810 (Core)
DescriptionRunning "yum upgrade" produces errors showing that there is a newer version of glusterfs in (base) than the
one I have installed from (@centos-gluster38). The problem is that no glusterfs package is available
for 3.8.15-2.el7

Thanks.
Steps To Reproduceyum update
Plugins loaded: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
epel / x86_64 / metalink | 3.3 kB 00:00:00
 * base: linorg.usp.br
 * elrepo: mirror.cedia.org.ec
 * epel: mirror.cedia.org.ec
 * extras: linorg.usp.br
 * updates: linorg.usp.br
base | 3.6 kB 00:00:00
elrepo | 2.9 kB 00:00:00
epel | 3.2 kB 00:00:00
extras | 3.4 kB 00:00:00
gf | 2.9 kB 00:00:00
google-earth | 1.3 kB 00:00:00
treasuredata | 2.9 kB 00:00:00
unikmhz-accel-ppp | 3.0 kB 00:00:00
updates | 3.4 kB 00:00:00
Resolving dependencies
-> Running transaction verification
---> The glusterfs.x86_64 package 0: 3.8.15-2.el7 will be updated
-> Processing dependency: glusterfs (x86-64) = 3.8.15-2.el7 for the package: glusterfs-server-3.8.15-2.el7.x86_64
---> The package glusterfs.x86_64 0: 3.12.2-18.el7 will be an update
---> The glusterfs-api.x86_64 package 0: 3.8.15-2.el7 will be updated
-> Processing Dependency: glusterfs-api (x86-64) = 3.8.15-2.el7 for the package: glusterfs-server-3.8.15-2.el7.x86_64
---> The glusterfs-api.x86_64 package 0: 3.12.2-18.el7 will be an update
---> The glusterfs-cli.x86_64 package 0: 3.8.15-2.el7 will be updated
-> Processing Dependency: glusterfs-cli (x86-64) = 3.8.15-2.el7 for the package: glusterfs-server-3.8.15-2.el7.x86_64
---> The glusterfs-cli.x86_64 package 0: 3.12.2-18.el7 will be an update
---> The package glusterfs-client-xlators.x86_64 0: 3.8.15-2.el7 will be updated
-> Processing Dependency: glusterfs-client-xlators (x86-64) = 3.8.15-2.el7 for the package: glusterfs-server-3.8.15-2.el7.x86_64
---> The package glusterfs-client-xlators.x86_64 0: 3.12.2-18.el7 will be an update
---> The glusterfs-fuse.x86_64 package 0: 3.8.15-2.el7 will be updated
-> Processing Dependency: glusterfs-fuse (x86-64) = 3.8.15-2.el7 for the package: glusterfs-server-3.8.15-2.el7.x86_64
---> The glusterfs-fuse.x86_64 package 0: 3.12.2-18.el7 will be an update
---> The glusterfs-libs.x86_64 package 0: 3.8.15-2.el7 will be updated
-> Processing Dependency: glusterfs-libs (x86-64) = 3.8.15-2.el7 for the package: glusterfs-server-3.8.15-2.el7.x86_64
---> The glusterfs-libs.x86_64 package 0: 3.12.2-18.el7 will be an update
---> The package python2-cached_property.noarch 0: 1.3.0-7.el7 will be updated
---> The package python2-cached_property.noarch 0: 1.5.1-1.el7 will be an update
---> The package python34-cached_property.noarch 0: 1.3.0-7.el7 will be updated
---> The package python34-cached_property.noarch 0: 1.5.1-1.el7 will be an update
-> Resolved dependencies resolution
Error: Package: glusterfs-server-3.8.15-2.el7.x86_64 (@ centos-gluster38)
           Requires: glusterfs-libs (x86-64) = 3.8.15-2.el7
           Removing: glusterfs-libs-3.8.15-2.el7.x86_64 (@ centos-gluster38)
               glusterfs-libs (x86-64) = 3.8.15-2.el7
           Updated by: glusterfs-libs-3.12.2-18.el7.x86_64 (base)
               glusterfs-libs (x86-64) = 3.12.2-18.el7
Error: Package: glusterfs-server-3.8.15-2.el7.x86_64 (@ centos-gluster38)
           Requires: glusterfs-fuse (x86-64) = 3.8.15-2.el7
           Removing: glusterfs-fuse-3.8.15-2.el7.x86_64 (@ centos-gluster38)
               glusterfs-fuse (x86-64) = 3.8.15-2.el7
           Updated by: glusterfs-fuse-3.12.2-18.el7.x86_64 (base)
               glusterfs-fuse (x86-64) = 3.12.2-18.el7
Error: Package: glusterfs-server-3.8.15-2.el7.x86_64 (@ centos-gluster38)
           Requires: glusterfs-cli (x86-64) = 3.8.15-2.el7
           Removing: glusterfs-cli-3.8.15-2.el7.x86_64 (@ centos-gluster38)
               glusterfs-cli (x86-64) = 3.8
TagsNo tags attached.
abrt_hash
URL

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2018-12-18 10:10 volnei New Issue