View Issue Details

IDProjectCategoryView StatusLast Update
0015625CentOS-7[All Projects] generalpublic2019-01-22 01:39
Status newResolutionopen 
Product Version7.6.1810 
Target VersionFixed in Version 
Summary0015625: This bug affects CentOS 7.6. There is a garbled screen just before log in.
DescriptionThis bug is for CentOS 7.6 1810. But I can not select that in the list since it is not available.
I am using a laptop with Ati Radeon graphics, I am using the open source driver Xorg for that. 5470 is the Ati Radeon proprietary driver version. I am not using that.
In CentOS 7.5 and previous versions. this bug was not present. It was present in previous and the current version of Fedora (Xorg) not Wayland. But it was fixed after installing Fedora updates.
There is a garbled screen much like a tv which has no signal just before login.
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Park [Mobility Radeon HD 5430/5450/5470] [1002:68e0] (prog-if 00 [VGA controller])
    Subsystem: Sony Corporation Device [104d:9071]
    Flags: bus master, fast devsel, latency 0, IRQ 27
    Memory at e0000000 (64-bit, prefetchable) [size=256M]
    Memory at f0020000 (64-bit, non-prefetchable) [size=128K]
    I/O ports at d000 [size=256]
    Expansion ROM at f0000000 [disabled] [size=128K]
    Capabilities: <access denied>
    Kernel driver in use: radeon
    Kernel modules: radeon

01:00.1 Audio device [0403]: Advanced Micro Devices, Inc. [AMD/ATI] Cedar HDMI Audio [Radeon HD 5400/6300/7300 Series] [1002:aa68]
    Subsystem: Sony Corporation Device [104d:9071]
This is information for my graphic card.
Note: After the persistence of the bug I tried to install the proprietary driver to see if that would solve the problem, but it didn't, or maybe I did not install it properly. Otherwise the open source drivers work fine, except for this issue.
Steps To ReproduceNone, this is machine specific.I have not encountered this bug in a machine with intel graphics. Just start CentOS.
TagsNo tags attached.




2018-12-22 12:57

developer   ~0033431

Can you post the boot command line? I know I have seen that in the past and I have a similar card (01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Madison [Mobility Radeon HD 5730 / 6570M] [1002:68c0]).
IIRC, I was only getting this if I was booting without "rhgb quiet".
Maybe it is time to acually fix this ;)


2018-12-22 13:01

manager   ~0033432

It could also be to do with a problem documented in the 7.6 release notes with a bypass listed in


2019-01-22 00:47

reporter   ~0033651

Fix worked for me on Dell 980 with ATI5450.
Also KDE plasma (failsafe) worked well enough to access internet to find solution.


2019-01-22 01:39

manager   ~0033652

Related RHBZs: (RHEL 7.6) (Fedora, but RHEL mentioned)

Issue History

Date Modified Username Field Change
2018-12-21 11:18 ervindine New Issue
2018-12-21 14:33 toracat Product Version 7.5.1804 => 7.6.1810
2018-12-22 12:57 pgreco Note Added: 0033431
2018-12-22 13:01 TrevorH Note Added: 0033432
2019-01-22 00:47 terry1738 Note Added: 0033651
2019-01-22 01:39 toracat Note Added: 0033652