View Issue Details

IDProjectCategoryView StatusLast Update
0015629CentOS-7cloud-initpublic2019-09-20 21:54
Reporterricharson 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformCentOSOSLinuxOS Version7.6.18.10
Product Version 
Target VersionFixed in Version7.7-1908 
Summary0015629: cloud-init removes 'NOZEROCONF=yes' from /etc/sysconfig/network
DescriptionA few days ago I stumbled upon a bug in cloud-init 18.2 which prevents CentOS 7 VMs to connect to old (IceHouse in my case) OpenStack's metadata service.

It's been reported since 2018/11/26 here:
https://bugzilla.redhat.com/show_bug.cgi?id=1653131

I applied a patch to cloud-init that I found in https://bugzilla.redhat.com/show_bug.cgi?id=1558641 and it worked for me.

I notified of this patch in RH's BZ#1653131 and they're considering including it in cloud-init 18.2 (maybe even upstreaming it).
Steps To ReproduceSimply upgrade cloud-init to 18.2 and reboot.
TagsNo tags attached.
abrt_hash
URL

Activities

pgreco

pgreco

2019-01-06 12:18

developer   ~0033523

@richarson we did a build for a fasttrack candidate that is available here https://buildlogs.centos.org/c7-fasttrack.x86_64/cloud-init/20190106113327/18.2-1.el7.1.0.1.x86_64/ , please test it and let us know if it works for you so we can push it to the right repo.

Thanks.
Pablo.
richarson

richarson

2019-01-07 18:46

reporter   ~0033531

Hi @pgreco, I'm on vacation at the moment, I can test the new version next week.

Thanks!
ltosolini

ltosolini

2019-01-25 08:44

reporter   ~0033673

Hello there!
I am facing exactly same problem so I have tried the build above https://buildlogs.centos.org/c7-fasttrack.x86_64/cloud-init/20190106113327/18.2-1.el7.1.0.1.x86_64/
but I can not see any improvement in behavior.
'NOZEROCONF=yes' is removed from /etc/sysconfig/network
route 169.254.0.0 is added preventing communication with the metadata service.

rpm -q --info cloud-init
Name : cloud-init
Version : 18.2
Release : 1.el7.1.0.1
Architecture: x86_64
Install Date: Fri 25 Jan 2019 08:24:38 AM UTC
Group : System Environment/Base
Size : 2792483
License : GPLv3
Signature : (none)
Source RPM : cloud-init-18.2-1.el7.1.0.1.src.rpm
Build Date : Sun 06 Jan 2019 11:34:47 AM UTC
Build Host : x86-01.bsys.centos.org
Relocations : (not relocatable)
Packager : CentOS BuildSystem <http://bugs.centos.org>
Vendor : CentOS
URL : http://launchpad.net/cloud-init
Summary : Cloud instance init scripts
richarson

richarson

2019-01-25 18:50

reporter   ~0033681

Is this update included in cloud-init-18.2-1.el7.centos.1.x86_64? Because I cannot reproduce the bug anymore.

I also downgraded from my version to 18.2-1.el7.centos.1.x86_64 and then to 18.2-1.el7.centos but /etc/sysconfig/network was not modified.

@ltosolini you probably have to re-add 'NOZEROCONF=yes' to /etc/sysconfig/network if it was removed after the upgrade from 0.7.9-9.el7.centos.6, the new version shouldn't touch that file anymore.
pgreco

pgreco

2019-01-26 11:23

developer   ~0033690

@richarson the fix is not included in cloud-init.18.2-1.el7.centos.1.x86_64 from updates, but it is included in cloud-init.18.2-1.el7.1.0.1.x86_64 from fasttrack repo
ltosolini

ltosolini

2019-02-02 18:57

reporter   ~0033760

I confirm cloud-init-18.2-1.el7.1.0.1.x86_64 is working fine for me!
BTW, does anybody know if same bug is also affecting RHEL?
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
[root@contrail-15629 ~]# ip route
default via 100.64.10.1 dev eth0
100.64.10.0/24 dev eth0 proto kernel scope link src 100.64.10.3

[root@contrail-15629 ~]# cat /etc/sysconfig/network
NOZEROCONF=yes
# Created by cloud-init on instance boot automatically, do not edit.
#
NETWORKING=yes

[root@contrail-15629 ~]# ip route
default via 100.64.10.1 dev eth0
100.64.10.0/24 dev eth0 proto kernel scope link src 100.64.10.3

[root@contrail-15629 ~]# rpm -qa cloud-init
cloud-init-18.2-1.el7.1.0.1.x86_64
richarson

richarson

2019-02-05 14:06

reporter   ~0033779

@ltosolini, yes it affects RHEL, I provided a BZ# in my original report :)
richarson

richarson

2019-03-29 15:28

reporter   ~0034131

OK, I've finally got another couple of clouds presenting this bug so I was abel to test cloud-init-18.2-1.el7.1.0.1 from fasttrack, it works as advertised :)

That said, Miroslav Rezanina from RedHat reports that they will include the fix in cloud-init-18.2-5.el7 (https://bugzilla.redhat.com/show_bug.cgi?id=1653131#c36) so you might want to wait for that version to arrive.

Thanks!
pgreco

pgreco

2019-09-20 21:54

developer   ~0035174

Closing, this was solved in 7.7.1908

Issue History

Date Modified Username Field Change
2018-12-21 20:19 richarson New Issue
2018-12-22 12:27 pgreco Status new => assigned
2019-01-05 08:36 toracat Category -OTHER => cloud-init
2019-01-06 12:18 pgreco Note Added: 0033523
2019-01-07 18:46 richarson Note Added: 0033531
2019-01-25 08:44 ltosolini Note Added: 0033673
2019-01-25 18:50 richarson Note Added: 0033681
2019-01-26 11:23 pgreco Note Added: 0033690
2019-02-02 18:57 ltosolini Note Added: 0033760
2019-02-05 14:06 richarson Note Added: 0033779
2019-03-29 15:28 richarson Note Added: 0034131
2019-09-20 21:54 pgreco Status assigned => closed
2019-09-20 21:54 pgreco Resolution open => fixed
2019-09-20 21:54 pgreco Fixed in Version => 7.7-1908
2019-09-20 21:54 pgreco Note Added: 0035174