View Issue Details

IDProjectCategoryView StatusLast Update
0015688CentOS-7net-snmppublic2019-01-10 10:04
Reporterfebi881 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionwon't fix 
Product Version7.4.1708 
Target VersionFixed in Version 
Summary0015688: variable declared inside /etc/sysconfig/snmpd is throwing the error
DescriptionI am managing the /etc/sysconfig/snmpd file from puppet and we have two management IPs which will be populated from puppet.

The content of /etc/sysconfig/snmpd is as below

MGMTIPS="192.168.17.108 192.168.17.109"
OPTIONS='-LS 0-4 d -Lf /dev/null -p /var/run/snmpd.pid -a 127.0.0.1 $MGMTIPS'

But when I start the snmp service I am getting the error "Error opening specified endpoint "$MGMTIPS"" Looks like the variable value is not parsing.

Kindly advise.

Steps To Reproduce1. Declare a variable with two IPs inside /etc/sysconfig/snmpd file and use the variable inside OPTIONS
TagsNo tags attached.
abrt_hash
URL

Activities

TrevorH

TrevorH

2019-01-10 10:04

manager   ~0033554

Your OPTIONS line is enclosed in single quotes which stops variable substitution from taking place.

Issue History

Date Modified Username Field Change
2019-01-10 09:47 febi881 New Issue
2019-01-10 10:04 TrevorH Status new => closed
2019-01-10 10:04 TrevorH Resolution open => won't fix
2019-01-10 10:04 TrevorH Note Added: 0033554