View Issue Details

IDProjectCategoryView StatusLast Update
0015737CentOS-7-OTHERpublic2019-01-23 14:21
Reporterhetz 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
Product Version7.6.1810 
Target VersionFixed in Version 
Summary0015737: Cannot boot ISO using Disk on Key
DescriptionTrying to boot the latest CentOS on old IBM X3550 M3 servers shows an error (for 2 seconds)

Failed to set MokListRT: Invalid Parameter
Something has gone seriously wrong: import_mok_state() failed:
Invalid Parameter

And then the machine powers off.
Steps To ReproduceUse any tool (Rufus) to install the ISO to a Disk on key, and boot an IBM M3 server. When the USB storage boots starts, it shows the message and it powers off the machine.
Additional InformationThere is a so called "solution" which involved copying a file to the GRUB partition, see here: https://angrysysadmins.tech/index.php/2018/12/grassyloki/centos-7-failed-set-moklistrt/ but I'm not sure this will help with the ISO installation.

The only workaround to this problem is to use the IMM (the IBM's IPMI) to mount remotely the ISO as a virtual DVD and select "Classic Mode" to boot - and then it works.
Tagsboot, IBM, M3
abrt_hash
URL

Relationships

duplicate of 0015522 resolvedarrfab Machine with older uefi fw doesn't boot with newer shim (like on Apple 2008 iMac) 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2019-01-23 13:12 hetz New Issue
2019-01-23 13:12 hetz Tag Attached: boot
2019-01-23 13:12 hetz Tag Attached: IBM
2019-01-23 13:12 hetz Tag Attached: M3
2019-01-23 14:21 TrevorH Status new => closed
2019-01-23 14:21 TrevorH Resolution open => duplicate
2019-01-23 14:21 TrevorH Relationship added duplicate of 0015522