View Issue Details

IDProjectCategoryView StatusLast Update
0015744CentOS-7libvirtpublic2019-01-27 19:57
Reporterteknohippie 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionno change required 
Product Version7.6.1810 
Target VersionFixed in Version 
Summary0015744: libvirtd.service fails to start
DescriptionReturn of command

# systemctl status libvirtd.service

--------------------------------------------------------------------------------------------------------------------------------------------

‚óŹ libvirtd.service - Virtualization daemon
   Loaded: loaded (/usr/lib/systemd/system/libvirtd.service; disabled; vendor preset: enabled)
   Active: failed (Result: start-limit) since Thu 2019-01-24 21:54:04 EST; 1min 11s ago
     Docs: man:libvirtd(8)
           https://libvirt.org
 Main PID: 21263 (code=exited, status=3)

Jan 24 21:54:04 CentOS7Server systemd[1]: Failed to start Virtualization daemon.
Jan 24 21:54:04 CentOS7Server systemd[1]: Unit libvirtd.service entered failed state.
Jan 24 21:54:04 CentOS7Server systemd[1]: libvirtd.service failed.
Jan 24 21:54:04 CentOS7Server systemd[1]: libvirtd.service holdoff time over, scheduling restart.
Jan 24 21:54:04 CentOS7Server systemd[1]: Stopped Virtualization daemon.
Jan 24 21:54:04 CentOS7Server systemd[1]: start request repeated too quickly for libvirtd.service
Jan 24 21:54:04 CentOS7Server systemd[1]: Failed to start Virtualization daemon.
Jan 24 21:54:04 CentOS7Server systemd[1]: Unit libvirtd.service entered failed state.
Jan 24 21:54:04 CentOS7Server systemd[1]: libvirtd.service failed.

--------------------------------------------------------------------------------------------------------------------------------------------

Return of command

# journalctl --no-pager -u libvirtd.service

--------------------------------------------------------------------------------------------------------------------------------------------

Jan 24 22:00:45 CentOS7Server systemd[1]: Starting Virtualization daemon...
Jan 24 22:00:45 CentOS7Server libvirtd[21780]: 2019-01-25 03:00:45.783+0000: 21780: info : libvirt version: 4.5.0, package: 10.el7_6.3 (CentOS BuildSystem <http://bugs.centos.org>, 2018-11-28-20:51:39, x86-01.bsys.centos.org)
Jan 24 22:00:45 CentOS7Server libvirtd[21780]: 2019-01-25 03:00:45.783+0000: 21780: info : hostname: CentOS7Server
Jan 24 22:00:45 CentOS7Server libvirtd[21780]: 2019-01-25 03:00:45.783+0000: 21780: error : virModuleLoadFile:53 : internal error: Failed to load module '/usr/lib64/libvirt/connection-driver/libvirt_driver_interface.so': libexslt.so.0: cannot open shared object file: No such file or directory
Jan 24 22:00:45 CentOS7Server systemd[1]: libvirtd.service: main process exited, code=exited, status=3/NOTIMPLEMENTED
Jan 24 22:00:45 CentOS7Server systemd[1]: Failed to start Virtualization daemon.
Jan 24 22:00:45 CentOS7Server systemd[1]: Unit libvirtd.service entered failed state.
Jan 24 22:00:45 CentOS7Server systemd[1]: libvirtd.service failed.
Jan 24 22:00:46 CentOS7Server systemd[1]: libvirtd.service holdoff time over, scheduling restart.
Jan 24 22:00:46 CentOS7Server systemd[1]: Stopped Virtualization daemon.
Jan 24 22:00:46 CentOS7Server systemd[1]: Starting Virtualization daemon...
Jan 24 22:00:46 CentOS7Server libvirtd[21792]: 2019-01-25 03:00:46.066+0000: 21792: info : libvirt version: 4.5.0, package: 10.el7_6.3 (CentOS BuildSystem <http://bugs.centos.org>, 2018-11-28-20:51:39, x86-01.bsys.centos.org)
Jan 24 22:00:46 CentOS7Server libvirtd[21792]: 2019-01-25 03:00:46.066+0000: 21792: info : hostname: CentOS7Server
Jan 24 22:00:46 CentOS7Server libvirtd[21792]: 2019-01-25 03:00:46.066+0000: 21792: error : virModuleLoadFile:53 : internal error: Failed to load module '/usr/lib64/libvirt/connection-driver/libvirt_driver_interface.so': libexslt.so.0: cannot open shared object file: No such file or directory
Jan 24 22:00:46 CentOS7Server systemd[1]: libvirtd.service: main process exited, code=exited, status=3/NOTIMPLEMENTED
Jan 24 22:00:46 CentOS7Server systemd[1]: Failed to start Virtualization daemon.
Jan 24 22:00:46 CentOS7Server systemd[1]: Unit libvirtd.service entered failed state.
Jan 24 22:00:46 CentOS7Server systemd[1]: libvirtd.service failed.
Jan 24 22:00:46 CentOS7Server systemd[1]: libvirtd.service holdoff time over, scheduling restart.
Jan 24 22:00:46 CentOS7Server systemd[1]: Stopped Virtualization daemon.
Jan 24 22:00:46 CentOS7Server systemd[1]: Starting Virtualization daemon...
Jan 24 22:00:46 CentOS7Server libvirtd[21813]: 2019-01-25 03:00:46.316+0000: 21813: info : libvirt version: 4.5.0, package: 10.el7_6.3 (CentOS BuildSystem <http://bugs.centos.org>, 2018-11-28-20:51:39, x86-01.bsys.centos.org)
Jan 24 22:00:46 CentOS7Server libvirtd[21813]: 2019-01-25 03:00:46.316+0000: 21813: info : hostname: CentOS7Server
Jan 24 22:00:46 CentOS7Server libvirtd[21813]: 2019-01-25 03:00:46.316+0000: 21813: error : virModuleLoadFile:53 : internal error: Failed to load module '/usr/lib64/libvirt/connection-driver/libvirt_driver_interface.so': libexslt.so.0: cannot open shared object file: No such file or directory
Jan 24 22:00:46 CentOS7Server systemd[1]: libvirtd.service: main process exited, code=exited, status=3/NOTIMPLEMENTED
Jan 24 22:00:46 CentOS7Server systemd[1]: Failed to start Virtualization daemon.
Jan 24 22:00:46 CentOS7Server systemd[1]: Unit libvirtd.service entered failed state.
Jan 24 22:00:46 CentOS7Server systemd[1]: libvirtd.service failed.
Jan 24 22:00:46 CentOS7Server systemd[1]: libvirtd.service holdoff time over, scheduling restart.
Jan 24 22:00:46 CentOS7Server systemd[1]: Stopped Virtualization daemon.
Jan 24 22:00:46 CentOS7Server systemd[1]: Starting Virtualization daemon...
Jan 24 22:00:46 CentOS7Server libvirtd[21825]: 2019-01-25 03:00:46.565+0000: 21825: info : libvirt version: 4.5.0, package: 10.el7_6.3 (CentOS BuildSystem <http://bugs.centos.org>, 2018-11-28-20:51:39, x86-01.bsys.centos.org)
Jan 24 22:00:46 CentOS7Server libvirtd[21825]: 2019-01-25 03:00:46.565+0000: 21825: info : hostname: CentOS7Server
Jan 24 22:00:46 CentOS7Server libvirtd[21825]: 2019-01-25 03:00:46.565+0000: 21825: error : virModuleLoadFile:53 : internal error: Failed to load module '/usr/lib64/libvirt/connection-driver/libvirt_driver_interface.so': libexslt.so.0: cannot open shared object file: No such file or directory
Jan 24 22:00:46 CentOS7Server systemd[1]: libvirtd.service: main process exited, code=exited, status=3/NOTIMPLEMENTED
Jan 24 22:00:46 CentOS7Server systemd[1]: Failed to start Virtualization daemon.
Jan 24 22:00:46 CentOS7Server systemd[1]: Unit libvirtd.service entered failed state.
Jan 24 22:00:46 CentOS7Server systemd[1]: libvirtd.service failed.
Jan 24 22:00:46 CentOS7Server systemd[1]: libvirtd.service holdoff time over, scheduling restart.
Jan 24 22:00:46 CentOS7Server systemd[1]: Stopped Virtualization daemon.
Jan 24 22:00:46 CentOS7Server systemd[1]: Starting Virtualization daemon...
Jan 24 22:00:46 CentOS7Server libvirtd[21837]: 2019-01-25 03:00:46.814+0000: 21837: info : libvirt version: 4.5.0, package: 10.el7_6.3 (CentOS BuildSystem <http://bugs.centos.org>, 2018-11-28-20:51:39, x86-01.bsys.centos.org)
Jan 24 22:00:46 CentOS7Server libvirtd[21837]: 2019-01-25 03:00:46.814+0000: 21837: info : hostname: CentOS7Server
Jan 24 22:00:46 CentOS7Server libvirtd[21837]: 2019-01-25 03:00:46.814+0000: 21837: error : virModuleLoadFile:53 : internal error: Failed to load module '/usr/lib64/libvirt/connection-driver/libvirt_driver_interface.so': libexslt.so.0: cannot open shared object file: No such file or directory
Jan 24 22:00:46 CentOS7Server systemd[1]: libvirtd.service: main process exited, code=exited, status=3/NOTIMPLEMENTED
Jan 24 22:00:46 CentOS7Server systemd[1]: Failed to start Virtualization daemon.
Jan 24 22:00:46 CentOS7Server systemd[1]: Unit libvirtd.service entered failed state.
Jan 24 22:00:46 CentOS7Server systemd[1]: libvirtd.service failed.
Jan 24 22:00:47 CentOS7Server systemd[1]: libvirtd.service holdoff time over, scheduling restart.
Jan 24 22:00:47 CentOS7Server systemd[1]: Stopped Virtualization daemon.
Jan 24 22:00:47 CentOS7Server systemd[1]: start request repeated too quickly for libvirtd.service
Jan 24 22:00:47 CentOS7Server systemd[1]: Failed to start Virtualization daemon.
Jan 24 22:00:47 CentOS7Server systemd[1]: Unit libvirtd.service entered failed state.
Jan 24 22:00:47 CentOS7Server systemd[1]: libvirtd.service failed.

--------------------------------------------------------------------------------------------------------------------------------------------
Return of command

# systemctl start libvirtd.service

--------------------------------------------------------------------------------------------------------------------------------------------

Job for libvirtd.service failed because the control process exited with error code. See "systemctl status libvirtd.service" and "journalctl -xe" for details.

--------------------------------------------------------------------------------------------------------------------------------------------

Return of command

# libvirtd

--------------------------------------------------------------------------------------------------------------------------------------------

2019-01-25 03:13:15.173+0000: 22586: info : libvirt version: 4.5.0, package: 10.el7_6.3 (CentOS BuildSystem <http://bugs.centos.org>, 2018-11-28-20:51:39, x86-01.bsys.centos.org)
2019-01-25 03:13:15.173+0000: 22586: info : hostname: CentOS7Server
2019-01-25 03:13:15.173+0000: 22586: error : virModuleLoadFile:53 : internal error: Failed to load module '/usr/lib64/libvirt/connection-driver/libvirt_driver_interface.so': libexslt.so.0: cannot open shared object file: No such file or directory
Steps To ReproduceCommands listed in description.
Additional InformationForgive me if this does not qualify as a bug.
If my issue is out of the scope of this report page please feel free to point me in the direction of answers!

I have re-installed packages with the command:

# yum reinstall \*

No current packages marked for update/upgrade.

Attempted reinstalling all packages with no errors:

qemu-kvm libvirt libvirt-python libguestfs-tools virt-install

Finally, for what it's worth I was able to locate one of the files seemingly disrupting things with the command:

# find / -name "libexslt.so.0"

which returns:

/usr/lib/plexmediaserver/libexslt.so.0

I have attempted to disable and stop plexmediaserver.service and the issue persists.
Tagskvm, libvirt, libvirtd, qemu
abrt_hash
URL

Activities

teknohippie

teknohippie

2019-01-27 18:45

reporter   ~0033701

Apologies for opening this here.. Hindsight, this is obviously not a CentOS bug.

From a reddit thread I started earlier:

"Please contact whichever rpm repository provided your plexmediaserver package and report a bug in their package. Tell them that they need to disable auto-provide in their RPM spec file by adding a line reading "Autoprov: 0".

When an rpm package is built, rpm will search for shared libraries in the installed content and add them to a list of capabilities that the package "provides" for others in order to solve their "dependencies." Your plexmediaserver rpm contains a shared library that conflicts with a base system package, in a location where it will not be available to other packages. rpm believes it satisfies a dependency, but the system shared library linker does not.

In the meantime, manually install "libxslt" to resolve the problem."

--/u/gordonmessmer

I will open a forum topic with Plex Media Server so that they may fix this on their end.

Regards,

teknohippie
tigalch

tigalch

2019-01-27 19:57

manager   ~0033702

Marking as resolved per reporters feedback (I hopefully didn't read the feedback wrong).

Issue History

Date Modified Username Field Change
2019-01-25 03:24 teknohippie New Issue
2019-01-25 03:24 teknohippie Tag Attached: kvm
2019-01-25 03:24 teknohippie Tag Attached: libvirt
2019-01-25 03:24 teknohippie Tag Attached: libvirtd
2019-01-25 03:24 teknohippie Tag Attached: qemu
2019-01-27 18:45 teknohippie Note Added: 0033701
2019-01-27 19:57 tigalch Status new => resolved
2019-01-27 19:57 tigalch Resolution open => no change required
2019-01-27 19:57 tigalch Note Added: 0033702