View Issue Details

IDProjectCategoryView StatusLast Update
0015770CentOS-7perl-IO-Socket-SSLpublic2019-03-18 13:19
Reporterjifl 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionwon't fix 
Product Version7.6.1810 
Target VersionFixed in Version 
Summary0015770: perl-Mojolicious version clash with perl-IO-Socket-SSL
Description[ Arguably this should be filed against a perl-Mojolicious category, but there isn't one ]

The perl-Mojolicious module was updated recently from v7.67 to v7.94. As can be seen in /usr/share/perl5/vendor_perl/Mojo/IOLoop/TLS.pm (near the top) there is a fixed dependency there on 2.009+ of IO::Socket::SSL. However the current IO::Socket::SSL shipped is still 1.94 (which is what perl-Mojolicious v7.67 wanted).

So either perl-Mojolicious should be downgraded (bad) or perl-IO-Socket-SSL should be upgraded (better), but at the moment the two modules are incompatible and anything using them fails instantly so something needs doing somewhere.
Steps To Reproduce/usr/share/perl5/vendor_perl/Mojo/IOLoop/TLS.pm has this on line 29:
  return $self->emit(error => 'IO::Socket::SSL 2.009+ required for TLS support')
TagsNo tags attached.
abrt_hash
URL

Activities

jrd

jrd

2019-02-02 05:10

manager   ~0033758

It appears the package in question is provided by EPEL or another 3rd-party; you may wish to file a bug there. In the case of EPEL this would be https://bugzilla.redhat.com

Issue History

Date Modified Username Field Change
2019-02-02 04:04 jifl New Issue
2019-02-02 05:10 jrd Note Added: 0033758
2019-02-02 05:11 jrd Status new => closed
2019-02-02 05:11 jrd Resolution open => won't fix