View Issue Details

IDProjectCategoryView StatusLast Update
0015773BuildsysCi.centos.org Ecosystem Testingpublic2019-02-28 22:56
Reporterjmelis 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionopen 
Summary0015773: Request dedicated slave node for Red Hat Service Delivery organization
DescriptionI would like to request:

- Dedicated slave node for Red Hat's Service Delivery organization, with accounts and SSH keys for the admins listed below.
- Jenkins view (for example `ServiceDelivery`)
- enkins account to manage this view (for example 'sd-app-sre').
- Duffy key.

In this slave, we will run CI/CD pipelines for any open-source project that that should be open to the public in the context of the effort driven by the Service Delivery organization. This organization works on delivering OpenShift services.

The first projects that would be built by this node are:

- https://github.com/app-sre/qontract-server
- https://github.com/app-sre/qontract-reconcile
- https://github.com/app-sre/qontract-validator

Currently, the load would be very small, and we don't expect it to grow substantially in the short/medium term. We will make use of Duffy as we need to create docker images.

Associated admins for this node are:

- Jaime Melis <jmelis@redhat.com>
- Paul Bergene <pbergene@redhat.com>
- Roman Iuvshyn <riuvshyn@redhat.com>
- Karanbir Singh <kbsingh@redhat.com>

SSH keys for the admins https://gitlab.cee.redhat.com/dtsd/housekeeping/blob/master/ansible/hosts/group_vars/all

The official contact method should be this mailing list: <sd-app-sre@redhat.com>.

Also, please accept the `centos-ci` invitations for these repositories:

- https://github.com/app-sre/qontract-server/invitations
- https://github.com/app-sre/qontract-reconcile/invitations
- https://github.com/app-sre/qontract-validator/invitations

Please let me know if you require any further information.
TagsNo tags attached.

Activities

kbsingh@karan.org

kbsingh@karan.org

2019-02-10 23:29

administrator   ~0033798

+1

Brian can we get this actioned when you create new accounts etc next.
bstinson

bstinson

2019-02-18 23:43

administrator   ~0033864

@jmelis, I tried a few times to catch you on IRC. We need to work out a separate github token for this, and one or more for the rest of the devtools repos before we can support more tenants from this group.

Supporting all of this under the current setup is not possible.
jmelis

jmelis

2019-02-19 08:13

reporter   ~0033867

@bstinson, apologies, will be on IRC to discuss this with you.

note that we are not under the Devtools organization, this is a different organization, called Service Delivery. We wouldn't mind sharing the same slave node node with Devtools (slave04), but it's not a requirement, since the scope of both orgs are completely different. Servide Delivery aims to delivery OpenShift based services.

Issue History

Date Modified Username Field Change
2019-02-03 19:18 jmelis New Issue
2019-02-10 23:29 kbsingh@karan.org Note Added: 0033798
2019-02-18 23:43 bstinson Note Added: 0033864
2019-02-19 08:13 jmelis Note Added: 0033867
2019-02-28 22:56 bstinson Status new => resolved