View Issue Details

IDProjectCategoryView StatusLast Update
0015817CentOS-7javapublic2019-02-12 13:41
Reporterpeshay 
PrioritynormalSeveritytweakReproducibilityalways
Status newResolutionopen 
Product Version7.6.1810 
Target VersionFixed in Version 
Summary0015817: openjdk-11-devel RPM provides
DescriptionIn the openjdk-11-devel SPEC has within it's "Provides" the %{javaver} included in the name. In older version that is not the case.
For example:
java-devel = 1:1.8
java-devel = 1:1.7
java-11-devel = 1:11

If others set in their RPM that they require java-devel but don't care about the exact version, it won't fit anymore with java-11, the require has to be exact on the major version then.
In my eyes the version here is redundant if included in the name. If I would like to only have java 8 as requirement for my RPM, I could set `java-devel = 1:1.8` or for 11 I would set `java-devel = 1:11`
Tagsjava, rpm
abrt_hash
URL

Activities

TrevorH

TrevorH

2019-02-12 13:41

manager   ~0033813

These packages are rebuilds of those supplied by Redhat for RHEL and are unmodified. You will need to report this on bugzilla.redhat.com but I think it may be by design as the default java on RHEL/CentOS is currently 8.

Issue History

Date Modified Username Field Change
2019-02-12 13:36 peshay New Issue
2019-02-12 13:36 peshay Tag Attached: java
2019-02-12 13:36 peshay Tag Attached: rpm
2019-02-12 13:41 TrevorH Note Added: 0033813