View Issue Details

IDProjectCategoryView StatusLast Update
0015835CentOS-7-OTHERpublic2019-02-16 12:04
Reporterangie 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionnot fixable 
Product Version 
Target VersionFixed in Version 
Summary0015835: youtube-dl (2018.12.17-1.el7) crash on start
DescriptionOn start youtube-dl crash with error:
$ youtube-dl
Traceback (most recent call last):
  File "/usr/bin/youtube-dl", line 6, in <module>
    from pkg_resources import load_entry_point
ImportError: No module named 'pkg_resources'
Steps To Reproduce$ youtube-dl
Additional InformationReinstallation don't help:
$ sudo yum reinstall youtube-dl
Loaded plugins: copr, fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * base: mirror.host.ag
 * centosplus: mirror.host.ag
 * epel: mirrors.nav.ro
 * extras: mirrors.neterra.net
 * ius: mirror.slu.cz
 * nux-dextop: li.nux.ro
 * updates: mirrors.neterra.net

Resolving Dependencies
--> Running transaction check
---> Package youtube-dl.noarch 0:2018.12.17-1.el7 will be reinstalled
--> Finished Dependency Resolution

Dependencies Resolved
...
Installed:
  youtube-dl.noarch 0:2018.12.17-1.el7

$ youtube-dl
Traceback (most recent call last):
  File "/usr/bin/youtube-dl", line 6, in <module>
    from pkg_resources import load_entry_point
ImportError: No module named 'pkg_resources'

Problem solving:
$ sudo yum downgrade youtube-dl
Loaded plugins: copr, fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * base: mirror.host.ag
 * centosplus: mirror.host.ag
 * epel: mirrors.nav.ro
 * extras: mirrors.neterra.net
 * ius: mirror.slu.cz
 * nux-dextop: li.nux.ro
 * updates: mirrors.neterra.net

Resolving Dependencies
--> Running transaction check
---> Package youtube-dl.noarch 0:2014.11.13-1.el7.nux will be a downgrade
---> Package youtube-dl.noarch 0:2018.12.17-1.el7 will be erased
--> Finished Dependency Resolution

Dependencies Resolved
...
Removed:
  youtube-dl.noarch 0:2018.12.17-1.el7

Installed:
  youtube-dl.noarch 0:2014.11.13-1.el7.nux

Complete!
$ youtube-dl
Usage: youtube-dl [options] url [url...]

youtube-dl: error: you must provide at least one URL

Tagscrash, youtube-dl
abrt_hash
URL

Activities

pgreco

pgreco

2019-02-16 11:29

developer   ~0033851

CentOS doesn't provide youtube-dl, you're using 2 versions, 1 from nux, and 1 from epel.
My suggestion is to file the bug in https://bugzilla.redhat.com under the correct epel component.
jrd

jrd

2019-02-16 12:04

manager   ~0033853

Preface: I do hope this will not be taken as advertising; I present the following only as an aid to the user.

Alternatively you can get the package from my repo :) I keep it updated far more frequently than either of the other repos you're using. If interested please remove
the version(s) you have installed and then see https://wiki.psychotic.ninja/index.php?title=Usage to install my release file and then yum install youtube-dl. Any follow-ups, if you decide to go this route, should be done via IRC or my mailing list - information for both is available on the nav-bar of the wiki.

Issue History

Date Modified Username Field Change
2019-02-16 10:24 angie New Issue
2019-02-16 10:24 angie Tag Attached: crash
2019-02-16 10:24 angie Tag Attached: youtube-dl
2019-02-16 11:29 pgreco Status new => closed
2019-02-16 11:29 pgreco Resolution open => not fixable
2019-02-16 11:29 pgreco Note Added: 0033851
2019-02-16 12:04 jrd Note Added: 0033853