View Issue Details

IDProjectCategoryView StatusLast Update
0015850CentOS-7rpmpublic2019-04-22 23:42
ReporterPUCKfcab 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionno change required 
Product Version7.6.1810 
Target VersionFixed in Version 
Summary0015850: 'rpm -V' doesn't report missing files from grub2-tools-2.02-0.76.el7.centos.x86_64
Descriptionunder CentOS 7.6.1810, 'rpm -V' does not report missing files, at least for grub2-tools.
Steps To ReproduceInstall a host from CentOS-7-x86_64-Minimal-1810.iso.

Given this file:

# ls /etc/default/grub
/etc/default/grub
# rpm -qf /etc/default/grub
grub2-tools-2.02-0.76.el7.centos.x86_64

if I delete this file, 'rpm -V' does not report it as missing:

# mv /etc/default/grub /etc/default/grub.aside
# rpm -V grub2-tools-2.02-0.76.el7.centos.x86_64
# echo $?
0


Additional Information# rpm -qf /bin/rpm
rpm-4.11.3-35.el7.x86_64
TagsNo tags attached.
abrt_hash
URL

Activities

Evolution

Evolution

2019-04-22 23:41

administrator   ~0034237

This isn't a bug, this is an intentional packaging choice by upstream. That file is marked as %ghost, which means rpm says it's associated with that package, but otherwise largely ignores it.
Evolution

Evolution

2019-04-22 23:42

administrator   ~0034238

Upstream packaging choice. This behavior is due to the file being marked as %ghost in the package spec.

Issue History

Date Modified Username Field Change
2019-02-20 19:20 PUCKfcab New Issue
2019-04-22 23:41 Evolution Note Added: 0034237
2019-04-22 23:42 Evolution Status new => closed
2019-04-22 23:42 Evolution Resolution open => no change required
2019-04-22 23:42 Evolution Note Added: 0034238