View Issue Details

IDProjectCategoryView StatusLast Update
0015897CentOS-7[All Projects] generalpublic2019-04-19 09:10
ReporterJasonYchen 
PriorityhighSeveritymajorReproducibilityalways
Status newResolutionopen 
Product Version7.5.1804 
Target VersionFixed in Version 
Summary0015897: CentOS 7.5(1804)/7.6(1810) unable to install on HMB feature capable SSD
DescriptionHello,
I cannot install CentOS 7.5(1804)/7.6(1810) O.S on HMB feature capable SSD, same install can success on CentOS 7.3(1611)/7.4(1708), installation procedure will freeze and "[2.840042] i8042: No controller found" error message displayed(as attached).
Is there any different between these 4 versions?(CentOS 7.3(1611)/7.4(1708)/7.5(1804)/7.6(1810))
Can you help to fix this issue and let CentOS 7.5(1804)/7.6(1810) can be install on HMB function carry SSD?
As I know, only TOSHIBA SSD(BG series) has carry HMB function.
TagsNo tags attached.
abrt_hash
URL

Activities

JasonYchen

JasonYchen

2019-03-06 02:18

reporter  

install failed.jpg (24,508 bytes)
install failed.jpg (24,508 bytes)
TrevorH

TrevorH

2019-03-06 07:04

manager   ~0033943

7.5 is unsupported. Try 7.6. Make sure you remove 'rhgb quiet' from the kernel command line when booting.
JasonYchen

JasonYchen

2019-03-06 09:29

reporter   ~0033945

Hello,
Yes, I also tried 7.6 but failed still.
The installation can proceed and continue after I press "e" and "Ctrl+x" to issue command "nvme.max_host_mem_size_mb=0"(equal to setup HMB function disable) before install procedure, but it request to issue this command every time before enter O.S even installation is complete.
For actual usage we need the boot sequence can enter O.S automatically not manually.

edit cmd-1.jpg (35,314 bytes)
edit cmd-1.jpg (35,314 bytes)
edit cmd-2.jpg (58,023 bytes)
edit cmd-2.jpg (58,023 bytes)
TrevorH

TrevorH

2019-03-06 16:58

manager   ~0033951

Then you need to report this upstream on bugzilla.redhat.com though you still don't have the latest kernel installed = 3.10.0-957.el7 is the original 7.6 one and there have been several updates since then with the current one being 3.10.0-957.5.1.el7.

You can also edit the installed system /boot/grub2/grub.cfg (or its UEFI equivalent) and amend the kernel line in there to contain your bypass. Add it to the top entry - the default one - and all future kernel updates will pick up that change and include it.
JasonYchen

JasonYchen

2019-03-08 09:56

reporter   ~0033963

Hello,

Good day~~
Thank you for your help, based on your suggestion, I'm try to validate by swap to new version of kernel but I'm facing error message "error: /vmlinuz-5.0.0-2.el7.elrepo.x86_64 has invalid signature." & "error: you need to load the kernel first."
I had reference related comment on CentOS Community web but still cannot figure out and cannot works. Can you help to direct show me how to operate and make it work? thank you very much~~

Feedback from Centos Community:
Re: Kernel v4.17X invalid signature
"Post by toracat ? 2018/08/06 23:51:45
As stated in the quoted ELRepo wiki article, "ELRepo's kernel packages (kernel-ml and kernel-lt) are not signed with the Secure Boot key.""

new kernel-1s.jpg (80,353 bytes)
new kernel-1s.jpg (80,353 bytes)
new kernel-3s.jpg (46,600 bytes)
new kernel-3s.jpg (46,600 bytes)
JasonYchen

JasonYchen

2019-04-01 08:21

reporter   ~0034141

Hello,

 Good day~~
 Thank you for your help, based on your suggestion, I'm try to validate by swap to new version of kernel but I'm facing error message "error: /vmlinuz-5.0.0-2.el7.elrepo.x86_64 has invalid signature." & "error: you need to load the kernel first."
 I had reference related comment on CentOS Community web but still cannot figure out and cannot works. Can you help to direct show me how to operate and make it work? thank you very much~~

 Feedback from Centos Community:
 Re: Kernel v4.17X invalid signature
 "Post by toracat ? 2018/08/06 23:51:45
 As stated in the quoted ELRepo wiki article, "ELRepo's kernel packages (kernel-ml and kernel-lt) are not signed with the Secure Boot key.""

new kernel-1s-2.jpg (80,353 bytes)
new kernel-1s-2.jpg (80,353 bytes)
new kernel-3s-2.jpg (46,600 bytes)
new kernel-3s-2.jpg (46,600 bytes)
JasonYchen

JasonYchen

2019-04-19 09:10

reporter   ~0034224

Hello TrevorH,

Good day~~
Thank you for your help always~~
Based on your suggestion, I'm try to validate by swap to new version of kernel but I'm facing error message "error: /vmlinuz-5.0.0-2.el7.elrepo.x86_64 has invalid signature." & "error: you need to load the kernel first."
I had reference related comment on CentOS Community web but still cannot figure out and cannot works. Can you help to direct show me how to operate and make it work? thank you very much~~

  Feedback from Centos Community:
  Re: Kernel v4.17X invalid signature
  "Post by toracat ? 2018/08/06 23:51:45
  As stated in the quoted ELRepo wiki article, "ELRepo's kernel packages (kernel-ml and kernel-lt) are not signed with the Secure Boot key.""

new kernel-1s-2.png (306,005 bytes)
new kernel-3s-2.png (187,037 bytes)
new kernel-3s-2.png (187,037 bytes)

Issue History

Date Modified Username Field Change
2019-03-06 02:18 JasonYchen New Issue
2019-03-06 02:18 JasonYchen File Added: install failed.jpg
2019-03-06 07:04 TrevorH Note Added: 0033943
2019-03-06 09:29 JasonYchen File Added: edit cmd-1.jpg
2019-03-06 09:29 JasonYchen File Added: edit cmd-2.jpg
2019-03-06 09:29 JasonYchen Note Added: 0033945
2019-03-06 16:58 TrevorH Note Added: 0033951
2019-03-08 09:56 JasonYchen File Added: new kernel-1s.jpg
2019-03-08 09:56 JasonYchen File Added: new kernel-3s.jpg
2019-03-08 09:56 JasonYchen Note Added: 0033963
2019-04-01 08:21 JasonYchen File Added: new kernel-1s-2.jpg
2019-04-01 08:21 JasonYchen File Added: new kernel-3s-2.jpg
2019-04-01 08:21 JasonYchen Note Added: 0034141
2019-04-19 09:10 JasonYchen File Added: new kernel-1s-2.png
2019-04-19 09:10 JasonYchen File Added: new kernel-3s-2.png
2019-04-19 09:10 JasonYchen Note Added: 0034224