View Issue Details

IDProjectCategoryView StatusLast Update
0015920CentOS-7krb5public2019-03-18 17:51
ReporterCasm 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
Product Version7.6.1810 
Target VersionFixed in Version 
Summary0015920: Node.js kerberos module segmentation fault after upgrading CentOS Linux 7.5.1804 to CentOS Linux 7.6.1810
DescriptionAfter upgrading CentOS Linux 7.5.1804 to CentOS Linux 7.6.1810 node.js kerberos module crash.

I checked on Node.js 10.15.3
On CentOS Linux 7.5.1804 everything works without error, on CentOS Linux 7.6.1810 the module causes a crash.

Issue on kerberos module page:
https://github.com/mongodb-js/kerberos/issues/96

https://github.com/mongodb-js/kerberos/issues/95
Steps To ReproduceDownload node.js 10

Install kerberos and express modules: npm install kerberos, express

Download this example:
https://gist.github.com/Casm82/6dcbade764faf36a0ca87225b61db857

Create keytab on Windows domain member server
ktpass -princ HTTP/centos.domain.org@DOMAIN.ORG -mapuser user_krb@domain.org -crypto ALL -ptype KRB5_NT_PRINCIPAL -pass ****** -out %tmp%\krbAuth.keytab

On Node.js server (Centos Linux) I copied keytab file and set environment variable: export KRB5_KTNAME=/path/krbAuth.keytab

On the client (Windows 10, domain member) I added the site http://centos.domain.org to the Local Intranet Zone.

The example startup log is the following:
Centos 7.5
https://gist.github.com/Casm82/a25242d07ca41b1364f49b13b769482c

Centos 7.6
https://gist.github.com/Casm82/4691d18366d768125975656b1fb7f78f

Command ldd output:
Centos 7.5
https://gist.github.com/Casm82/7045b294bfec6bbaae6f343ef6451cf3

Centos 7.6
https://gist.github.com/Casm82/a1c0bc31c7b3f79592609454bc15fd9b
Additional InformationI compiled the Node.js 10.14.2 from the source with options

./configure --debug --gdb --prefix=/opt/node-debug

I also changed kerberos/package.json
"scripts": { ..."install": "prebuild-install || node-gyp rebuild --debug", ...
and launched again npm install

Simplified example https://gist.github.com/Casm82/71ca16932e03df1a6afd3974c9204633

And launched the example through the debugger
 gdb --args /opt/node-debug/bin/node krb_test.js

Full log: https://gist.github.com/Casm82/9b49ca64f0c92bfed96fa922b968ef02
TagsNo tags attached.
abrt_hash
URL

Activities

Casm

Casm

2019-03-18 17:40

reporter   ~0034030

After update to krb5-libs-1.15.1-37, krb5-workstation-1.15.1-37 error disappeared.
Problem solved.

Issue History

Date Modified Username Field Change
2019-03-14 09:58 Casm New Issue
2019-03-18 17:40 Casm Note Added: 0034030
2019-03-18 17:51 TrevorH Status new => closed
2019-03-18 17:51 TrevorH Resolution open => unable to reproduce