View Issue Details

IDProjectCategoryView StatusLast Update
0015941Buildsyscommunity buildsyspublic2019-06-08 20:53
Reportermrunge 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Summary0015941: please create build tags for messaging sig
DescriptionFor the newly founded messaging sig, please create build tags:
(with appended -testing, -release, -el7-build, -candidate)

messaging7-qpid-proton

messaging7-qpid-dispatch

- Inherits tag messaging7-qpid-proton

messaging7-qpid-cpp
- Inherits tag messaging7-qpid-proton
- Inherits tag messaging7-qpid-python

messaging7-pyngus
- Inherits tag messaging7-qpid-proton

messaging7-rhea

messaging7-qpid-python

messaging7-rabbitmq


Thank you
TagsNo tags attached.

Activities

alphacc

alphacc

2019-03-27 13:59

developer   ~0034110

Hi,

1/ x86_64 only ?
2/ Do we need that many tags / projects ? will the buildroot change a lot ? do they need to be in separate repos ?
messaging7-qpid-<version> better ? and proton / dispatch just pkg names ?

Thomas.
mrunge

mrunge

2019-03-27 14:04

reporter   ~0034111

1) x86, aarch64, ppc

2) we don't *need* them, the buildroot will not change very often. But let me take the question back to the team.
mrunge

mrunge

2019-04-01 08:14

reporter   ~0034140

I got some feedback:

-----------
The potentially important thing here is that Qpid is not one release stream. Qpid's components each have independent release streams. As long as that doesn't overly complicate use of the bulid tag, it should be okay.

To underline the key thing: in effect, qpid-proton is a totally separate project from qpid-python. They just happen to share a parent project. Qpid-python could be renamed to Shoelaces and it would function the same way
------------
so: question: is it complicated, or are there caveats to separate the tags/projects?
alphacc

alphacc

2019-04-18 12:10

developer   ~0034215

No it looks like it makes sense then. I'll follow your original request.
mrunge

mrunge

2019-05-24 06:45

reporter   ~0034517

Can we please get tags created as well?
arrfab

arrfab

2019-05-24 07:36

administrator   ~0034518

As discussed on the #centos-devel irc channel, some were created (see https://cbs.centos.org/koji/search?match=glob&type=tag&terms=messa*)
but some need also a release_name, so let me know which one you want to use and I'll create those accordingly.
irinabov

irinabov

2019-05-28 22:25

reporter   ~0034533

Still missing tags for messaging7-pyngus. Please create them.
arrfab

arrfab

2019-05-29 14:12

administrator   ~0034535

@irinabov : yes, per discussion with @mrunge, so still waiting for his feedback about the tags to create in koji
mrunge

mrunge

2019-05-29 14:28

reporter   ~0034536

@irinabov The remaining question was, if there are release_names (as mentioned above by @arrfab).

That would be used to separate release versions and their dependencies.
irinabov

irinabov

2019-06-04 14:32

reporter   ~0034593

Ok, "stable" as release_name works for me.
Lets complete tags.
arrfab

arrfab

2019-06-04 15:51

administrator   ~0034594

@mrunge : can we have a +1 on this ? if so I can add other tags later
mrunge

mrunge

2019-06-04 20:04

reporter   ~0034597

of course, +1
arrfab

arrfab

2019-06-05 22:01

administrator   ~0034608

Can you verify that you have all you need :
https://cbs.centos.org/koji/search?match=glob&type=tag&terms=messag*

Issue History

Date Modified Username Field Change
2019-03-21 06:46 mrunge New Issue
2019-03-27 13:59 alphacc Status new => feedback
2019-03-27 13:59 alphacc Note Added: 0034110
2019-03-27 14:04 mrunge Note Added: 0034111
2019-03-27 14:04 mrunge Status feedback => assigned
2019-04-01 08:14 mrunge Note Added: 0034140
2019-04-18 12:10 alphacc Note Added: 0034215
2019-05-24 06:45 mrunge Note Added: 0034517
2019-05-24 07:36 arrfab Status assigned => feedback
2019-05-24 07:36 arrfab Note Added: 0034518
2019-05-28 22:25 irinabov Note Added: 0034533
2019-05-29 14:12 arrfab Note Added: 0034535
2019-05-29 14:28 mrunge Note Added: 0034536
2019-05-29 14:28 mrunge Status feedback => assigned
2019-06-04 14:32 irinabov Note Added: 0034593
2019-06-04 15:51 arrfab Status assigned => feedback
2019-06-04 15:51 arrfab Note Added: 0034594
2019-06-04 20:04 mrunge Note Added: 0034597
2019-06-04 20:04 mrunge Status feedback => assigned
2019-06-05 22:01 arrfab Status assigned => feedback
2019-06-05 22:01 arrfab Note Added: 0034608
2019-06-08 20:53 arrfab Status feedback => resolved
2019-06-08 20:53 arrfab Resolution open => fixed