View Issue Details

IDProjectCategoryView StatusLast Update
0015976CentOS-7python-s3transferpublic2019-05-21 13:05
Reportercepheid 
PrioritynormalSeverityminorReproducibilityalways
Status newResolutionopen 
PlatformAWS (x86_64)OSCentOSOS Version7.6.1810
Product Version7.6.1810 
Target VersionFixed in Version 
Summary0015976: NOT EPEL -- python-s3transfer (still) blocks python2-boto3 install from epel
DescriptionBug #15974 was closed in error -- this is not an EPEL issue -- the issue is that python-s3transfer from CentOS updates repo does not list the correct name-v-r and therefore breaks packages that depend on python2-s3transfer from EPEL. The fix must be within CentOS Updates python-s3transfer to ensure it provides the correct name-v-r so as not to break dependencies on python2-s3stransfer.

Please see the "Additional comments" under Bug #15523.

python-s3transfer from base repo obsoletes python2-s3transfer and blocks install of python2-boto3 from EPEL. This was originally reported in bug #0015523 which was closed as "fixed in 7.6." However, this is still occurring even in a fully up-to-date CentOS 7.6.1810, as shown in yum output below.
Steps To Reproduce# cat /etc/redhat-release
CentOS Linux release 7.6.1810 (Core)

# yum install python2-boto3

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: packages.oit.ncsu.edu
 * epel: epel.mirror.constant.com
 * extras: mirrors.usinternet.com
 * remi-safe: repo1.ash.innoscale.net
 * updates: mirrors.tummy.com
Resolving Dependencies
--> Running transaction check
---> Package python2-boto3.noarch 0:1.4.6-1.el7 will be installed
--> Processing Dependency: python-futures >= 2.2.0 for package: python2-boto3-1.4.6-1.el7.noarch
--> Processing Dependency: python2-botocore >= 1.5.0 for package: python2-boto3-1.4.6-1.el7.noarch
--> Processing Dependency: python2-jmespath >= 0.7.1 for package: python2-boto3-1.4.6-1.el7.noarch
--> Processing Dependency: python2-s3transfer >= 0.1.10 for package: python2-boto3-1.4.6-1.el7.noarch
Package python2-s3transfer is obsoleted by python-s3transfer, but obsoleting package does not provide for requirements
--> Running transaction check
---> Package python2-boto3.noarch 0:1.4.6-1.el7 will be installed
--> Processing Dependency: python2-s3transfer >= 0.1.10 for package: python2-boto3-1.4.6-1.el7.noarch
Package python2-s3transfer is obsoleted by python-s3transfer, but obsoleting package does not provide for requirements
---> Package python2-botocore.noarch 0:1.6.0-1.el7 will be installed
--> Processing Dependency: python-dateutil >= 1.4 for package: python2-botocore-1.6.0-1.el7.noarch
--> Processing Dependency: python-docutils >= 0.10 for package: python2-botocore-1.6.0-1.el7.noarch
---> Package python2-futures.noarch 0:3.1.1-5.el7 will be installed
---> Package python2-jmespath.noarch 0:0.9.0-3.el7 will be installed
--> Running transaction check
---> Package python-dateutil.noarch 0:1.5-7.el7 will be installed
---> Package python-docutils.noarch 0:0.11-0.3.20130715svn7687.el7 will be installed
--> Processing Dependency: python-imaging for package: python-docutils-0.11-0.3.20130715svn7687.el7.noarch
---> Package python2-boto3.noarch 0:1.4.6-1.el7 will be installed
--> Processing Dependency: python2-s3transfer >= 0.1.10 for package: python2-boto3-1.4.6-1.el7.noarch
Package python2-s3transfer is obsoleted by python-s3transfer, but obsoleting package does not provide for requirements
--> Running transaction check
---> Package python-pillow.x86_64 0:2.0.0-19.gitd1c6db8.el7 will be installed
--> Processing Dependency: libtiff.so.5(LIBTIFF_4.0)(64bit) for package: python-pillow-2.0.0-19.gitd1c6db8.el7.x86_64
--> Processing Dependency: libwebp.so.4()(64bit) for package: python-pillow-2.0.0-19.gitd1c6db8.el7.x86_64
--> Processing Dependency: libtiff.so.5()(64bit) for package: python-pillow-2.0.0-19.gitd1c6db8.el7.x86_64
---> Package python2-boto3.noarch 0:1.4.6-1.el7 will be installed
--> Processing Dependency: python2-s3transfer >= 0.1.10 for package: python2-boto3-1.4.6-1.el7.noarch
Package python2-s3transfer is obsoleted by python-s3transfer, but obsoleting package does not provide for requirements
--> Running transaction check
---> Package libtiff.x86_64 0:4.0.3-27.el7_3 will be installed
--> Processing Dependency: libjbig.so.2.0()(64bit) for package: libtiff-4.0.3-27.el7_3.x86_64
---> Package libwebp.x86_64 0:0.3.0-7.el7 will be installed
---> Package python2-boto3.noarch 0:1.4.6-1.el7 will be installed
--> Processing Dependency: python2-s3transfer >= 0.1.10 for package: python2-boto3-1.4.6-1.el7.noarch
Package python2-s3transfer is obsoleted by python-s3transfer, but obsoleting package does not provide for requirements
--> Running transaction check
---> Package jbigkit-libs.x86_64 0:2.0-11.el7 will be installed
---> Package python2-boto3.noarch 0:1.4.6-1.el7 will be installed
--> Processing Dependency: python2-s3transfer >= 0.1.10 for package: python2-boto3-1.4.6-1.el7.noarch
Package python2-s3transfer is obsoleted by python-s3transfer, but obsoleting package does not provide for requirements
--> Finished Dependency Resolution
Error: Package: python2-boto3-1.4.6-1.el7.noarch (epel)
           Requires: python2-s3transfer >= 0.1.10
           Available: python2-s3transfer-0.1.10-1.el7.noarch (epel)
               python2-s3transfer = 0.1.10-1.el7
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Additional InformationThis is not an EPEL problem -- the issue is that python-s3transfer from CentOS updates repo does not list the correct name-v-r and therefore breaks packages that depend on python2-s3transfer from EPEL. The fix must be within CentOS Updates python-s3transfer to ensure it provides the correct name-v-r.

Please see the "Additional comments" under Bug #15523.
TagsNo tags attached.
abrt_hash
URL

Activities

TrevorH

TrevorH

2019-04-02 17:41

manager   ~0034152

EPEL should not be shipping packages that are already supplied by RHEL/CentOS.

Why are you trying to use python2-boto3 and not the base version

python-boto3.noarch 1.4.6-5.el7 base
python-s3transfer.noarch 0.1.13-1.el7.0.1 updates
cepheid

cepheid

2019-04-02 17:58

reporter   ~0034153

I am trying to install a CertBot DNS plugin, python2-certbot-dns-route53, which is from EPEL, which relies on python2-boto3, which relies on python2-s3transfer. It is this last package that is causing installation to fail due to incorrect dependencies.

Issue History

Date Modified Username Field Change
2019-04-02 17:34 cepheid New Issue
2019-04-02 17:41 TrevorH Note Added: 0034152
2019-04-02 17:58 cepheid Note Added: 0034153