View Issue Details

IDProjectCategoryView StatusLast Update
0016033CentOS-7xorg-x11-drv-intelpublic2019-04-26 12:36
ReporterRachelGoreham 
PriorityhighSeverityminorReproducibilityalways
Status newResolutionopen 
Product Version7.6.1810 
Target VersionFixed in Version 
Summary0016033: High resolution display not working, fails resizing framebuffer to 4480x1440
DescriptionI am using latest CentOS 7.6 software with all available updates on a Lenovo desktop system with IntelĀ® HD Graphics 400 (Braswell). Whenever I plug in a high-resolution monitor, the screen is black.

Steps To ReproducePlug in monitor.
Additional Information
Here is the output of xrandr:
Screen 0: minimum 8 x 8, current 4480 x 1440, maximum 32767 x 32767
DP1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 530mm x 300mm
   1920x1080 60.00*+ 50.00 59.94
   1600x1200 75.00 70.00 60.00
   1680x1050 59.95
   1280x1024 75.02 72.05 60.02
   1440x900 74.98 59.89
   1366x768 59.79
   1280x800 59.81
   1152x864 75.00
   1280x768 59.87
   1280x720 60.00 50.00 59.94
   1024x768 75.03 70.07 60.00
   800x600 72.19 75.00 60.32
   720x576 50.00
   720x480 60.00 59.94
   640x480 75.00 72.81 66.67 60.00 59.94
   720x400 70.08
   640x350 70.10
DP2 disconnected (normal left inverted right x axis y axis)
DP3 connected 2560x1440+1920+0 (normal left inverted right x axis y axis) 530mm x 300mm
   2560x1440 59.95*+
   1920x1200 59.88
   1920x1080 60.00 60.00 50.00 59.94
   1680x1050 59.95
   1600x900 60.00
   1280x1024 60.02
   1440x900 59.89
   1280x720 60.00 50.00 59.94
   1024x768 60.00
   800x600 60.32
   720x480 60.00 59.94
   640x480 60.00 59.94
   720x400 70.08
HDMI1 disconnected (normal left inverted right x axis y axis)
HDMI2 disconnected (normal left inverted right x axis y axis)
HDMI3 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)
 
Here are the errors from Xorg log:
[ 3567.736] (II) intel(0): resizing framebuffer to 4480x1440
[ 3567.794] (EE) intel(0): get_fb: failed to add fb: 4480x1440 depth=24, bpp=32, pitch=17920: 22
[ 3567.840] (II) intel(0): switch to mode 2560x1440@60.0 on DP3 using pipe 2, position (1920, 0), rotation normal, reflection none
[ 3567.841] (EE) intel(0): get_fb: failed to add fb: 4480x1440 depth=24, bpp=32, pitch=17920: 22

Here is the error from /var/log/messages:
kernel: [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe C FIFO underrun
TagsNo tags attached.
abrt_hash
URL

Activities

toracat

toracat

2019-04-25 15:25

manager   ~0034262

Upstream BZ https://bugzilla.redhat.com/show_bug.cgi?id=1506339 may be relevant.
RachelGoreham

RachelGoreham

2019-04-25 16:47

reporter   ~0034264

Thank you, I already visited the suggested upstream BZ and even logged a comment there, but did not find anything to solve my issues with this single monitor not working. Do you have any other suggestions?
toracat

toracat

2019-04-25 17:06

manager   ~0034265

You might want to test-install the latest stable kernel from kernel.org to see if the problem has been fixed there. You can do this test by using ELRepo's kernel-ml.
RachelGoreham

RachelGoreham

2019-04-25 17:38

reporter   ~0034266

I just test EL Repos kernel-ml and it reports the same error as I reported above.
RachelGoreham

RachelGoreham

2019-04-26 12:36

reporter   ~0034395

I also tested the monitor with Ubuntu and Fedora. Both had the same issues, so most likely this is an issue with the Intel driver, but could also be a setting in Xorg.

Issue History

Date Modified Username Field Change
2019-04-25 15:08 RachelGoreham New Issue
2019-04-25 15:25 toracat Note Added: 0034262
2019-04-25 16:47 RachelGoreham Note Added: 0034264
2019-04-25 17:06 toracat Note Added: 0034265
2019-04-25 17:38 RachelGoreham Note Added: 0034266
2019-04-26 12:36 RachelGoreham Note Added: 0034395