View Issue Details

IDProjectCategoryView StatusLast Update
0016054administrationoperationspublic2019-08-12 13:14
Reporterrbr146 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionwon't fix 
PlatformToshiba SatelliteOScentos-release-7-6.1810.2.el7.ceOS Version7-6.1810.2
Product Version 
Target VersionFixed in Version 
Summary0016054: after update of skypeforlinux.x86_64 0:8.44.0.40-1 skype doesn't start
Descriptionafter yum update of skypeforlinux.x86_64 0:8.44.0.40-1 skype doesn't start
KSysGuard shows that skype has 3 processes but nothing happend.
Steps To Reproducejust yum update skypeforlinux
and start it
Additional Informationdowngrade works fine
TagsNo tags attached.

Activities

pakistan

pakistan

2019-05-05 09:27

reporter   ~0034426

I experienced same issue .

Downgrade works .

yum downgrade skypeforlinux-8.34.0.78-1.x86_64

LSB Version: :core-4.1-amd64:core-4.1-noarch
Distributor ID: CentOS
Description: CentOS Linux release 7.6.1810 (Core)
Release: 7.6.1810
Codename: Core
LUTi

LUTi

2019-05-14 16:27

reporter   ~0034463

I have the same issue. Any (stable / unstable) release after skypeforlinux-8.34.0.78-1.x86_64 fails to run as expected.

If I remember well, I've noticed something like a library issue (that some process related to skypeforlinux failed to start or so...) at one of the first pre-releases after 8.34.0.78-1 (probably managed to find something in some log or so... don't remember details though). With the most recent releases, no indication of what went wrong.

The problem is that even if launched through terminal, initial process is terminated instantly (and, command prompt is back), without any error being reported. Don't have an idea about how to make skype processes to be more verbose or to log issues somewhere. Anyone has an idea about that?
gorano

gorano

2019-05-20 05:40

reporter   ~0034482

Apparently the new version has been compiled with a newer version of GLIBC (GLIBC_2.18) and CentOS 7 is at GLIBC_2.17.
Source of this info:
https://answers.microsoft.com/en-us/skype/forum/all/skypeforlinux-844040-1x8664-will-not-launch-on/ce3107dd-fc1e-4c64-9dfb-16d259dfed49
DrLove73

DrLove73

2019-05-22 08:00

reporter   ~0034491

I can confirm that versions after skypeforlinux-8.34.0.78-1.x86_64 does not work any more.
Since new version appeared, I had to apply "yum downgrade skypeforlinux" twice to reach skypeforlinux-8.34.0.78-1.x86_64.

Even Skype System Requirements do not show CentOS/RHEL as supported anymore: https://support.skype.com/en/faq/fa10328/what-are-the-system-requirements-for-skype
As @gorano wrote, problem seams to be with newer GLIBC version and Microsoft does not care to support RHEL any more. There is possibility it is connected with Microsofts new ties with Ubuntu or recent stop of support for both Skype Desktop and Skype for Web on Windows XP platform that happened last month.

In any case, I propose for this bug to be marked unfixable,
and to propose that everyone using skype-stable repo apply "yum-config-manager --disable skype-stable" to dissable further hassle.

Maybe Nux can move one copy of skypeforlinux rpm to his repository in case skypeforlinux-8.34.0.78-1.x86_64 is removed from official repo.
rbr146

rbr146

2019-05-23 05:06

reporter   ~0034503

skypeforlinux.x86_64 0:8.45.0.41-1 does not solve the problem we have to downgrade twice to skypeforlinux.x86_64 0:8.34.0.78-1
gorano

gorano

2019-06-03 05:19

reporter   ~0034580

Version 8.46.0.60 fixes this.
DrLove73

DrLove73

2019-06-03 07:50

reporter   ~0034583

" Version 8.46.0.60 fixes this. "
I can confirm this, Skype 8.46.0.60 loads and works.
It is quite unexpected but nice development.
rbr146

rbr146

2019-06-04 05:15

reporter   ~0034590

solved by skypeforlinux-8.46.0.60-1.x86_64

Many thanks,
René
TrevorH

TrevorH

2019-08-12 13:14

manager   ~0034947

Skypeforlinux is a proprietary package supplied by Microsoft. They made a change to their package to require a newer version of glibc than is supplied by CentOS 7 and that is impossible to satisfy (attempting to update glibc will result in a dead system). They've subsequently re-updated the package to require the correct glibc 2.17 version. This is not a CentOS problem.

Issue History

Date Modified Username Field Change
2019-05-04 12:34 rbr146 New Issue
2019-05-05 09:27 pakistan Note Added: 0034426
2019-05-14 16:27 LUTi Note Added: 0034463
2019-05-20 05:40 gorano Note Added: 0034482
2019-05-22 08:00 DrLove73 Note Added: 0034491
2019-05-23 05:06 rbr146 Note Added: 0034503
2019-06-03 05:19 gorano Note Added: 0034580
2019-06-03 07:50 DrLove73 Note Added: 0034583
2019-06-04 05:15 rbr146 Note Added: 0034590
2019-08-12 13:14 TrevorH Status new => closed
2019-08-12 13:14 TrevorH Resolution open => won't fix
2019-08-12 13:14 TrevorH Note Added: 0034947