View Issue Details

IDProjectCategoryView StatusLast Update
0016116CentOS-7-OTHERpublic2020-09-19 11:05
Reporterwhoelzl Assigned To 
Status newResolutionopen 
Product Version7.6.1810 
Summary0016116: leapp for upgrade CentOS 7 to 8
Descriptionrhel-7-server-extras-rpms contains leapp for upgrade CentOS 7 to 8.
Will CentOS extras provide leapp?
Steps To Reproduceyum install leapp
Additional Information
TagsNo tags attached.




2019-05-24 15:10

manager   ~0034519

There are no plans for the CentOS core team to support or package leapp but if there is sufficient support from the community to provide copies amended for CentOS then they could be released as part of a SIG. However, given the current lack of support for the preupgrade tool to migrate from CentOS 6 to 7 and the total lack of response to all calls for volunteers to package that, I would not be optimistic about it happening.


2019-10-08 12:00

reporter   ~0035370

Ok. Any update about this question? I am testing Centos 8 and I need to upgrade some Centos 7. If I have to make a new install, maybe is better change the distro?

And what about this?


2019-10-16 22:43

reporter   ~0035518

are there other ways to upgrade centos 7 to centos 8?
Because of the support of centos 7 its not very relevant to upgrade in next 5 years, but after end of support it would be nice to upgrade every centos machine without reinstall ...

Thank you,


2019-10-17 06:46

reporter   ~0035520

+1 for rolling upgrades.


2019-10-17 09:50

reporter   ~0035522

Hopefully upgrading centos-release package will start the upgrade from 7 to 8. But sometimes things do not work smoothly so please take a look at this page for some tips and tricks.:

Of course, sole responsibility is on you.

Disclaimer: i have not played with these things for many years and i don't remember ever doing it in Centos but it worked every time in Fedora...

Also a note about speed: If backup restore system is in place and working, just reinstalling the new version is much faster/cleaner/etc .


2019-10-20 15:43

reporter   ~0035532

So played around a little. Attached is the process that I used.

Worked for me<tm>, no support is given and remember backups. YMMV.
Do not try to do it, if you don't know what you are doing. Especially if you don't know how to resolve dependency issues.

If you fail to resolve them, rollback by installing CentOS 7, EPEL 7 etc back or restore the backup.
centos7-to-8.txt (1,961 bytes)   
# Centos 7 => 8 manual upgrade.
# No support is given, YMMV, remember backups!
# Tested with upcloud and cloudatcost.

# Get ready to upgrade
yum -y install
yum -y install rpmconf yum-utils

# Resolve all config stuff.
rpmconf -a

# Packages you might not need/require, remove if something doens't seem to be required.
package-cleanup --leaves
package-cleanup --orphans

# Install DNF.
yum -y install dnf

# Remove yum
dnf -y remove yum yum-metadata-parser
rm -Rf /etc/yum

# Upgrade system to be up-to-date
dnf -y upgrade

# Install new versions:
dnf -y upgrade

# Upgrade EPEL
dnf -y upgrade

# Dnf clean
dnf clean all

# Remove kernels, kernel packages are kernel-core in c8.
rpm -e `rpm -q kernel`

# Remove definitely conflicting stuff.
rpm -e --nodeps sysvinit-tools

# Try to run the upgrade
dnf -y --releasever=8 --allowerasing --setopt=deltarpm=false distro-sync

# If it doesn't succeed (YMMV), fix dependency stuff by removing/installing conficting stuff and try again.
# eg. if you want to drop all the dependencies
#dnf remove python2-six python-six
# eg. you don't want to drop all the dependencies, they would remove too much.
#rpm -e --nodeps sysvinit-tools

# Process new configs
rpmconf -a

# Ensure kernel is properly installed
rpm -e kernel-core
dnf -y install kernel-core

# Make sure grub is updated (ensure that it's right place!)
ROOTDEV=`ls /dev/*da|head -1`;
echo "Detected root as $ROOTDEV..."
grub2-install $ROOTDEV

# Install new stuff that is in the Core/Minimum Install:
dnf -y groupupdate "Core" "Minimal Install"

# Install back the stuff that you need and removed to get the dnf distro-sync to succeed.

centos7-to-8.txt (1,961 bytes)   


2019-10-31 08:58

reporter   ~0035614

I tried bestis solution, but I have a lot of dependency issues. I tried in a cloned production server, I suppose in an easy configuration maybe will work, but for me Is faster making a new deploy of centos8 with ansible, and install from scratch, but also requires a lot of work. I updated a week ago an Ubuntu Server 12.04 (obsolete) to Ubuntu 18.04 (12.04 to 14.04 to 16.04 to 18.04) without issues. Very sad if Centos doesn't provide an upgrade tool.
Milan Kerslager

Milan Kerslager

2020-05-03 10:59

reporter   ~0036855

I updated several servers from CentOS 7 to 8 and wrote down the steps here (as the scenarios all around not work including TXT file from this bugreport):

I could imagine to test the leapp on my developer machine too (free developer RHEL licence)..

Issue History

Date Modified Username Field Change
2019-05-24 13:48 whoelzl New Issue
2019-05-24 15:10 TrevorH Note Added: 0034519
2019-10-08 12:00 hugo.fernandez Note Added: 0035370
2019-10-16 22:43 dpilichiewicz Note Added: 0035518
2019-10-17 06:46 sj_dk Note Added: 0035520
2019-10-17 09:50 cpanceac Note Added: 0035522
2019-10-20 15:43 bestis File Added: centos7-to-8.txt
2019-10-20 15:43 bestis Note Added: 0035532
2019-10-31 08:58 hugo.fernandez Note Added: 0035614
2020-05-03 10:59 Milan Kerslager Note Added: 0036855