View Issue Details

IDProjectCategoryView StatusLast Update
0016124CentOS-7gnome-terminalpublic2019-05-29 09:56
Reporterchryssoc 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionwon't fix 
Product Version7.6.1810 
Target VersionFixed in Version 
Summary0016124: Cannot copy from Vim and paste to Terminal
DescriptionRunning Vim 8.1.1415 I cannot copy from Vim and paste to the Terminal outside of Vim.
Copy-pasting in the opposite direction works: copy some text in Terminal, then open Vim and paste with "+p.
Also copying from Vim and pasting in other program except the Terminal, e.g. Gedit, works.
Steps To Reproduce1. Open Vim in Terminal
2. Visually select some text pressing v
3. Yank to the "+ register via "+y
4. Suspend Vim with C-z
5. Control-Shift-v doesn't paste the selected text in Terminal

Note that copy-pasting in the opposite direction works. I.e.:

1. In Terminal, outside of Vim, select with the mouse some text
2. Copy it with Control-Shift-c
3. Open Vim
4. Paste with "+p. It works.

Also note that copying from Vim and pasting in any other program except the Terminal, e.g. Gedit, works too.
So it seems to be a problem with Terminal.

Tagsgnome-terminal vim clipboard copy-paste
abrt_hash
URL

Activities

TrevorH

TrevorH

2019-05-29 09:56

manager   ~0034534

We do not ship vim 8.1.1415 so you need to report this to the people that do. Our copy of vim is:

vim-minimal-7.4.160-5.el7.x86_64
vim-filesystem-7.4.160-5.el7.x86_64
vim-enhanced-7.4.160-5.el7.x86_64
vim-common-7.4.160-5.el7.x86_64

Issue History

Date Modified Username Field Change
2019-05-29 07:41 chryssoc New Issue
2019-05-29 07:41 chryssoc Tag Attached: gnome-terminal vim clipboard copy-paste
2019-05-29 09:56 TrevorH Status new => closed
2019-05-29 09:56 TrevorH Resolution open => won't fix
2019-05-29 09:56 TrevorH Note Added: 0034534