View Issue Details

IDProjectCategoryView StatusLast Update
0016128CentOS-7yumpublic2019-05-29 20:49
ReporterEckyBrazzz 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionwon't fix 
Product Version7.6.1810 
Target VersionFixed in Version 
Summary0016128: yum check-update ## Updateinfo file is not valid XML:
Descriptionyum check-update
Loaded plugins: fastestmirror, priorities, versionlock
Loading mirror speeds from cached hostfile
 * base: mirror.nl.datapacket.com
 * centos-sclo-rh: ftp.nluug.nl
 * centos-sclo-sclo: mirror.ams1.nl.leaseweb.net
 * epel: mirror.hostnet.nl
 * extras: mirror.nl.datapacket.com
 * rpmforge: ftp.nluug.nl
 * updates: mirror.ams1.nl.leaseweb.net
310 packages excluded due to repository priority protections
Updateinfo file is not valid XML: <open file '/var/cache/yum/x86_64/7/epel/92f2e15cad66d79ea1ad327e2af7af89d98e4d153d7a3e27ff41946f476af5b4-updateinfo.xml.zck', mode 'rt' at 0x7fca7e92e930>
Additional Information<----- START YUM Auto Update
yum -y install yum-cron
EMAIL=your@email.com
sed -i "s|^email_to = root|email_to = ${EMAIL}|" /etc/yum/yum-cron.conf
sed -i 's|^update_messages = no|update_messages = yes|' /etc/yum/yum-cron.conf
sed -i 's|^download_updates = no|download_updates = yes|' /etc/yum/yum-cron.conf
sed -i 's|^apply_updates = no|apply_updates = yes|' /etc/yum/yum-cron.conf
sed -i 's|^emit_via = stdio|emit_via = email|' /etc/yum/yum-cron.conf
sed -i "s|^email_to = root|email_to = ${EMAIL}|" /etc/yum/yum-cron-hourly.conf
sed -i 's|^update_cmd = default|update_cmd = security|' /etc/yum/yum-cron-hourly.conf
sed -i 's|^update_messages = no|update_messages = yes|' /etc/yum/yum-cron-hourly.conf
sed -i 's|^download_updates = no|download_updates = yes|' /etc/yum/yum-cron-hourly.conf
sed -i 's|^apply_updates = no|apply_updates = yes|' /etc/yum/yum-cron-hourly.conf
sed -i 's|^emit_via = stdio|emit_via = email|' /etc/yum/yum-cron-hourly.conf
egrep '^email_to|^update_messages|^download_updates|^apply_updates|^emit_via' /etc/yum/yum-cron.conf
<----- END YUM Auto Update
Tags7.6, yum-cron
abrt_hash
URL

Activities

EckyBrazzz

EckyBrazzz

2019-05-29 20:36

reporter   ~0034540

This started several days ago as I noticed it in the e-mails when the cron runs
tigalch

tigalch

2019-05-29 20:37

manager   ~0034541

Looks like a problem with EPEL. You can try to run 'yum clean-all' and thzen try the update again. Apart from that, this is an EPEL issue as it is the repo file from an EPEL mirror-
EckyBrazzz

EckyBrazzz

2019-05-29 20:48

reporter   ~0034542

Wow, the first issue didn't expect a response that soon. You wanted to say "yum clean all" without a dash. Looks like it resolved the problem.

[20:40][root@server6. ~]# yum update
Loaded plugins: fastestmirror, priorities, versionlock
Determining fastest mirrors
epel/x86_64/metalink | 24 kB 00:00:00
 * base: mirror.denit.net
 * centos-sclo-rh: mirror.denit.net
 * centos-sclo-sclo: ftp.nluug.nl
 * epel: ftp.nluug.nl
 * extras: ftp.nluug.nl
 * rpmforge: ftp.nluug.nl
 * updates: ftp.nluug.nl
base | 3.6 kB 00:00:00
centos-sclo-rh | 3.0 kB 00:00:00
centos-sclo-sclo | 2.9 kB 00:00:00
digitalocean-agent | 3.3 kB 00:00:00
epel | 4.9 kB 00:00:00
extras | 3.4 kB 00:00:00
mariadb | 2.9 kB 00:00:00
percona-release-x86_64 | 2.9 kB 00:00:00
rpmforge | 1.9 kB 00:00:00
updates | 3.4 kB 00:00:00
(1/11): centos-sclo-sclo/x86_64/primary_db | 291 kB 00:00:00
(2/11): centos-sclo-rh/x86_64/primary_db | 3.8 MB 00:00:00
(3/11): base/7/x86_64/group_gz | 166 kB 00:00:00
(4/11): epel/x86_64/group_gz | 88 kB 00:00:00
(5/11): epel/x86_64/primary_db | 6.7 MB 00:00:00
(6/11): extras/7/x86_64/primary_db | 200 kB 00:00:00
(7/11): base/7/x86_64/primary_db | 6.0 MB 00:00:00
(8/11): updates/7/x86_64/primary_db | 5.0 MB 00:00:00
(9/11): digitalocean-agent/x86_64/primary_db | 3.6 kB 00:00:00
(10/11): mariadb/primary_db | 54 kB 00:00:00
(11/11): percona-release-x86_64/7/primary_db | 951 kB 00:00:00
rpmforge/primary_db | 125 kB 00:00:00
310 packages excluded due to repository priority protections
No packages marked for update
[20:41][root@server6. ~]# yum update
Loaded plugins: fastestmirror, priorities, versionlock
Loading mirror speeds from cached hostfile
 * base: mirror.denit.net
 * centos-sclo-rh: mirror.denit.net
 * centos-sclo-sclo: ftp.nluug.nl
 * epel: ftp.nluug.nl
 * extras: ftp.nluug.nl
 * rpmforge: ftp.nluug.nl
 * updates: ftp.nluug.nl
310 packages excluded due to repository priority protections
No packages marked for update
[20:41][root@server6. ~]# yum check update
Loaded plugins: fastestmirror, priorities, versionlock
check ['update']
TrevorH

TrevorH

2019-05-29 20:49

manager   ~0034543

https://pagure.io/releng/issue/8392 is the actual EPEL issue.

Issue History

Date Modified Username Field Change
2019-05-29 20:33 EckyBrazzz New Issue
2019-05-29 20:33 EckyBrazzz Tag Attached: 7.6
2019-05-29 20:33 EckyBrazzz Tag Attached: yum-cron
2019-05-29 20:36 EckyBrazzz Note Added: 0034540
2019-05-29 20:37 tigalch Note Added: 0034541
2019-05-29 20:48 EckyBrazzz Note Added: 0034542
2019-05-29 20:49 TrevorH Status new => closed
2019-05-29 20:49 TrevorH Resolution open => won't fix
2019-05-29 20:49 TrevorH Note Added: 0034543