View Issue Details

IDProjectCategoryView StatusLast Update
0016134CentOS-7yum-utilspublic2019-06-01 09:52
Reporternoremorze 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version7.6.1810 
Target VersionFixed in Version 
Summary0016134: yum-utils-1.1.31-50.el7.noarch cannont sync files with ++ in filename
Descriptionfiiles with ++ in name fail to sync to local directory

---
gcc-c++-aarch64-linux-gnu-4.8. FAILED
gcc-c++-alpha-linux-gnu-4.8.5- FAILED ============= ] 4.3 MB/s | 3.1 GB 00:48:09 ETA
gcc-c++-arm-linux-gnu-4.8.5-16 FAILED ============= ] 4.3 MB/s | 3.1 GB 00:48:09 ETA
gcc-c++-avr32-linux-gnu-4.8.5- FAILED ============= ] 4.3 MB/s | 3.1 GB 00:48:09 ETA
gcc-c++-bfin-linux-gnu-4.8.5-1 FAILED ============= ] 4.3 MB/s | 3.1 GB 00:48:09 ETA
gcc-c++-c6x-linux-gnu-4.8.5-16 FAILED ============= ] 4.3 MB/s | 3.1 GB 00:48:09 ETA
gcc-c++-cris-linux-gnu-4.8.5-1 FAILED ============= ] 4.3 MB/s | 3.1 GB 00:48:09 ETA
gcc-c++-frv-linux-gnu-4.8.5-16 FAILED ============= ] 4.3 MB/s | 3.1 GB 00:48:09 ETA
gcc-c++-h8300-linux-gnu-4.8.5- FAILED ============= ] 4.3 MB/s | 3.1 GB 00:48:09 ETA
gcc-c++-hppa-linux-gnu-4.8.5-1 FAILED ============= ] 4.3 MB/s | 3.1 GB 00:48:09 ETA
gcc-c++-hppa64-linux-gnu-4.8.5 FAILED ============= ] 4.3 MB/s | 3.1 GB 00:48:09 ETA
gcc-c++-ia64-linux-gnu-4.8.5-1 FAILED ============= ] 4.3 MB/s | 3.1 GB 00:48:09 ETA
gcc-c++-m32r-linux-gnu-4.8.5-1 FAILED ============= ] 4.3 MB/s | 3.1 GB 00:48:09 ETA
gcc-c++-m68k-linux-gnu-4.8.5-1 FAILED ============= ] 4.3 MB/s | 3.1 GB 00:48:09 ETA
gcc-c++-microblaze-linux-gnu-4 FAILED ============= ] 4.3 MB/s | 3.1 GB 00:48:09 ETA
gcc-c++-mips64-linux-gnu-4.8.5 FAILED ============= ] 4.3 MB/s | 3.1 GB 00:48:09 ETA
gcc-c++-mn10300-linux-gnu-4.8. FAILED ============= ] 4.3 MB/s | 3.1 GB 00:48:09 ETA
gcc-c++-powerpc64-linux-gnu-4. FAILED ============= ] 4.3 MB/s | 3.1 GB 00:48:09 ETA
gcc-c++-ppc64-linux-gnu-4.8.5- FAILED ============= ] 4.3 MB/s | 3.1 GB 00:48:09 ETA
gcc-c++-s390x-linux-gnu-4.8.5- FAILED ============= ] 4.3 MB/s | 3.1 GB 00:48:09 ETA
gcc-c++-sh-linux-gnu-4.8.5-16. FAILED ============= ] 4.3 MB/s | 3.1 GB 00:48:09 ETA
gcc-c++-sh64-linux-gnu-4.8.5-1 FAILED ============= ] 4.3 MB/s | 3.1 GB 00:48:09 ETA
gcc-c++-sparc64-linux-gnu-4.8. FAILED ============= ] 4.3 MB/s | 3.1 GB 00:48:09 ETA
gcc-c++-tile-linux-gnu-4.8.5-1 FAILED ============= ] 4.3 MB/s | 3.1 GB 00:48:09 ETA
gcc-c++-x86_64-linux-gnu-4.8.5 FAILED ============= ] 4.3 MB/s | 3.1 GB 00:48:09 ETA
gcc-c++-xtensa-linux-gnu-4.8.5 FAILED ============= ] 4.3 MB/s | 3.1 GB 00:48:09 ETA
---
Steps To Reproducefollowing options are provided

reposync -m --download-metadata --allow-path-traversal -l -d --repoid=<repo>--newest-only --download_path=/<path>
TagsNo tags attached.
abrt_hash
URL

Activities

noremorze

noremorze

2019-06-01 09:12

reporter   ~0034566

file with only a + are also not synced

gtk+-devel-1.2.10-77.el7.x86_6 FAILED
noremorze

noremorze

2019-06-01 09:14

reporter   ~0034567

oh and on a sidenote ... reposync is running in docker container when syncing
using centos:latest image
underlying OS is SLES15
TrevorH

TrevorH

2019-06-01 09:52

manager   ~0034569

It works perfectly here so the problem is either with your SLES system or the filesystem you are attempting to use it on. Are you sure that whatever filesystem you are trying to write to supports files containing + signs?

Added "includepkgs=gcc-c++*" to the [epel] section of /etc/yum.repos.d/epel.repo then ran
[root@centos7 ~]# reposync -m --download-metadata --allow-path-traversal -l -d --repoid=epel --newest-only --download_path=/tmp
Loaded plugins: priorities
epel/x86_64/metalink | 13 kB 00:00:00
epel/x86_64/group | 365 kB 00:00:00
epel/x86_64/updateinfo_zck | 1.4 MB 00:00:00
(1/26): gcc-c++-aarch64-linux-gnu-4.8.5-16.el7.1.x86_64.rpm | 4.3 MB 00:00:01
(2/26): gcc-c++-alpha-linux-gnu-4.8.5-16.el7.1.x86_64.rpm | 4.1 MB 00:00:00
(3/26): gcc-c++-arm-linux-gnu-4.8.5-16.el7.1.x86_64.rpm | 4.9 MB 00:00:00
(4/26): gcc-c++-avr32-linux-gnu-4.8.5-16.el7.1.x86_64.rpm | 4.0 MB 00:00:00
(5/26): gcc-c++-bfin-linux-gnu-4.8.5-16.el7.1.x86_64.rpm | 4.1 MB 00:00:00
(6/26): gcc-c++-c6x-linux-gnu-4.8.5-16.el7.1.x86_64.rpm | 6.2 MB 00:00:00
(7/26): gcc-c++-cris-linux-gnu-4.8.5-16.el7.1.x86_64.rpm | 3.9 MB 00:00:00
(8/26): gcc-c++-frv-linux-gnu-4.8.5-16.el7.1.x86_64.rpm | 4.1 MB 00:00:00
(9/26): gcc-c++-h8300-linux-gnu-4.8.5-16.el7.1.x86_64.rpm | 3.9 MB 00:00:00
(10/26): gcc-c++-hppa-linux-gnu-4.8.5-16.el7.1.x86_64.rpm | 8.1 MB 00:00:00
(11/26): gcc-c++-hppa64-linux-gnu-4.8.5-16.el7.1.x86_64.rpm | 4.1 MB 00:00:00
(12/26): gcc-c++-ia64-linux-gnu-4.8.5-16.el7.1.x86_64.rpm | 4.2 MB 00:00:00
(13/26): gcc-c++-m32r-linux-gnu-4.8.5-16.el7.1.x86_64.rpm | 4.0 MB 00:00:00
(14/26): gcc-c++-m68k-linux-gnu-4.8.5-16.el7.1.x86_64.rpm | 4.1 MB 00:00:00
(15/26): gcc-c++-microblaze-linux-gnu-4.8.5-16.el7.1.x86_64.rpm | 4.1 MB 00:00:00
(16/26): gcc-c++-mips64-linux-gnu-4.8.5-16.el7.1.x86_64.rpm | 4.7 MB 00:00:00
(17/26): gcc-c++-mn10300-linux-gnu-4.8.5-16.el7.1.x86_64.rpm | 4.0 MB 00:00:00
(18/26): gcc-c++-powerpc64-linux-gnu-4.8.5-16.el7.1.x86_64.rpm | 5.0 MB 00:00:00
(19/26): gcc-c++-ppc64-linux-gnu-4.8.5-16.el7.1.x86_64.rpm | 6.4 kB 00:00:00
(20/26): gcc-c++-s390x-linux-gnu-4.8.5-16.el7.1.x86_64.rpm | 4.4 MB 00:00:00
(21/26): gcc-c++-sh-linux-gnu-4.8.5-16.el7.1.x86_64.rpm | 8.6 MB 00:00:00
(22/26): gcc-c++-sh64-linux-gnu-4.8.5-16.el7.1.x86_64.rpm | 4.4 MB 00:00:00
(23/26): gcc-c++-sparc64-linux-gnu-4.8.5-16.el7.1.x86_64.rpm | 4.2 MB 00:00:00
(24/26): gcc-c++-tile-linux-gnu-4.8.5-16.el7.1.x86_64.rpm | 4.1 MB 00:00:00
(25/26): gcc-c++-x86_64-linux-gnu-4.8.5-16.el7.1.x86_64.rpm | 4.9 MB 00:00:00
(26/26): gcc-c++-xtensa-linux-gnu-4.8.5-16.el7.1.x86_64.rpm | 4.0 MB 00:00:00
[root@centos7 ~]#
[root@centos7 ~]# ls -la /tmp/epel/Packages/g/
total 118956
drwxr-xr-x. 2 root root 560 Jun 1 10:49 .
drwxr-xr-x. 3 root root 60 Jun 1 10:49 ..
-rw-r--r--. 1 root root 4489824 Jun 28 2017 gcc-c++-aarch64-linux-gnu-4.8.5-16.el7.1.x86_64.rpm
-rw-r--r--. 1 root root 4282932 Jun 28 2017 gcc-c++-alpha-linux-gnu-4.8.5-16.el7.1.x86_64.rpm
-rw-r--r--. 1 root root 5124672 Jun 28 2017 gcc-c++-arm-linux-gnu-4.8.5-16.el7.1.x86_64.rpm
-rw-r--r--. 1 root root 4228600 Jun 28 2017 gcc-c++-avr32-linux-gnu-4.8.5-16.el7.1.x86_64.rpm
-rw-r--r--. 1 root root 4261572 Jun 28 2017 gcc-c++-bfin-linux-gnu-4.8.5-16.el7.1.x86_64.rpm
-rw-r--r--. 1 root root 6506240 Jun 28 2017 gcc-c++-c6x-linux-gnu-4.8.5-16.el7.1.x86_64.rpm
-rw-r--r--. 1 root root 4086452 Jun 28 2017 gcc-c++-cris-linux-gnu-4.8.5-16.el7.1.x86_64.rpm
-rw-r--r--. 1 root root 4278320 Jun 28 2017 gcc-c++-frv-linux-gnu-4.8.5-16.el7.1.x86_64.rpm
-rw-r--r--. 1 root root 4108172 Jun 28 2017 gcc-c++-h8300-linux-gnu-4.8.5-16.el7.1.x86_64.rpm
-rw-r--r--. 1 root root 4322056 Jun 28 2017 gcc-c++-hppa64-linux-gnu-4.8.5-16.el7.1.x86_64.rpm
-rw-r--r--. 1 root root 8453876 Jun 28 2017 gcc-c++-hppa-linux-gnu-4.8.5-16.el7.1.x86_64.rpm
-rw-r--r--. 1 root root 4417784 Jun 28 2017 gcc-c++-ia64-linux-gnu-4.8.5-16.el7.1.x86_64.rpm
-rw-r--r--. 1 root root 4186172 Jun 28 2017 gcc-c++-m32r-linux-gnu-4.8.5-16.el7.1.x86_64.rpm
-rw-r--r--. 1 root root 4283628 Jun 28 2017 gcc-c++-m68k-linux-gnu-4.8.5-16.el7.1.x86_64.rpm
-rw-r--r--. 1 root root 4295168 Jun 28 2017 gcc-c++-microblaze-linux-gnu-4.8.5-16.el7.1.x86_64.rpm
-rw-r--r--. 1 root root 4911464 Jun 28 2017 gcc-c++-mips64-linux-gnu-4.8.5-16.el7.1.x86_64.rpm
-rw-r--r--. 1 root root 4183064 Jun 28 2017 gcc-c++-mn10300-linux-gnu-4.8.5-16.el7.1.x86_64.rpm
-rw-r--r--. 1 root root 5194304 Jun 28 2017 gcc-c++-powerpc64-linux-gnu-4.8.5-16.el7.1.x86_64.rpm
-rw-r--r--. 1 root root 6604 Jun 28 2017 gcc-c++-ppc64-linux-gnu-4.8.5-16.el7.1.x86_64.rpm
-rw-r--r--. 1 root root 4584788 Jun 28 2017 gcc-c++-s390x-linux-gnu-4.8.5-16.el7.1.x86_64.rpm
-rw-r--r--. 1 root root 4588376 Jun 28 2017 gcc-c++-sh64-linux-gnu-4.8.5-16.el7.1.x86_64.rpm
-rw-r--r--. 1 root root 8969072 Jun 28 2017 gcc-c++-sh-linux-gnu-4.8.5-16.el7.1.x86_64.rpm
-rw-r--r--. 1 root root 4384988 Jun 28 2017 gcc-c++-sparc64-linux-gnu-4.8.5-16.el7.1.x86_64.rpm
-rw-r--r--. 1 root root 4272560 Jun 28 2017 gcc-c++-tile-linux-gnu-4.8.5-16.el7.1.x86_64.rpm
-rw-r--r--. 1 root root 5155148 Jun 28 2017 gcc-c++-x86_64-linux-gnu-4.8.5-16.el7.1.x86_64.rpm
-rw-r--r--. 1 root root 4176044 Jun 28 2017 gcc-c++-xtensa-linux-gnu-4.8.5-16.el7.1.x86_64.rpm
[root@centos7 ~]#

Issue History

Date Modified Username Field Change
2019-06-01 08:55 noremorze New Issue
2019-06-01 09:12 noremorze Note Added: 0034566
2019-06-01 09:14 noremorze Note Added: 0034567
2019-06-01 09:52 TrevorH Status new => closed
2019-06-01 09:52 TrevorH Resolution open => fixed
2019-06-01 09:52 TrevorH Note Added: 0034569