View Issue Details

IDProjectCategoryView StatusLast Update
0016190CentOS-7libvirtpublic2019-06-17 14:30
Reportergalileo 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Product Version7.6.1810 
Target VersionFixed in Version 
Summary0016190: Update of libvirt-daemon fails with: Error unpacking rpm package ...
Description==============================================================================================================================================================================================================================================
 Package Arch Version Repository Size
==============================================================================================================================================================================================================================================
Updating:
 libvirt-daemon x86_64 4.5.0-10.el7_6.10 updates 830 k

Transaction Summary
==============================================================================================================================================================================================================================================
Upgrade 1 Package

Total download size: 830 k
Is this ok [y/d/N]: y
Downloading packages:
Delta RPMs disabled because /usr/bin/applydeltarpm not installed.
libvirt-daemon-4.5.0-10.el7_6.10.x86_64.rpm | 830 kB 00:00:00
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Updating : libvirt-daemon-4.5.0-10.el7_6.10.x86_64 1/2
Error unpacking rpm package libvirt-daemon-4.5.0-10.el7_6.10.x86_64
error: unpacking of archive failed on file /var/lib/libvirt/images: cpio: chown
  Verifying : libvirt-daemon-4.5.0-10.el7_6.10.x86_64 1/2
libvirt-daemon-4.5.0-10.el7_6.7.x86_64 was supposed to be removed but is not!
  Verifying : libvirt-daemon-4.5.0-10.el7_6.7.x86_64 2/2

Failed:
  libvirt-daemon.x86_64 0:4.5.0-10.el7_6.7 libvirt-daemon.x86_64 0:4.5.0-10.el7_6.10



Also fails with a package downloaded from: http://mirror.centos.org/centos/7/updates/x86_64/Packages/libvirt-daemon-4.5.0-10.el7_6.10.x86_64.rpm
Steps To Reproduceyum update
TagsNo tags attached.
abrt_hash
URL

Activities

TrevorH

TrevorH

2019-06-17 13:30

manager   ~0034681

This would appear to be a problem with the current status of your system. The usual explanation for things like this is that the target of a file/directory supplied by the package has been changed - for example marking it immutable with chattr or replacing a directory with a file of the same name (or vice versa). Check /var/lib/libvirt/images on your system for these problems and correct them and then try the update again.
galileo

galileo

2019-06-17 13:36

reporter   ~0034682

You are right, /var/lib/libvirt/images was a mount point on a remote file system.
Update worked after a umount. Newer seen this before and I have used this setup
for years now.
Sorry for the false alert.

Issue History

Date Modified Username Field Change
2019-06-17 13:27 galileo New Issue
2019-06-17 13:30 TrevorH Note Added: 0034681
2019-06-17 13:36 galileo Note Added: 0034682
2019-06-17 14:30 TrevorH Status new => closed
2019-06-17 14:30 TrevorH Resolution open => no change required