View Issue Details

IDProjectCategoryView StatusLast Update
0016322administrationBuild Policypublic2019-08-12 13:15
Reporterjongj 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionwon't fix 
PlatformOSRed Hat Enterprise Linux Server OS Version7.7 (Maipo)
Product Version 
Target VersionFixed in Version 
Summary0016322: Error: Package: xorgxrdp-0.2.10-1.el7.x86_64 (epel) (dependency escalation)
Descriptionepel package xorgxrdp-0.2.10-1.el7.x86_ is failing to install after recent xorg update.

please rebuild xorgxrdp against newer xorg packages.

# yum install xorgxrdp
Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-manager
Resolving Dependencies
--> Running transaction check
---> Package xorgxrdp.x86_64 0:0.2.10-1.el7 will be installed
--> Processing Dependency: xorg-x11-server-Xorg(x86-64) = 1.20.1 for package: xorgxrdp-0.2.10-1.el7.x86_64
--> Finished Dependency Resolution
Error: Package: xorgxrdp-0.2.10-1.el7.x86_64 (epel)
           Requires: xorg-x11-server-Xorg(x86-64) = 1.20.1
           Installed: xorg-x11-server-Xorg-1.20.4-7.el7.x86_64 (@rhel-7-server-rpms)
               xorg-x11-server-Xorg(x86-64) = 1.20.4-7.el7
           Available: xorg-x11-server-Xorg-1.15.0-7.el7.x86_64 (rhel-7-server-rpms)
               xorg-x11-server-Xorg(x86-64) = 1.15.0-7.el7
           Available: xorg-x11-server-Xorg-1.15.0-7.el7_0.3.x86_64 (rhel-7-server-rpms)
               xorg-x11-server-Xorg(x86-64) = 1.15.0-7.el7_0.3
           Available: xorg-x11-server-Xorg-1.15.0-32.el7.x86_64 (rhel-7-server-rpms)
               xorg-x11-server-Xorg(x86-64) = 1.15.0-32.el7
           Available: xorg-x11-server-Xorg-1.15.0-33.el7_1.x86_64 (rhel-7-server-rpms)
               xorg-x11-server-Xorg(x86-64) = 1.15.0-33.el7_1
           Available: xorg-x11-server-Xorg-1.17.2-10.el7.x86_64 (rhel-7-server-rpms)
               xorg-x11-server-Xorg(x86-64) = 1.17.2-10.el7
           Available: xorg-x11-server-Xorg-1.17.2-22.el7.x86_64 (rhel-7-server-rpms)
               xorg-x11-server-Xorg(x86-64) = 1.17.2-22.el7
           Available: xorg-x11-server-Xorg-1.19.3-11.el7.x86_64 (rhel-7-server-rpms)
               xorg-x11-server-Xorg(x86-64) = 1.19.3-11.el7
           Available: xorg-x11-server-Xorg-1.19.3-11.el7_4.1.x86_64 (rhel-7-server-rpms)
               xorg-x11-server-Xorg(x86-64) = 1.19.3-11.el7_4.1
           Available: xorg-x11-server-Xorg-1.19.3-11.el7_4.2.x86_64 (rhel-7-server-rpms)
               xorg-x11-server-Xorg(x86-64) = 1.19.3-11.el7_4.2
           Available: xorg-x11-server-Xorg-1.19.5-5.el7.x86_64 (rhel-7-server-rpms)
               xorg-x11-server-Xorg(x86-64) = 1.19.5-5.el7
           Available: xorg-x11-server-Xorg-1.19.5-5.1.el7_5.x86_64 (rhel-7-server-rpms)
               xorg-x11-server-Xorg(x86-64) = 1.19.5-5.1.el7_5
           Available: xorg-x11-server-Xorg-1.20.1-3.el7.x86_64 (rhel-7-server-rpms)
               xorg-x11-server-Xorg(x86-64) = 1.20.1-3.el7
           Available: xorg-x11-server-Xorg-1.20.1-5.el7.x86_64 (rhel-7-server-rpms)
               xorg-x11-server-Xorg(x86-64) = 1.20.1-5.el7
           Available: xorg-x11-server-Xorg-1.20.1-5.1.el7.x86_64 (rhel-7-server-rpms)
               xorg-x11-server-Xorg(x86-64) = 1.20.1-5.1.el7
           Available: xorg-x11-server-Xorg-1.20.1-5.2.el7_6.x86_64 (rhel-7-server-rpms)
               xorg-x11-server-Xorg(x86-64) = 1.20.1-5.2.el7_6
           Available: xorg-x11-server-Xorg-1.20.1-5.3.el7_6.x86_64 (rhel-7-server-rpms)
               xorg-x11-server-Xorg(x86-64) = 1.20.1-5.3.el7_6
           Available: xorg-x11-server-Xorg-1.20.1-5.6.el7_6.x86_64 (rhel-7-server-rpms)
               xorg-x11-server-Xorg(x86-64) = 1.20.1-5.6.el7_6
**********************************************************************
yum can be configured to try to resolve such errors by temporarily enabling
disabled repos and searching for missing dependencies.
To enable this functionality please set 'notify_only=0' in /etc/yum/pluginconf.d/search-disabled-repos.conf
**********************************************************************

Error: Package: xorgxrdp-0.2.10-1.el7.x86_64 (epel)
           Requires: xorg-x11-server-Xorg(x86-64) = 1.20.1
           Installed: xorg-x11-server-Xorg-1.20.4-7.el7.x86_64 (@rhel-7-server-rpms)
               xorg-x11-server-Xorg(x86-64) = 1.20.4-7.el7
           Available: xorg-x11-server-Xorg-1.15.0-7.el7.x86_64 (rhel-7-server-rpms)
               xorg-x11-server-Xorg(x86-64) = 1.15.0-7.el7
           Available: xorg-x11-server-Xorg-1.15.0-7.el7_0.3.x86_64 (rhel-7-server-rpms)
               xorg-x11-server-Xorg(x86-64) = 1.15.0-7.el7_0.3
           Available: xorg-x11-server-Xorg-1.15.0-32.el7.x86_64 (rhel-7-server-rpms)
               xorg-x11-server-Xorg(x86-64) = 1.15.0-32.el7
           Available: xorg-x11-server-Xorg-1.15.0-33.el7_1.x86_64 (rhel-7-server-rpms)
               xorg-x11-server-Xorg(x86-64) = 1.15.0-33.el7_1
           Available: xorg-x11-server-Xorg-1.17.2-10.el7.x86_64 (rhel-7-server-rpms)
               xorg-x11-server-Xorg(x86-64) = 1.17.2-10.el7
           Available: xorg-x11-server-Xorg-1.17.2-22.el7.x86_64 (rhel-7-server-rpms)
               xorg-x11-server-Xorg(x86-64) = 1.17.2-22.el7
           Available: xorg-x11-server-Xorg-1.19.3-11.el7.x86_64 (rhel-7-server-rpms)
               xorg-x11-server-Xorg(x86-64) = 1.19.3-11.el7
           Available: xorg-x11-server-Xorg-1.19.3-11.el7_4.1.x86_64 (rhel-7-server-rpms)
               xorg-x11-server-Xorg(x86-64) = 1.19.3-11.el7_4.1
           Available: xorg-x11-server-Xorg-1.19.3-11.el7_4.2.x86_64 (rhel-7-server-rpms)
               xorg-x11-server-Xorg(x86-64) = 1.19.3-11.el7_4.2
           Available: xorg-x11-server-Xorg-1.19.5-5.el7.x86_64 (rhel-7-server-rpms)
               xorg-x11-server-Xorg(x86-64) = 1.19.5-5.el7
           Available: xorg-x11-server-Xorg-1.19.5-5.1.el7_5.x86_64 (rhel-7-server-rpms)
               xorg-x11-server-Xorg(x86-64) = 1.19.5-5.1.el7_5
           Available: xorg-x11-server-Xorg-1.20.1-3.el7.x86_64 (rhel-7-server-rpms)
               xorg-x11-server-Xorg(x86-64) = 1.20.1-3.el7
           Available: xorg-x11-server-Xorg-1.20.1-5.el7.x86_64 (rhel-7-server-rpms)
               xorg-x11-server-Xorg(x86-64) = 1.20.1-5.el7
           Available: xorg-x11-server-Xorg-1.20.1-5.1.el7.x86_64 (rhel-7-server-rpms)
               xorg-x11-server-Xorg(x86-64) = 1.20.1-5.1.el7
           Available: xorg-x11-server-Xorg-1.20.1-5.2.el7_6.x86_64 (rhel-7-server-rpms)
               xorg-x11-server-Xorg(x86-64) = 1.20.1-5.2.el7_6
           Available: xorg-x11-server-Xorg-1.20.1-5.3.el7_6.x86_64 (rhel-7-server-rpms)
               xorg-x11-server-Xorg(x86-64) = 1.20.1-5.3.el7_6
           Available: xorg-x11-server-Xorg-1.20.1-5.6.el7_6.x86_64 (rhel-7-server-rpms)
               xorg-x11-server-Xorg(x86-64) = 1.20.1-5.6.el7_6
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

# wget http://mirror.centos.org/centos/7/os/x86_64/Packages/xorg-x11-server-Xorg-1.20.1-3.el7.x86_64.rpm
# rpm -i xorg-x11-server-Xorg-1.20.1-3.el7.x86_64.rpm
warning: xorg-x11-server-Xorg-1.20.1-3.el7.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID f4a80eb5: NOKEY
error: Failed dependencies:
    xorg-x11-server-Xorg < 1.20.4-6 conflicts with (installed) gdm-1:3.28.2-16.el7.x86_64
TagsNo tags attached.

Activities

TrevorH

TrevorH

2019-08-12 13:15

manager   ~0034948

This is an EPEL package and needs EPEL to solve it.

Issue History

Date Modified Username Field Change
2019-08-07 17:33 jongj New Issue
2019-08-12 13:15 TrevorH Status new => closed
2019-08-12 13:15 TrevorH Resolution open => won't fix
2019-08-12 13:15 TrevorH Note Added: 0034948