View Issue Details

IDProjectCategoryView StatusLast Update
0016338CentOS-7-OTHERpublic2019-08-15 14:18
Reportersergey chernomorets 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionwon't fix 
Product Version7.2.1511 
Target VersionFixed in Version 
Summary0016338: Ignore /proc/diskstat, /proc/partitions and /proc/bus/pci in OpenVZ-container
Descriptionnet-snmp-5.7.2-38.el7.centos.2.x86_64
CentOS Linux release 7.2.1511 (Core)
OpenVZ/Virtuozzo-container (kernel 3.10.0-862.11.6.vz7.64.7)

In OpenVZ/Virtuozzo 7 containers file /proc/diskstat is absent and file /proc/partitions is empty. So snmpd write errors in log:
> Aug 15 15:56:25 container snmpd[115]: diskio.c: cannot find statistics in /proc/partitions

Another problem with libpci: if snmpd build with libpci then it does not started in OpenVZ-container because /proc/bus/pci does not exists:
> snmpd: pcilib: Cannot open /proc/bus/pci
> snmpd: pcilib: Cannot find any working access method.

I think these problems may be prevented if snmpd will ignore these cases when exists directory /proc/vz - it's OpenVZ-specific thing.

Upstream report (with patch): https://sourceforge.net/p/net-snmp/bugs/2975/
TagsNo tags attached.
abrt_hash
URL

Activities

TrevorH

TrevorH

2019-08-15 14:18

manager   ~0034980

a) 7.2 is 4 years out of date
b) we don't support openvz at all
c) if you want a change in a package inherited from RHEL then you must get that into RHEL first. CentOS is a rebuild of RHEL and the only changes made are to remove branding and logos.

Issue History

Date Modified Username Field Change
2019-08-15 13:24 sergey chernomorets New Issue
2019-08-15 14:18 TrevorH Status new => closed
2019-08-15 14:18 TrevorH Resolution open => won't fix
2019-08-15 14:18 TrevorH Note Added: 0034980