View Issue Details

IDProjectCategoryView StatusLast Update
0016423SCLo[All Projects] generalpublic2020-11-17 14:21
Reportermatttbe 
PrioritynormalSeverityminorReproducibilityalways
Status acknowledgedResolutionopen 
Platformx86_64OSCentOSOS Version7.7.1908
Summary0016423: SCLo source repository does not exist for CentOS 7.7.1908
DescriptionFirst, thank you for maintaining this new CentOS 7.7 version!

The issue I have looks the same as what is described in #15606 : The new default version is 7.7.1908 and with this new version, there is no "repodata" dir for SCLO repos:

- http://vault.centos.org/centos/7/sclo/Source/rh/repodata/repomd.xml
- http://vault.centos.org/centos/7/sclo/Source/sclo/repodata/repomd.xml

So we can add the two repos (via centos-release-scl-rh package) but any "yum-builddep" or "yumdownloader --source" commands fail after:

[code]

(...)
centos-sclo-rh | 3.0 kB 00:00:00
http://vault.centos.org/centos/7/sclo/Source/rh/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
To address this issue please refer to the below wiki article
                                                                                                                                                                                                                                                                        
https://wiki.centos.org/yum-errors
                                                                                                                                                                                                                                                                        
If above article doesn't help to resolve this issue please use https://bugs.centos.org/.
                                                                                                                                                                                                                                                                        
failure: repodata/repomd.xml from centos-sclo-rh-source: [Errno 256] No more mirrors to try.
http://vault.centos.org/centos/7/sclo/Source/rh/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found

[/code]

The only solution seems to add: --disablerepo=centos-sclo-sclo --disablerepo=centos-sclo-rh
But that's not convenient :-)
Steps To Reproduceyum install -y centos-release-scl-rh yum-utils
yum-builddep gzip # error
yumdownloader --source gzip # error
Additional InformationI guess the resolution can be the same as done by @bstinson on https://bugs.centos.org/view.php?id=0015606
Tags7.7, 7.9, scl

Activities

gavin.llewellyn

gavin.llewellyn

2019-09-19 09:46

reporter   ~0035136

I can't believe this has happened again with the next CentOS release. I'm sure I don't need to remind you that with most of this software, publishing "derivative work" binaries without providing the associated source code is in breach of the software licenses. It's time to fix your release process.
matttbe

matttbe

2020-11-14 10:34

reporter   ~0037902

I have the same issue when switching to 7.9.

I didn't notice this was fixed in 7.7 (and 7.8). Do you want me to open a new bug report?
matttbe

matttbe

2020-11-14 10:58

reporter   ~0037903

Note that centosplus source are also missing in 7.9 :)

Issue History

Date Modified Username Field Change
2019-09-19 08:50 matttbe New Issue
2019-09-19 08:50 matttbe Tag Attached: 7.7
2019-09-19 09:46 gavin.llewellyn Note Added: 0035136
2020-11-14 10:34 matttbe Note Added: 0037902
2020-11-14 10:35 matttbe Tag Attached: scl
2020-11-14 10:35 matttbe Tag Attached: 7.9
2020-11-14 10:58 matttbe Note Added: 0037903
2020-11-14 16:17 toracat Status new => acknowledged