View Issue Details

IDProjectCategoryView StatusLast Update
0016449CentOS-7rp-pppoepublic2019-09-24 18:03
Reporteragoodm 
PrioritylowSeverityminorReproducibilityalways
Status newResolutionopen 
Product Version7.6.1810 
Target VersionFixed in Version 
Summary0016449: rp-pppoe not compiled with kernel mode enabled for pppoe-server
Descriptionpppoe-server in CentOS 7 is not compiled with kernel mode enabled. This prevents you from using the -k command line switch and causes performance of pppoe-server to be extremely reduced. In my testing kernel mode is over 600% faster. There was a similar bug in RHEL6 https://bugzilla.redhat.com/show_bug.cgi?id=841194
Steps To ReproduceInstall rp-pppoe
Try to start pppoe-server with -k switch. Find that you cant.
Additional InformationI tested this by downloading rp-pppoe srpm, untarring the sources, editing pppoe-server.c and adding line "#define HAVE_LINUX_KERNEL_PPPOE 1" before tarring the sources back up and building the rpm in the normal manner. After removing the original rp-pppoe and installing my modified RPM I was able to run pppoe-server with the -k switch and observe higher performance as a result.

I ran into an issue after compiling the RPM in this manner whereby pppoe-server is looking for the kernel module in the wrong place, I worked around this by creating a sym link. Obviously someone should work out a better solution when you roll out the fix.

I state that kernel mode is more than 600% faster since I ran into a cpu based limitation for my test tool, rather than a performance limitation caused by pppoe-server while testing.
TagsNo tags attached.
abrt_hash
URL

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2019-09-24 18:03 agoodm New Issue