View Issue Details

IDProjectCategoryView StatusLast Update
0016456CentOS-8anacondapublic2020-05-03 07:16
Reporterrustyx Assigned To 
Status resolvedResolutionfixed 
Product Version8.0.1905 
Summary0016456: CentOS 8 Netinstall broken: "Error setting up base repository"
DescriptionIt is impossible to do network installation using 8.0.1905-boot image.

The installer cannot find any mirrors, and rejects any manually-provided repo URL.
Steps To ReproduceDownload the 8 boot image.
Try installing CentOS 8 using it.


parent of 0016633 closedarrfab mirror fails when requesting$infra 




2019-09-25 19:58

reporter   ~0035216

I sniffed the traffic of the machine being installed and noticed, that it attempts a GET request to$infra
where the response is:
Invalid release/repo/arch combination

So I tried manually with curl and a modified URL (only the major release number):$infra
and successfully got a mirror list.

I don't know, if this is a bug in anaconda (wrongly requesting the full qualified release number) or the setup of (wrongly only accepting a major release number), so please redirect it if appropriate.


2019-09-26 04:27

reporter   ~0035222

I confirm the issue. After configuring the repo to use I can continue with the installation.


2019-09-26 04:45

reporter   ~0035223

Same here. No direct link is allowed to proceed. Only mirror one as mentioned above.


2019-09-26 08:20

reporter   ~0035229

I can NOT confirm the observation of the other guys, that direct repo URLs are not possible.
If i fetch with curl manually on another computer and then use one of the lines of the response
(e.g.: ) AND select "repository URL" in the "URL type" combobox below the URL field, then it works with direkt URLs as well.
Maybe you guys have overlooked the "URL type" combo box?


2019-09-27 00:44

reporter   ~0035243

I had the same issue! Automatic fetching of mirrors failed, and using the instructions above (inputing the release 8 URL) manually worked.

Looking at journalctl, I found this:

Cannot download '$infra': Cannot Prepare internal mirrorlist: No URLs in mirrorlist.

Which seems to have worked fine after the above fix. Unfortunately it's a VM, so I can't exactly get the complete journalctl output.


2019-09-27 01:11

reporter   ~0035244

> Maybe you guys have overlooked the "URL type" combo box?
I tried to substitute link to local intranet repo and failed.


2019-09-27 01:20

reporter   ~0035245

Well. Sorry for the noise, found error in my setup. Direct manually entered link really works as expected.


2019-10-12 17:57

reporter   ~0035454

I can confirm this issue when installing from CentOS-8-x86_64-1905-boot.iso.

How to reproduce:
1. Select Installation source -> Network -> Closest mirror
2. Check the logs

From /tmp/dnf.librepo.log:

2019-10-12T17:40:47Z DEBUG lr_handle_prepare_internal_mirrorlist: Preparing internal mirrorlist
2019-10-12T17:40:47Z DEBUG lr_download: Target:$infra (-)
2019-10-12T17:40:47Z DEBUG select_next_target: Selecting mirror for:$infra
2019-10-12T17:40:47Z DEBUG prepare_next_transfer: URL:$infra
2019-10-12T17:40:47Z DEBUG add_librepo_xattr: Cannot set xattr user.Librepo.DownloadInProgress (fd: 31): Operation not supported
2019-10-12T17:40:47Z DEBUG lr_download: Downloading started
2019-10-12T17:40:48Z DEBUG check_transfer_statuses: Transfer finished:$infra (Effective url:$infra)
2019-10-12T17:40:48Z DEBUG lr_handle_prepare_mirrorlist: Parsing mirrorlist
2019-10-12T17:40:48Z DEBUG lr_handle_prepare_mirrorlist: No URLs in mirrorlist
2019-10-12T17:40:48Z DEBUG lr_handle_prepare_internal_mirrorlist: LRO_MIRRORLISTURL processing failed
2019-10-12T17:40:48Z DEBUG Cannot prepare internal mirrorlist: No URLs in mirrorlist

And the same for the extras repo:

2019-10-12T17:40:49Z DEBUG lr_handle_prepare_internal_mirrorlist: Preparing internal mirrorlist
2019-10-12T17:40:49Z DEBUG lr_download: Target:$infra (-)
2019-10-12T17:40:49Z DEBUG select_next_target: Selecting mirror for:$infra
2019-10-12T17:40:49Z DEBUG prepare_next_transfer: URL:$infra
2019-10-12T17:40:49Z DEBUG add_librepo_xattr: Cannot set xattr user.Librepo.DownloadInProgress (fd: 31): Operation not supported
2019-10-12T17:40:49Z DEBUG lr_download: Downloading started
2019-10-12T17:40:50Z DEBUG check_transfer_statuses: Transfer finished:$infra (Effective url:$infra)
2019-10-12T17:40:50Z DEBUG lr_handle_prepare_mirrorlist: Parsing mirrorlist
2019-10-12T17:40:50Z DEBUG lr_handle_prepare_mirrorlist: No URLs in mirrorlist
2019-10-12T17:40:50Z DEBUG lr_handle_prepare_internal_mirrorlist: LRO_MIRRORLISTURL processing failed
2019-10-12T17:40:50Z DEBUG Cannot prepare internal mirrorlist: No URLs in mirrorlist
2019-10-12T17:40:50Z DEBUG Librepo version: 1.9.2 with CURL_GLOBAL_ACK_EINTR support (libcurl/7.61.1 OpenSSL/1.1.1 zlib/1.2.11 brotli/1.0.6 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.5) libssh/0.8.5/openssl/zlib nghttp2/1.33.0)

That means with 'Closest mirror' no closest mirror is actually selected and thus no installation source is available.

Manually enter some mirror-url as installation source, e.g. https and


2019-10-15 09:06

reporter   ~0035480


How on earth did this get past QA? does not inspire confidence when the worst OS installer in the world can't even do just that. :-|


2019-10-15 15:57

reporter   ~0035486

Found a video ""
Enter method "http" and URL "" then the problem has been solved.


2019-10-21 06:24

reporter   ~0035533

Just a note on the above, the URL provided for the sample mirror from @qholi is missing a folder, and should be:
"...Enter method "http" and URL "" ..."


2019-10-21 09:54

reporter   ~0035534

See also


2019-10-21 11:29

administrator   ~0035535

Hi, I've assigned this one to @bstinson to investigate what needs to be adapted in anaconda to act like if that was on a normal setup : $releasever should resolve to 8 (and for Streams, it would need to be investigated too) and *not* $major.$minor
Also closing the mirrorlist bug mentioned above, as it was clearly designed to *not* answer for specific $major.$minor (only $major, meaning only last one) : we don't want to give false impression that we still validate older trees, without any security updates, etc


2019-10-21 15:21

reporter   ~0035545

I should also note that even if you manually adjust the mirrorlist in the installer it then goes on to create a yum.repos.d file for BaseOS which is also broken in a similar way so you can't use yum in the installed system without manually adjusting the mirror settings again.


2019-10-25 11:00

reporter   ~0035578

Yes i agree, tried to installed it in a Virtual Box environment, the only way to get the installation done is to add a mirror by hand

2019-11-02 13:07

reporter   ~0035631

I tried to install centos 8 using the base ISO copied on an usb stick and got this issue too, fixed using the method suggested by jeremythebox. Thanks!


2019-11-12 20:48

reporter   ~0035679

This bug is still unresolved. Can anyone provide an answer for if this is going to be resolved? I tried the recommended fix above ( and still get the error setting up base repository.


2019-11-13 22:44

reporter   ~0035689

@arlen, you have to set that the repo url is and then it works


2019-11-14 02:19

reporter   ~0035690

@atem18 Thanks but this still does not work. I've provided a screenshot to prove it. Any tips are still appreciated!


2019-11-15 12:37

reporter   ~0035699

@arlen Where is that screenshot? I can't see it.

In any event, I've successfully used the broken ISO to install CentOS 8 a few days ago, so I know for a fact that it is possible. You need to manually specify the mirrorlist URL you have already tried and set the values in the comboboxes correctly. As I recall one of them needs to be set to `http://` and the other to `mirrorlist` or something similar. This also seems to fix the issue mentioned by @xylose as I have not experienced it at all.


2019-11-18 23:26

reporter   ~0035711

Any update on this? I agree with @unixpro on this... how did this get through the first stage of QA?


2019-11-18 23:30

reporter   ~0035712

BTW, for the work-around mentioned by others, make sure for the URL you DO NOT put the http:// or https://
Select the correct one from the drop down. When I typed in the protocol it failed.
Even though URL typically includes the protocol, in this case putting the protocol in the text field breaks it. This should be fixed as well. Parsing the input should look if the user put in the protocol.


2020-04-22 16:24

reporter   ~0036750

Looks like this also affects kickstart installations even on most recent CentOS-8.1.1911.


2020-04-23 10:47

reporter   ~0036754

Never mind, user error - had both url and cdrom by mistake in kickstart file. Now it works as expected.


2020-05-03 06:34

reporter   ~0036854

For me in version 1911 the issue is FIXED. We can close this bug.
I tested now.

Issue History

Date Modified Username Field Change
2019-09-25 10:24 rustyx New Issue
2019-09-25 19:58 felfert Note Added: 0035216
2019-09-26 04:27 hc6pe Note Added: 0035222
2019-09-26 04:45 krege Note Added: 0035223
2019-09-26 08:20 felfert Note Added: 0035229
2019-09-27 00:44 egberdun Note Added: 0035243
2019-09-27 01:11 krege Note Added: 0035244
2019-09-27 01:20 krege Note Added: 0035245
2019-10-12 17:57 gsauthof Note Added: 0035454
2019-10-15 09:06 unixpro Note Added: 0035480
2019-10-15 15:57 qholi Note Added: 0035486
2019-10-21 06:24 jeremybox Note Added: 0035533
2019-10-21 09:54 felfert Note Added: 0035534
2019-10-21 11:29 arrfab Note Added: 0035535
2019-10-21 11:32 arrfab Relationship added parent of 0016633
2019-10-21 15:21 xylose Note Added: 0035545
2019-10-21 18:14 toracat Status new => assigned
2019-10-25 11:00 mchoeti Note Added: 0035578
2019-11-02 13:07 Note Added: 0035631
2019-11-12 20:48 arlen Note Added: 0035679
2019-11-13 22:44 atem18 Note Added: 0035689
2019-11-14 02:19 arlen Note Added: 0035690
2019-11-15 12:37 Forinil Note Added: 0035699
2019-11-18 23:26 jwroysdon Note Added: 0035711
2019-11-18 23:30 jwroysdon Note Added: 0035712
2019-12-20 01:51 toracat Tag Attached: 8.0
2020-01-08 16:08 bstinson Status assigned => confirmed
2020-04-22 16:24 holdenSK Note Added: 0036750
2020-04-23 10:47 holdenSK Note Added: 0036754
2020-05-03 06:34 juvann Note Added: 0036854
2020-05-03 07:16 arrfab Status confirmed => resolved
2020-05-03 07:16 arrfab Resolution open => fixed