2017-08-16 14:55 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0001646CentOS-4centos-releasepublic2012-10-10 18:50
Reporteremoret 
PrioritynormalSeverityfeatureReproducibilityalways
StatusassignedResolutionreopened 
Product Version4.4 
Target VersionFixed in Version 
Summary0001646: Missing source repo
DescriptionIn trying to download source rpm files with yum, sources are not available:

$ yumdownloader --source ntp

For this to work, 2 things need to happen:
 * a new repo file needs to be created pointing to the SRPMS directory
 * the SRPMS directories for updates and os need to be yumified with createrepo
TagsNo tags attached.
Attached Files

-Relationships
has duplicate 0002035assignedJohnnyHughes Missing source repo in CentOS5 
+Relationships

-Notes

~0004360

JohnnyHughes (administrator)

Last edited: 2007-01-19 12:01

We understand that to use that feature, we need to make those changes.

The simple way to do that is to sym link the SRPMS dir down into each $ARCH repo and have it be available that way.

However, it does then double the time it takes to regenerate metadata for all the mirror sites, and people could be installing source RPMS accidentally.

This discussion has happened several times ... but we are just not sure that the convenience gained by a very small group of people (you are the 3rd to ask :P) is worth all the time spent doubling the rebuild time for metadata.

It also would require changes to the [os] repository so that it is no longer a copy of the DVD (but contains a symlink to ../SRPMS).

These are doable, but change some things significantly (especially the [os] repo).

~0004361

JohnnyHughes (administrator)

another option would be to publish the SRPMS as a separate repo ... we would have to make changes to the metadata build scripts for that. It would increase time to build the info, but would not impact the RPM repos.

That would probably be a better way to handle this.

~0004362

kbsingh@karan.org (administrator)

I would be ok to provide another .repo file which provides a means for source downloads, however not being enabled by default.

~0004363

emoret (reporter)

Yes, I was more thinking along the lines of a separate SRPMS repo disabled by default.

~0004366

JohnnyHughes (administrator)

Last edited: 2007-01-21 22:00

OK ... I have updated the master mirror and all the other mirrors will get updated as well.

for now, use this as the CentOS-SRPMS.repo file:

#------------------------------------------
[base-SRPMS]
name=CentOS-$releasever - Base SRPMS
baseurl=http://mirror.centos.org/centos/$releasever/os/SRPMS/
gpgcheck=1
gpgkey=http://mirror.centos.org/centos/RPM-GPG-KEY-centos4
priority=1
enabled=0

#released updates
[update-SRPMS]
name=CentOS-$releasever - Updates SRPMS
baseurl=http://mirror.centos.org/centos/$releasever/updates/SRPMS/
gpgcheck=1
gpgkey=http://mirror.centos.org/centos/RPM-GPG-KEY-centos4
priority=1
enabled=0

#packages used/produced in the build but not released
[addons-SRPMS]
name=CentOS-$releasever - Addons SRPMS
baseurl=http://mirror.centos.org/centos/$releasever/addons/SRPMS/
gpgcheck=1
gpgkey=http://mirror.centos.org/centos/RPM-GPG-KEY-centos4
priority=1
enabled=0

#additional packages that may be useful
[extras-SRPMS]
name=CentOS-$releasever - Extras SRPMS
baseurl=http://mirror.centos.org/centos/$releasever/extras/SRPMS/
gpgcheck=1
gpgkey=http://mirror.centos.org/centos/RPM-GPG-KEY-centos4
priority=1
enabled=0

#additional packages that extend functionality of existing packages
[centosplus-SRPMS]
name=CentOS-$releasever - Plus SRPMS
baseurl=http://mirror.centos.org/centos/$releasever/centosplus/SRPMS/
gpgcheck=1
enabled=0
gpgkey=http://mirror.centos.org/centos/RPM-GPG-KEY-centos4
priority=1

#contrib - packages by Centos Users
[contrib-SRPMS]
name=CentOS-$releasever - Contrib SRPMS
baseurl=http://mirror.centos.org/centos/$releasever/contrib/SRPMS/
gpgcheck=1
enabled=0
gpgkey=http://mirror.centos.org/centos/RPM-GPG-KEY-centos4
priority=1
#------------------------------------------

(do not use the [^] link at the end of the lines with links)

(obviously, enable the repos that you want to use)

~0005634

emoret (reporter)

I believe 4-4.3 is the latest update of the centos-release package. It seems to me that the CentOS-SRPMS.repo is still missing from the centos-release-4-4.3 package. Could you please include that file?

Thanks and regards,
__
Eric

~0006951

emoret (reporter)

This is missing from CentOS5 too

~0006952

JohnnyHughes (administrator)

it is not really missing as much as it is not needed by very many people and is probably not necessary in centos-release.

we also do not include the CentOS-Testing.repo file or the CentOS-Fasttrack.repo file.

I am not sure that many users need this file by default ... so I think just having a link to a file in the tree would be enough (and have it documented on the wiki).

what do other think?

~0008233

bochecha (reporter)

The best way would be IMHO to do it the way it is handled in Fedora: a separate repo file where you can manually enable the repositories or use "yumdownloader --source" (that can enable automatically the repositories).

And having a source repository is definitely a needed feature, at least to me :)

~0010181

emoret (reporter)

Could you please revisit this issue and create source repo entries in both CentOS4 and CentOS5. Disabling them by default would prevent n00b users to install unwanted packages by mistake and at the same time provide the flexibility to more advanced users.

Thank you

~0011032

rfdb (reporter)

Final straw, tired of gathering srpms by hand, I turn to yum.

Rant on: It's years after this issue was opened, but no disabled defaults came with a 5.3 or 4.8 install, and no mention on the wiki. Spend time searching and/or cobbling together source repo info.

Hurrah! Try to download some source. repomd.xml not found. Dig around, find many historic incidents of releases missing srpm repodata. As of today, 5.3 has its, but 4.8 doesn't.

So I've just lost half a day on this, and I'm back where I started. Why can't this be standard (disabled) yum configuration, and a standard part of updating the mirrors?

Rant off: But, thanks for all the time and energy you put in. It is appreciated.

~0011086

till (reporter)

This bug is also present in 5.4 and very annoying.

Afaics, the repos are already there so only the yum .repo conf files are missing... Can you please at least add the to a package likge centos-release-source?

~0011087

till (reporter)

btw the repos need to be called "-source" to work with yumdownloader --source, e.g updates-source and there is also a typo in the sample repo file from 2007-01-21 21:50 because it says "update-...", there is a "s" missing.

~0014103

jhein (reporter)

It would indeed be nice to have a package with the source repo files. I just had to grab a source rpm and re-remember where to find them [1] after seeing emptiness in, for instance, http://mirror.centos.org/centos/5.7/os/SRPMS/.

That said, it was mentioned in this thread that it should be documented on the wiki. I don't see such documentation at the moment. [2]

[1] For the record, they are in vault.centos.org

[2] I did find a hint in the wiki (for kernel srpms) after I wrote the above...
http://wiki.centos.org/HowTos/I_need_the_Kernel_Source
But it wasn't easy to find (searching for "source repo" in the wiki gets lots of unrelated chaff).

~0015913

mthibaut (reporter)

I have found a way to get this to work on CentOS 6.3. The problem here is that the $releasever variable only contains the number "6", not "6.3", so I had to hardcode the release in the file:

[base-source]
name=CentOS-$releasever - Base SRPMS
baseurl=http://vault.centos.org/6.3/os/Source/
gpgcheck=1
gpgkey=http://mirror.centos.org/centos/RPM-GPG-KEY-CentOS-6
priority=1
enabled=0

#released updates
[updates-source]
name=CentOS-$releasever - Updates SRPMS
baseurl=http://vault.centos.org/6.3/updates/Source/
gpgcheck=1
gpgkey=http://mirror.centos.org/centos/RPM-GPG-KEY-CentOS-6
priority=1
enabled=0

#packages used/produced in the build but not released
[addons-source]
name=CentOS-$releasever - Addons SRPMS
baseurl=http://vault.centos.org/6.3/addons/Source/
gpgcheck=1
gpgkey=http://mirror.centos.org/centos/RPM-GPG-KEY-CentOS-6
priority=1
enabled=0

#additional packages that may be useful
[extras-source]
name=CentOS-$releasever - Extras SRPMS
baseurl=http://vault.centos.org/6.3/extras/Source/
gpgcheck=1
gpgkey=http://mirror.centos.org/centos/RPM-GPG-KEY-CentOS-6
priority=1
enabled=0

#additional packages that extend functionality of existing packages
[centosplus-source]
name=CentOS-$releasever - Plus SRPMS
baseurl=http://vault.centos.org/6.3/centosplus/Source/
gpgcheck=1
enabled=0
gpgkey=http://mirror.centos.org/centos/RPM-GPG-KEY-CentOS-6
priority=1

#contrib - packages by Centos Users
[contrib-source]
name=CentOS-$releasever - Contrib SRPMS
baseurl=http://vault.centos.org/6.3/contrib/Source/
gpgcheck=1
enabled=0
gpgkey=http://mirror.centos.org/centos/RPM-GPG-KEY-CentOS-6
priority=1
+Notes

-Issue History
Date Modified Username Field Change
2007-01-19 03:23 emoret New Issue
2007-01-19 03:23 emoret Status new => assigned
2007-01-19 11:58 JohnnyHughes Note Added: 0004360
2007-01-19 12:01 JohnnyHughes Note Edited: 0004360
2007-01-19 12:05 JohnnyHughes Note Added: 0004361
2007-01-19 13:53 kbsingh@karan.org Note Added: 0004362
2007-01-19 17:15 emoret Note Added: 0004363
2007-01-21 21:50 JohnnyHughes Note Added: 0004366
2007-01-21 21:52 JohnnyHughes Note Edited: 0004366
2007-01-21 22:00 JohnnyHughes Note Edited: 0004366
2007-01-21 22:01 JohnnyHughes Status assigned => resolved
2007-01-21 22:01 JohnnyHughes Resolution open => fixed
2007-07-23 22:11 emoret Status resolved => feedback
2007-07-23 22:11 emoret Resolution fixed => reopened
2007-07-23 22:11 emoret Note Added: 0005634
2008-02-27 05:11 emoret Note Added: 0006951
2008-02-27 13:16 JohnnyHughes Note Added: 0006952
2008-02-28 15:36 toracat Relationship added has duplicate 0002035
2008-11-06 10:23 bochecha Note Added: 0008233
2009-10-27 19:26 emoret Note Added: 0010181
2010-02-24 16:48 rfdb Note Added: 0011032
2010-02-24 17:20 toracat Status feedback => assigned
2010-03-16 15:48 till Note Added: 0011086
2010-03-16 16:00 till Note Added: 0011087
2012-01-04 23:23 jhein Note Added: 0014103
2012-10-10 18:50 mthibaut Note Added: 0015913
+Issue History