View Issue Details

IDProjectCategoryView StatusLast Update
0016460CentOS-8loraxpublic2019-11-12 21:03
Reporterseaninspace 
PrioritynormalSeverityminorReproducibilityalways
Status newResolutionopen 
Product Version8.0.1905 
Target VersionFixed in Version 
Summary0016460: lorax-composer epends on anaconda-tui >= 29.19.0.41 which is unavailable
DescriptionWhen attempting to install lorax-composer DNF errors out with the following:

sudo dnf install lorax-composer
[...]
Error:
 Problem: cannot install the best candidate for the job
  - nothing provides anaconda-tui >= 29.19.0.41 needed by lorax-composer-28.14.23-7.el8_0.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

anaconda-tui (which is also in the AppStream OS repository) is available to install but is currently at 29.19.0.40-1.el8.
Steps To Reproducesudo dnf install lorax-composer
TagsNo tags attached.

Activities

u297b

u297b

2019-09-29 14:00

reporter   ~0035266

It seems to me that this is just an error (typo) in the spec file?

$ dnf info anaconda-tui
Source : anaconda-29.19.0.40-1.el8.src.rpm

$ dnf deplist lorax-composer | grep anaconda-tui
dependency: anaconda-tui
   provider: anaconda-tui-29.19.0.40-1.el8.x86_64
  dependency: anaconda-tui >= 29.19.0.41
  dependency: anaconda-tui >= 29.19.0.41

Almost seems like the "40-1" got concatenated into ".41"
seaninspace

seaninspace

2019-10-14 20:53

reporter   ~0035468

This looks to be resolved with the latest batch of updates. "dnf install cockpit-composer" completed successfully and pulled in:
* anaconda-tui 29.19.0.43-1.el8_0
* lorax-composer 28.14.23-7.el8_0

Thank you!

Issue History

Date Modified Username Field Change
2019-09-25 22:22 seaninspace New Issue
2019-09-29 14:00 u297b Note Added: 0035266
2019-10-14 20:53 seaninspace Note Added: 0035468