View Issue Details

IDProjectCategoryView StatusLast Update
0016471CentOS-8kmod-kvdopublic2019-10-02 05:02
ReporterjomaAT 
PriorityhighSeveritymajorReproducibilityalways
Status newResolutionopen 
Platformamd64OSCentosOS Version8
Product Version8.0.1905 
Target VersionFixed in Version 
Summary0016471: KVDO
DescriptionAfter updating from kernel 4.18.0-80.el8.x86_64 to 4.18.0-80.7.1.el8_0.x86_64 loading kvdo f ails.
Error message: modprobe: FATAL: Module kvdo not found in directory /lib/modules/4.18.0-80.7.1.el8_0.x86_64
VDO devices are no langer accessible
Steps To Reproduceyum upgrade
any vdo command that triggers modprobe kvdo
Additional InformationOf course, booting the old kernel is a workaround.

Thank you!
TagsVDO

Activities

kdrhr

kdrhr

2019-10-02 05:01

reporter   ~0035290

I confirm the problem. The current kmod-kvdo package contains modules for an old kernel:

# rpm -q kernel kmod-kvdo
kernel-4.18.0-80.7.1.el8_0.x86_64
kmod-kvdo-6.2.0.293-50.el8.x86_64
# rpm -ql kmod-kvdo| grep modules
/lib/modules/4.18.0-79.el8+2.x86_64
/lib/modules/4.18.0-79.el8+2.x86_64/extra
/lib/modules/4.18.0-79.el8+2.x86_64/extra/kmod-kvdo
/lib/modules/4.18.0-79.el8+2.x86_64/extra/kmod-kvdo/uds
/lib/modules/4.18.0-79.el8+2.x86_64/extra/kmod-kvdo/uds/uds.ko
/lib/modules/4.18.0-79.el8+2.x86_64/extra/kmod-kvdo/vdo
/lib/modules/4.18.0-79.el8+2.x86_64/extra/kmod-kvdo/vdo/kvdo.ko

VDO is unusable with the current kernel.

Issue History

Date Modified Username Field Change
2019-09-26 15:42 jomaAT New Issue
2019-09-26 15:42 jomaAT Tag Attached: VDO
2019-10-02 05:01 kdrhr Note Added: 0035290