View Issue Details

IDProjectCategoryView StatusLast Update
0016477CentOS-8anacondapublic2019-10-09 18:17
ReporterGuidoSunderovich 
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionno change required 
Product Version8.0.1905 
Target VersionFixed in Version 
Summary0016477: kickstart file not found when using boot (netinstall) iso image
DescriptionThe boot iso on a flash drive boots normally to grub menu. Add path to ks.cfg on kernel cmd line

      inst.ks=hd:sda3:/centos/ks.cfg

anaconda runs & halts with message run/image/ks.cfg "not found"

journalctl shows messge "error in fetch-kickstart-disk" + python traceback.

Strange, this worked yesterday!

Steps To ReproduceTried other mirrors for source of iso. Same result.
TagsNo tags attached.

Activities

GuidoSunderovich

GuidoSunderovich

2019-09-27 04:16

reporter   ~0035246

Clarifications

/run/install/ks.cfg : file not found

Pane is dead

journalctl:

/usr/sbin/fetch-kickstart-disk: line 24: rmdir: command not found


iscsi errors follow

python error traceback.

problem occurs on boot AND dvd1 versions
GuidoSunderovich

GuidoSunderovich

2019-09-27 05:05

reporter   ~0035247

Problem resolved.

The kickstart file had an unbalanced quotation mark (")!

And that was sufficient to create all sorts of irrelevant error messaging.

RHEL developers really ought to trap that type of innocent error more intelligently.

Issue History

Date Modified Username Field Change
2019-09-26 23:50 GuidoSunderovich New Issue
2019-09-27 04:16 GuidoSunderovich Note Added: 0035246
2019-09-27 05:05 GuidoSunderovich Note Added: 0035247
2019-10-09 18:17 TrevorH Status new => closed
2019-10-09 18:17 TrevorH Resolution open => no change required