View Issue Details

IDProjectCategoryView StatusLast Update
0016492CentOS-8_unreleased_devel_pkgspublic2020-04-02 08:44
Reportereesau 
PrioritynormalSeveritymajorReproducibilityalways
Status assignedResolutionopen 
Product Version8.0.1905 
Target VersionFixed in Version 
Summary0016492: No libssh2-devel package
DescriptionThere seems to be no libssh2-devel package in CentOS 8 repos. I found this from upstream:
https://access.redhat.com/discussions/4342891
but that didn't help, 'dnf module enable virt-devel' gives 'missing groups or modules: virt-devel' error.
Steps To Reproducednf list libssh2-devel
TagsNo tags attached.

Relationships

has duplicate 0016625 closed libssh2-devel-1.8.0-8.module_el8.0.0+189+f9babebb.1.x86_64 missing 
has duplicate 0016894 closedbstinson [RFE] libssh2-devel built but unreleased 
related to 0016626 acknowledgedbstinson Centos8 is missing many -devel rpms, and some other packages 
related to 0016549 resolvedbstinson [RFE] quota-devel package is missing in CentOS 8 PowerTools 
related to 0016795 assignedbstinson libdnf-devel is not available from CentOS 8.0 or CentOS Stream repositories 
related to 0016811 assignedbstinson package libepubgen-devel is omitted from the CentOS-Stream repositories 
related to 0016832 acknowledgedbstinson libnml-devel package is missing 
related to 0016826 resolvedbstinson libuv-devel package is missing 
related to 0016845 assignedbstinson Missing devel package 
related to 0017011 resolvedbstinson Package libss-devel is missing 
related to 0017032 confirmedbstinson devel packages missing from CentOS 8, needed by KDE 
related to 0016504 assignedbstinson libsmi-devel and libsmi-debuginfo not available in CentOS 8 
related to 0016620 resolvedbstinson twolame-devel omitted from release 
related to 0017081 newbstinson No libdnf-devel package available 
related to 0017092 newbstinson Missing libvirt-glib-devel 
related to 0017214 assignedbstinson libbluray-devel is not available 

Activities

AlphaCluster

AlphaCluster

2019-10-12 02:47

reporter   ~0035448

Any news on this? It seems like this package should be in PowerTools?

It seems to have been built with the libssh2 package on koji https://koji.mbox.centos.org/koji/buildinfo?buildID=4650
PryMar56

PryMar56

2019-10-19 21:44

reporter   ~0035529

Not only is libssh2-devel missing, but there is also no qemu-system-x86, which I tried to build. qemu-3.0.1 still has a libssh2-devel depends, but qemu-4.1.0 does not. Upstream qemu.git took it out, I believe the responsible developer is from Redhat.
https://lists.gnu.org/archive/html/qemu-devel/2019-06/msg02758.html

I'm currently packaging upstream xen-4.12.1 and xen-4.13~rc1 for CentOS 8. This is where I ran into this bug report.
limburgher

limburgher

2019-10-20 15:24

reporter   ~0035531

This is blocking my Copr build of zabbix as well.
Richard Jones

Richard Jones

2019-10-21 13:45

reporter   ~0035539

https://lists.centos.org/pipermail/centos-devel/2019-October/018011.html
limburgher

limburgher

2019-10-21 13:50

reporter   ~0035540

So. . .how will that impact the availability of libssh2-devel?
Richard Jones

Richard Jones

2019-10-21 13:56

reporter   ~0035541

It should be pretty clear: Starting with RHEL 8.1 it won't be shipped by Red Hat. I guess the reason it's missing now is a screw-up related to this.
limburgher

limburgher

2019-10-21 13:58

reporter   ~0035542

Thanks. it wasn't clear. So do you think they'll fix it for 8.0, or do we have to wait until 8.1 and add it to EPEL? And people who need it just don't use EL-8 for an entire point release?
AlphaCluster

AlphaCluster

2019-10-21 14:03

reporter   ~0035543

I found the build for libssh2 so I know there is a devel package that could be published? is there any reason to not publish this to powertools for the point release as it is published in RHEL? otherwise is there any reason not to go ask for the epel package at this time?
Richard Jones

Richard Jones

2019-10-21 14:19

reporter   ~0035544

I don't know, guess you'll have to ask Red Hat's RCM team.
toracat

toracat

2019-12-16 23:06

manager   ~0035846

"Unshipped -devel packages in CentOS Linux"
https://lists.centos.org/pipermail/centos-devel/2019-November/018082.html
gabrielvlasiu

gabrielvlasiu

2019-12-17 13:14

reporter   ~0035850

This is _very_ annoying. For example: libuser is needed by passwd, usermode, util-linux-user. So libuser-devel is built (koji) and used when building the above packages.
But if I try to use libuser-devel there is no way I can do that. Well, I can, if I re-compile libuser myself. But the list of packages needed to be built keep growing and growing.

And -devel packages are not the only ones:
Set GRUB_ENABLE_BLSCFG=false in /etc/default/grub, grub2-mkconfig --output=... and try to install a kernel. Nothing is added to /boot/grub2/grub.cfg.

Why?

Well, if we look in /usr/lib/kernel/install.d/20-grub.install we see that it needs /sbin/new-kernel-pkg. But grubby-deprecated (that provide new-kernel-pkg) is nowhere to be found (except in koji [https://koji.mbox.centos.org/koji/buildinfo?buildID=185]). And, you cannot manually download anything from koji anymore. Same to postfix (postfix-pcre). And many, many other packages.

It would be nice to have a repository with the remaining packages build in koji, somewhere... Because I don't want to build and keep tracking for yet another package just to have a sub-package that is already built and not provided to us. In the end, if the list of the missing packages keep growing and we have to build everything by ourself, why use CentOS (RH) in the first place?
ivanovaal

ivanovaal

2019-12-26 13:34

reporter   ~0035897

This issue is a problem. I can't build Rugged Ruby Gem with ssh support. It breaks functionality of Redmine Git Hosting plugin. I'm sure Redmine is not the only Ruby app that suffers from lack of this development package.
joeyos

joeyos

2020-02-28 15:38

reporter   ~0036401

For me, this is an issue that prevents me from upgrading and puts me in the situation of considering whether to wait it out or choose a different distribution.

The packages removed are both build dependencies of source RPMs and being able to compile software against the system libraries / packages. It creates a very hit an miss situation where anyone who compiles their own software, third party software or recompiles OS packages for the system is walking a potential minefield.

A holistic fix would really be ideal rather than doing it piece by piece. I considered building some of the missing packages myself but it's far from ideal. Not only in it being a lot of duplicate work but also keeping up to date with upstream updates and also assets in devel packages sometimes result from the build process meaning for optimal compatibility you would want to build and provide all of the packages from the SPEC where not all built packages are shipped.

Is there something specific that makes this difficult to address? Is it possible to in the build process compare built to shipped packages and put built but unshipped into another repo? Would it be possible to have a process that detects them, puts them in a private repo by default but then after being checked to see what they are and what they need into the unshipped repo?

I've heard some confusion about shipping them as modules. Is there something special that makes this more than simply RPMs missing from repos? Would they not still contain the relevant metadata?

Would it be a problem providing them if people start rolling their own already (I'm not sure if in their own repos)?

I'm not sure anything other than a holistic fix would really solve the problem.

At least one lazy way to get once sense of how much is missing could be to try to install all source rpms in dry run and capture error output about dependencies.

It really could do with tooling though. I think that might get a bit extensive. It's possible to figure out missing dependencies integrity checking the tree by traversing it fully (though it might need a small super computer if the full dependency resolution is used). That won't however detect leaf devel packages with no build dependants. For that would the RPMs not have to be fetched and then their SPEC's processed at least partially to determine if any RPMs it built are not available in current repositories? It might be enough with a fast check to go by name only rather than version?

Is there a script anywhere with a list or something that's responsible for these missing packages? What specifically is the thing that excludes them?

I assume their removal was via non-inclusion rather than exclusion which may make it difficult and is why there's not a list already available?

I found this probably lists most or a lot of things:

https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/8/html-single/considerations_in_adopting_rhel_8/index

> A.4. Removed packages

I'm not sure that it works however as a machine readable list or one that can be used without first studying. I think it mixes up valid removals from 7 to 8 to things that were really removed from 8 outright. IE, both 7 and 8 might have libuser, so both should have libuser-devel but 8 doesn't. If 8 removed libexample though because it we properly replaced or no longer supported, then that would be a true removal from 7 to 8.
Richard Jones

Richard Jones

2020-02-28 16:09

reporter   ~0036403

If it's that important to you I would suggest working on adding the package to EPEL 8.
PryMar56

PryMar56

2020-02-29 03:49

reporter   ~0036406

I set a goal of building recent xen, qemu-3.1,libvirt and supporting buid requires without using the rhel `virt module` from Appstream (198 packages with many *-devel, but not libssh2-devel). I stored the builds in 2 local repo, one for general use, the other with the `virt module` counterparts.

Before starting any mock session I did: dnf module disable virt(-devel).
I'm making progress, but without libguestfs. Attached is the latest install trace.

xen-412-full-stack-without-virt-module (24,683 bytes)
<mock-chroot> sh-4.4# dnf install libvirt xen xen-doc xen-ocaml qemuu --enablerepo=virt-xen4c
Last metadata expiration check: 1:32:22 ago on Fri 28 Feb 2020 04:33:03 PM PST.
Dependencies resolved.
==========================================================================================================================
 Package                                      Arch     Version                                         Repository    Size
==========================================================================================================================
Installing:
 qemuu                                        x86_64   1:3.0.1+2-2.el8                                 virt-xen4c   9.3 M
 xen                                          x86_64   1:4.12.2-2.el8                                  virt-xen4c   155 k
 xen-doc                                      x86_64   1:4.12.2-2.el8                                  virt-xen4c   349 k
 xen-ocaml                                    x86_64   1:4.12.2-2.el8                                  virt-xen4c   393 k
 libvirt                                      x86_64   5.1.0-9.el8                                     virt-xen4c    11 k
Installing dependencies:
 augeas-libs                                  x86_64   1.12.0-2.el8                                    BaseOS       436 k
 avahi-libs                                   x86_64   0.7-19.el8                                      BaseOS        62 k
 bluez-libs                                   x86_64   5.50-1.el8                                      BaseOS        91 k
 cyrus-sasl                                   x86_64   2.1.27-1.el8                                    BaseOS        96 k
 cyrus-sasl-gssapi                            x86_64   2.1.27-1.el8                                    BaseOS        49 k
 dejavu-fonts-common                          noarch   2.35-6.el8                                      BaseOS        74 k
 dejavu-sans-fonts                            noarch   2.35-6.el8                                      BaseOS       1.5 M
 device-mapper-event                          x86_64   8:1.02.163-5.el8.0.1                            BaseOS       266 k
 device-mapper-event-libs                     x86_64   8:1.02.163-5.el8.0.1                            BaseOS       265 k
 device-mapper-persistent-data                x86_64   0.8.5-2.el8                                     BaseOS       473 k
 dmidecode                                    x86_64   1:3.2-3.el8                                     BaseOS        89 k
 e2fsprogs-libs                               x86_64   1.44.6-3.el8                                    BaseOS       208 k
 fontconfig                                   x86_64   2.13.1-3.el8                                    BaseOS       275 k
 fontpackages-filesystem                      noarch   1.44-22.el8                                     BaseOS        16 k
 freetype                                     x86_64   2.9.1-4.el8                                     BaseOS       393 k
 glusterfs                                    x86_64   6.0-15.el8                                      BaseOS       661 k
 glusterfs-client-xlators                     x86_64   6.0-15.el8                                      BaseOS       868 k
 glusterfs-libs                               x86_64   6.0-15.el8                                      BaseOS       412 k
 gssproxy                                     x86_64   0.8.0-14.el8                                    BaseOS       118 k
 hwdata                                       noarch   0.314-8.2.el8_1                                 BaseOS       1.6 M
 iproute                                      x86_64   4.18.0-15.el8                                   BaseOS       616 k
 iproute-tc                                   x86_64   4.18.0-15.el8                                   BaseOS       412 k
 iptables                                     x86_64   1.8.2-16.el8                                    BaseOS       586 k
 iptables-ebtables                            x86_64   1.8.2-16.el8                                    BaseOS        68 k
 iscsi-initiator-utils                        x86_64   6.2.0.877-1.gitf71581b.el8                      BaseOS       375 k
 iscsi-initiator-utils-iscsiuio               x86_64   6.2.0.877-1.gitf71581b.el8                      BaseOS        99 k
 isns-utils-libs                              x86_64   0.99-1.el8                                      BaseOS       105 k
 keyutils                                     x86_64   1.5.10-6.el8                                    BaseOS        63 k
 libaio                                       x86_64   0.3.112-1.el8                                   BaseOS        33 k
 libbasicobjects                              x86_64   0.1.1-39.el8                                    BaseOS        31 k
 libcollection                                x86_64   0.7.0-39.el8                                    BaseOS        48 k
 libibverbs                                   x86_64   22.3-1.el8                                      BaseOS       239 k
 libicu                                       x86_64   60.3-1.el8                                      BaseOS       8.8 M
 libini_config                                x86_64   1.3.1-39.el8                                    BaseOS        70 k
 libmnl                                       x86_64   1.0.4-6.el8                                     BaseOS        30 k
 libnetfilter_conntrack                       x86_64   1.0.6-5.el8                                     BaseOS        65 k
 libnfnetlink                                 x86_64   1.0.1-13.el8                                    BaseOS        33 k
 libnfsidmap                                  x86_64   1:2.3.3-26.el8                                  BaseOS       118 k
 libnftnl                                     x86_64   1.1.1-4.el8                                     BaseOS        83 k
 libnl3                                       x86_64   3.4.0-5.el8                                     BaseOS       311 k
 libpath_utils                                x86_64   0.2.1-39.el8                                    BaseOS        34 k
 libpciaccess                                 x86_64   0.14-1.el8                                      BaseOS        32 k
 libpng                                       x86_64   2:1.6.34-5.el8                                  BaseOS       126 k
 librdmacm                                    x86_64   22.3-1.el8                                      BaseOS        70 k
 libref_array                                 x86_64   0.1.5-39.el8                                    BaseOS        33 k
 libselinux-utils                             x86_64   2.9-2.1.el8                                     BaseOS       243 k
 libverto-libevent                            x86_64   0.3.0-5.el8                                     BaseOS        16 k
 libxslt                                      x86_64   1.1.32-3.el8                                    BaseOS       249 k
 lvm2                                         x86_64   8:2.03.05-5.el8.0.1                             BaseOS       1.5 M
 lvm2-libs                                    x86_64   8:2.03.05-5.el8.0.1                             BaseOS       1.1 M
 lzo                                          x86_64   2.08-14.el8                                     BaseOS        69 k
 lzop                                         x86_64   1.03-20.el8                                     BaseOS        62 k
 mozjs60                                      x86_64   60.9.0-3.el8                                    BaseOS       6.7 M
 nfs-utils                                    x86_64   1:2.3.3-26.el8                                  BaseOS       472 k
 numactl-libs                                 x86_64   2.0.12-7.el8                                    BaseOS        36 k
 numad                                        x86_64   0.5-26.20150602git.el8                          BaseOS        41 k
 parted                                       x86_64   3.2-38.el8                                      BaseOS       557 k
 pciutils                                     x86_64   3.5.6-4.el8                                     BaseOS       105 k
 pciutils-libs                                x86_64   3.5.6-4.el8                                     BaseOS        53 k
 policycoreutils                              x86_64   2.9-3.el8_1.1                                   BaseOS       377 k
 polkit                                       x86_64   0.115-9.el8                                     BaseOS       154 k
 polkit-libs                                  x86_64   0.115-9.el8                                     BaseOS        76 k
 polkit-pkla-compat                           x86_64   0.1-12.el8                                      BaseOS        46 k
 python3-setuptools                           noarch   39.2.0-5.el8                                    BaseOS       162 k
 quota                                        x86_64   1:4.04-10.el8                                   BaseOS       214 k
 quota-nls                                    noarch   1:4.04-10.el8                                   BaseOS        94 k
 rdma-core                                    x86_64   22.3-1.el8                                      BaseOS        53 k
 rpcbind                                      x86_64   1.2.5-4.el8                                     BaseOS        70 k
 systemd-container                            x86_64   239-18.el8_1.4                                  BaseOS       500 k
 xml-common                                   noarch   0.6.3-50.el8                                    BaseOS        39 k
 alsa-lib                                     x86_64   1.1.9-4.el8                                     AppStream    429 k
 autogen-libopts                              x86_64   5.18.12-7.el8                                   AppStream     75 k
 boost-atomic                                 x86_64   1.66.0-6.el8                                    AppStream     13 k
 boost-chrono                                 x86_64   1.66.0-6.el8                                    AppStream     23 k
 boost-date-time                              x86_64   1.66.0-6.el8                                    AppStream     29 k
 boost-iostreams                              x86_64   1.66.0-6.el8                                    AppStream     39 k
 boost-program-options                        x86_64   1.66.0-6.el8                                    AppStream    143 k
 boost-random                                 x86_64   1.66.0-6.el8                                    AppStream     22 k
 boost-regex                                  x86_64   1.66.0-6.el8                                    AppStream    286 k
 boost-system                                 x86_64   1.66.0-6.el8                                    AppStream     18 k
 boost-thread                                 x86_64   1.66.0-6.el8                                    AppStream     59 k
 brlapi                                       x86_64   0.6.7-28.el8                                    AppStream    170 k
 brltty                                       x86_64   5.6-28.el8                                      AppStream    1.3 M
 cairo                                        x86_64   1.15.12-3.el8                                   AppStream    721 k
 celt051                                      x86_64   0.5.1.3-15.el8                                  AppStream     63 k
 dnsmasq                                      x86_64   2.79-6.el8                                      AppStream    317 k
 fribidi                                      x86_64   1.0.4-7.el8_1                                   AppStream     89 k
 glusterfs-api                                x86_64   6.0-15.el8                                      AppStream     93 k
 glusterfs-cli                                x86_64   6.0-15.el8                                      AppStream    189 k
 gnutls-dane                                  x86_64   3.6.8-8.el8                                     AppStream     45 k
 gnutls-utils                                 x86_64   3.6.8-8.el8                                     AppStream    341 k
 graphite2                                    x86_64   1.3.10-10.el8                                   AppStream    122 k
 gstreamer1                                   x86_64   1.14.0-3.el8                                    AppStream    1.3 M
 gstreamer1-plugins-base                      x86_64   1.14.0-4.el8                                    AppStream    1.8 M
 harfbuzz                                     x86_64   1.7.5-3.el8                                     AppStream    295 k
 iso-codes                                    noarch   3.79-2.el8                                      AppStream    3.4 M
 libX11                                       x86_64   1.6.7-1.el8                                     AppStream    612 k
 libX11-common                                noarch   1.6.7-1.el8                                     AppStream    157 k
 libX11-xcb                                   x86_64   1.6.7-1.el8                                     AppStream     14 k
 libXau                                       x86_64   1.0.8-13.el8                                    AppStream     36 k
 libXdamage                                   x86_64   1.1.4-14.el8                                    AppStream     27 k
 libXext                                      x86_64   1.3.3-9.el8                                     AppStream     45 k
 libXfixes                                    x86_64   5.0.3-7.el8                                     AppStream     25 k
 libXft                                       x86_64   2.3.2-10.el8                                    AppStream     66 k
 libXi                                        x86_64   1.7.9-7.el8                                     AppStream     49 k
 libXrender                                   x86_64   0.9.10-7.el8                                    AppStream     33 k
 libXtst                                      x86_64   1.2.3-7.el8                                     AppStream     22 k
 libXv                                        x86_64   1.0.11-7.el8                                    AppStream     20 k
 libXxf86vm                                   x86_64   1.1.4-9.el8                                     AppStream     19 k
 libdatrie                                    x86_64   0.2.9-7.el8                                     AppStream     33 k
 libdrm                                       x86_64   2.4.98-2.el8                                    AppStream    165 k
 libglvnd                                     x86_64   1:1.0.1-0.9.git5baa1e5.el8                      AppStream     95 k
 libglvnd-egl                                 x86_64   1:1.0.1-0.9.git5baa1e5.el8                      AppStream     50 k
 libglvnd-gles                                x86_64   1:1.0.1-0.9.git5baa1e5.el8                      AppStream     41 k
 libglvnd-glx                                 x86_64   1:1.0.1-0.9.git5baa1e5.el8                      AppStream    131 k
 libjpeg-turbo                                x86_64   1.5.3-10.el8                                    AppStream    156 k
 libogg                                       x86_64   2:1.3.2-10.el8                                  AppStream     31 k
 librados2                                    x86_64   1:12.2.7-9.el8                                  AppStream    2.9 M
 librbd1                                      x86_64   1:12.2.7-9.el8                                  AppStream    1.1 M
 libthai                                      x86_64   0.1.27-2.el8                                    AppStream    203 k
 libtheora                                    x86_64   1:1.1.1-21.el8                                  AppStream    184 k
 libvisual                                    x86_64   1:0.4.0-24.el8                                  AppStream    145 k
 libvorbis                                    x86_64   1:1.3.6-2.el8                                   AppStream    196 k
 libwayland-client                            x86_64   1.15.0-1.el8                                    AppStream     39 k
 libwayland-cursor                            x86_64   1.15.0-1.el8                                    AppStream     26 k
 libwayland-egl                               x86_64   1.15.0-1.el8                                    AppStream     19 k
 libwayland-server                            x86_64   1.15.0-1.el8                                    AppStream     45 k
 libxcb                                       x86_64   1.13-5.el8                                      AppStream    230 k
 libxshmfence                                 x86_64   1.3-2.el8                                       AppStream     13 k
 mesa-libEGL                                  x86_64   19.1.4-3.el8_1                                  AppStream    131 k
 mesa-libGL                                   x86_64   19.1.4-3.el8_1                                  AppStream    184 k
 mesa-libgbm                                  x86_64   19.1.4-3.el8_1                                  AppStream     55 k
 mesa-libglapi                                x86_64   19.1.4-3.el8_1                                  AppStream     61 k
 nmap-ncat                                    x86_64   2:7.70-5.el8                                    AppStream    237 k
 nspr                                         x86_64   4.21.0-2.el8_0                                  AppStream    143 k
 nss                                          x86_64   3.44.0-9.el8_1                                  AppStream    724 k
 nss-softokn                                  x86_64   3.44.0-9.el8_1                                  AppStream    472 k
 nss-softokn-freebl                           x86_64   3.44.0-9.el8_1                                  AppStream    273 k
 nss-sysinit                                  x86_64   3.44.0-9.el8_1                                  AppStream     69 k
 nss-util                                     x86_64   3.44.0-9.el8_1                                  AppStream    135 k
 opus                                         x86_64   1.3-0.4.beta.el8                                AppStream    204 k
 orc                                          x86_64   0.4.28-2.el8                                    AppStream    175 k
 pango                                        x86_64   1.42.4-6.el8                                    AppStream    298 k
 pixman                                       x86_64   0.36.0-1.el8                                    AppStream    256 k
 python3-lxml                                 x86_64   4.2.3-1.el8                                     AppStream    1.5 M
 python3-pip                                  noarch   9.0.3-15.el8                                    AppStream     19 k
 python3-webencodings                         noarch   0.5.1-6.el8                                     AppStream     27 k
 python36                                     x86_64   3.6.8-2.module_el8.1.0+245+c39af44f             AppStream     19 k
 qemu-img                                     x86_64   15:2.12.0-88.module_el8.1.0+258+1d2a1d58.1      AppStream    1.7 M
 radvd                                        x86_64   2.17-12.el8                                     AppStream    104 k
 spice-server                                 x86_64   0.14.2-1.el8                                    AppStream    405 k
 usbredir                                     x86_64   0.8.0-1.el8                                     AppStream     50 k
 yajl                                         x86_64   2.1.0-10.el8                                    AppStream     41 k
 SDL2                                         x86_64   2.0.8-7.el8                                     PowerTools   429 k
 xen-hypervisor                               x86_64   1:4.12.2-2.el8                                  virt-xen4c   3.5 M
 xen-libs                                     x86_64   1:4.12.2-2.el8                                  virt-xen4c   615 k
 xen-licenses                                 x86_64   1:4.12.2-2.el8                                  virt-xen4c    72 k
 xen-runtime                                  x86_64   1:4.12.2-2.el8                                  virt-xen4c   8.1 M
 libvirt-bash-completion                      x86_64   5.1.0-9.el8                                     virt-xen4c    12 k
 libvirt-client                               x86_64   5.1.0-9.el8                                     virt-xen4c   318 k
 libvirt-daemon                               x86_64   5.1.0-9.el8                                     virt-xen4c   682 k
 libvirt-daemon-config-network                x86_64   5.1.0-9.el8                                     virt-xen4c    12 k
 libvirt-daemon-config-nwfilter               x86_64   5.1.0-9.el8                                     virt-xen4c    17 k
 libvirt-daemon-driver-interface              x86_64   5.1.0-9.el8                                     virt-xen4c    89 k
 libvirt-daemon-driver-libxl                  x86_64   5.1.0-9.el8                                     virt-xen4c   195 k
 libvirt-daemon-driver-network                x86_64   5.1.0-9.el8                                     virt-xen4c   231 k
 libvirt-daemon-driver-nodedev                x86_64   5.1.0-9.el8                                     virt-xen4c    89 k
 libvirt-daemon-driver-nwfilter               x86_64   5.1.0-9.el8                                     virt-xen4c   113 k
 libvirt-daemon-driver-qemu                   x86_64   5.1.0-9.el8                                     virt-xen4c   652 k
 libvirt-daemon-driver-secret                 x86_64   5.1.0-9.el8                                     virt-xen4c    78 k
 libvirt-daemon-driver-storage                x86_64   5.1.0-9.el8                                     virt-xen4c    11 k
 libvirt-daemon-driver-storage-core           x86_64   5.1.0-9.el8                                     virt-xen4c   261 k
 libvirt-daemon-driver-storage-disk           x86_64   5.1.0-9.el8                                     virt-xen4c    80 k
 libvirt-daemon-driver-storage-gluster        x86_64   5.1.0-9.el8                                     virt-xen4c    93 k
 libvirt-daemon-driver-storage-iscsi          x86_64   5.1.0-9.el8                                     virt-xen4c    77 k
 libvirt-daemon-driver-storage-iscsi-direct   x86_64   5.1.0-9.el8                                     virt-xen4c    80 k
 libvirt-daemon-driver-storage-logical        x86_64   5.1.0-9.el8                                     virt-xen4c    82 k
 libvirt-daemon-driver-storage-mpath          x86_64   5.1.0-9.el8                                     virt-xen4c    76 k
 libvirt-daemon-driver-storage-rbd            x86_64   5.1.0-9.el8                                     virt-xen4c    85 k
 libvirt-daemon-driver-storage-scsi           x86_64   5.1.0-9.el8                                     virt-xen4c    78 k
 libvirt-libs                                 x86_64   5.1.0-9.el8                                     virt-xen4c   4.2 M
 libiscsi                                     x86_64   1.18.0-8.el8                                    virt-xen4c    88 k
 netcf-libs                                   x86_64   0.2.8-13.el8                                    virt-xen4c    76 k
 bridge-utils                                 x86_64   1.6-3.el8                                       msp-main      39 k
 libssh2                                      x86_64   1.8.0-9.el8                                     msp-main      97 k
 libnfs                                       x86_64   4.0.0-1.el8                                     epel         136 k
Installing weak dependencies:
 python3-html5lib                             noarch   1:0.999999999-6.el8                             AppStream    214 k
 python3-beautifulsoup4                       noarch   4.6.3-2.el8.1                                   epel         185 k
 python3-cssselect                            noarch   0.9.2-10.el8                                    epel          40 k
Enabling module streams:
 python36                                              3.6                                                               

Transaction Summary
==========================================================================================================================
Install  194 Packages

Total download size: 90 M
Installed size: 331 M
Is this ok [y/N]: N

joeyos

joeyos

2020-03-01 00:17

reporter   ~0036410

Unfortunately adding all the missing packages isn't well done as a piecemeal process. It really needs to be fixed in all the build scripts for Centos itself and upstream.

It's not only leaf nodes that are unshipped but also build dependencies. It means it's an incomplete open source operating system on at least two fronts with the missing packages.

Many of the packages are missing build dependencies for packages in the OS that are shipped themselves, presumably they must therefore be built, they're just not being shipped.

To fix it properly they'll want to be shipped from the normal centos full package build process especially as there's a concern with build matching. Many missing devel packages are the result of building their reciprocal binary packages and ideally should not be built or separately for full compatibility including version matching as well as the specifics of the build.

The reason they're left out is that with RHEL, they're missing so that if you want to do something that needs them you have to pay for their support to do it for you.

You can technically build the missing things yourself but it's a massive undertaking sometimes. The way the packages are shipped is like shipping a database then deliberately removing parts breaking integrity. The packages are a bit like a file system and if you did an integrity check it would fail from these removed packages. You can discover this because a relational integrity check is done when installing packages. If you try to install source RPMs with the integrity checking enabled it will often fail because of these removed parents. Some of these missing packages are part of core packages and some of them also have recursive integrity errors which means you can end up having to rebuild and maintain yourself not only one package but a large chain of dependencies.

While the removal works with the way upstream does things, it's incompatible with centos where you don't have that paid support and are meant to be able to do things yourself. The removed packages are the ones you need to do a lot of things yourself and their removal now means if you want to do things yourself it goes from something that would have a small amount of work and maintenance involved to a major project.

The system for building centos already does most of the work needed and once the rest is done it only needs to be done once to serve everyone so we just need to know where that is so we can work out how to assemble a list of these packages in the right format or provide some level of contribution toward fixing the issue.

I'd not feel right getting a corresponding devel package for a system library from a third party source rather than having the one resulting from the original build of a package. Chances are in reality it might work but will eventually start to show cracks.
limburgher

limburgher

2020-03-02 17:20

reporter   ~0036419

Right, and EPEL isn't an option for the packages as the SRPM/main RPMs are in RHEL. It's not permitted and not possible with the current tooling, which is why it needs to be fixed at the RHEL and/or CentOS level.

Issue History

Date Modified Username Field Change
2019-09-30 09:21 eesau New Issue
2019-10-12 02:47 AlphaCluster Note Added: 0035448
2019-10-19 21:44 PryMar56 Note Added: 0035529
2019-10-20 15:19 toracat Relationship added has duplicate 0016625
2019-10-20 15:20 toracat Relationship added related to 0016626
2019-10-20 15:24 limburgher Note Added: 0035531
2019-10-21 13:45 Richard Jones Note Added: 0035539
2019-10-21 13:50 limburgher Note Added: 0035540
2019-10-21 13:56 Richard Jones Note Added: 0035541
2019-10-21 13:58 limburgher Note Added: 0035542
2019-10-21 14:03 AlphaCluster Note Added: 0035543
2019-10-21 14:19 Richard Jones Note Added: 0035544
2019-12-03 17:39 toracat Relationship added related to 0016549
2019-12-03 17:40 toracat Relationship added related to 0016795
2019-12-16 21:35 toracat Relationship added related to 0016811
2019-12-16 21:36 toracat Relationship added related to 0016832
2019-12-16 21:38 toracat Relationship added related to 0016826
2019-12-16 23:06 toracat Note Added: 0035846
2019-12-17 13:14 gabrielvlasiu Note Added: 0035850
2019-12-19 22:05 toracat Relationship added related to 0016845
2019-12-26 13:34 ivanovaal Note Added: 0035897
2020-01-06 17:33 toracat Relationship added has duplicate 0016894
2020-01-06 17:34 toracat Status new => assigned
2020-01-21 13:47 arrfab Relationship deleted has duplicate 0016894
2020-01-21 13:47 arrfab Relationship added has duplicate 0016894
2020-02-05 18:49 bstinson Relationship added related to 0017011
2020-02-10 15:23 tigalch Relationship added related to 0017032
2020-02-12 18:25 toracat Relationship added related to 0016504
2020-02-12 18:25 toracat Relationship added related to 0016620
2020-02-24 15:15 tdawson Relationship added related to 0017081
2020-02-28 08:16 toracat Relationship added related to 0017092
2020-02-28 15:38 joeyos Note Added: 0036401
2020-02-28 16:09 Richard Jones Note Added: 0036403
2020-02-29 03:49 PryMar56 File Added: xen-412-full-stack-without-virt-module
2020-02-29 03:49 PryMar56 Note Added: 0036406
2020-03-01 00:17 joeyos Note Added: 0036410
2020-03-02 17:20 limburgher Note Added: 0036419
2020-03-18 23:01 toracat Category libssh2 => _unreleased_devel_pkgs
2020-04-02 08:44 toracat Relationship added related to 0017214