View Issue Details

IDProjectCategoryView StatusLast Update
0016525CentOS-8-OTHERpublic2020-05-02 14:16
Reporteralexhaydock 
PrioritynormalSeverityminorReproducibilityalways
Status newResolutionopen 
Product Version8.0.1905 
Target VersionFixed in Version 
Summary0016525: new upstream microrelease flatpak 1.0.9
DescriptionThere is a new upstream microrelease of Flatpak (1.0.9), which brings backported fixes and improvements - the main being allowing use of extra_data in runtimes (which is required by the openh264 extension).

Installing the common dependency org.freedesktop.Platform.openh264/x86_64/19.08 from Flathub generates the following error:

Warning: Failed to install org.freedesktop.Platform.openh264/x86_64/19.08: runtime/org.freedesktop.Platform.openh264/x86_64/19.08 needs a later flatpak version (1.4.2;1.2.5;1.0.9;)

As noted by the error, bumping the Flatpak version from 1.0.6 to 1.0.9 would solve this issue. I can imagine it is an issue which will end up affecting many who wish to use Flatpaks on their CentOS system.
Steps To Reproduceflatpak install flathub org.freedesktop.Platform.openh264
Additional InformationAn identical bug exists for Ubuntu 18.04 LTS over at their bugtracker here: https://bugs.launchpad.net/ubuntu/+source/flatpak/+bug/1844666
TagsNo tags attached.

Activities

smarocchi

smarocchi

2019-12-02 09:39

reporter   ~0035787

I met the same problem while I was trying to use flatpak-builder to develop a new application.

Bests
alexhaydock

alexhaydock

2020-05-02 14:16

reporter   ~0036852

As the original reporter, I propose that this can be closed now that flatpak 1.0.9 has been available in the repositories for some time now.

Best,
Alex

Issue History

Date Modified Username Field Change
2019-10-03 10:47 alexhaydock New Issue
2019-12-02 09:39 smarocchi Note Added: 0035787
2020-05-02 14:16 alexhaydock Note Added: 0036852