View Issue Details

IDProjectCategoryView StatusLast Update
0016534Buildsyscommunity buildsyspublic2019-10-22 08:39
Reporteramoralej 
PrioritynormalSeveritymajorReproducibilityhave not tried
Status resolvedResolutionfixed 
Summary0016534: [Cloud SIG] Create OpenStack Ussuri tags in CBS
DescriptionCloud SIG is now branching Train release, so we'd like to requests tags for OpenStack Ussuri (next release).

Build target: cloud7-openstack-ussuri-el7
Buildroot: cloud7-openstack-ussuri-el7-build
Buildroot inheritance:
cloud7-openstack-ussuri-el7-build
  ├─buildsys7
  ├─cloud7-openstack-ussuri-testing
  └─cloud7-openstack-ussuri-candidate

Destination tag: cloud7-openstack-ussuri-candidate

Publishing tags:
cloud7-openstack-ussuri-testing
cloud7-openstack-ussuri-release

Note that because of upstream timelines we can't wait for CentOS8 CBS to get tags for ussuri so, let's start using CentOS7. At some later point we will probably switch to CentOS8 (TBD).
TagsNo tags attached.

Activities

alphacc

alphacc

2019-10-07 20:48

developer   ~0035366

Done ! Let me know if the buildroot need some updates for this release.

$ /opt/cbs-tools/scripts/create_sig.sh -s cloud -d 7 -p openstack -r ussuri -t el7 -x -a "x86_64 ppc64le aarch64"
* Checking distribution el7 configuration...
 -> Checking cloud config...
Reading openstack additional configs...
Creating tag : cloud7-openstack-ussuri-candidate
Creating tag : cloud7-openstack-ussuri-testing
Creating tag : cloud7-openstack-ussuri-release
 -> creating cloud7-openstack-ussuri-el7
Added external repo centos7-cr to tag cloud7-openstack-ussuri-el7-build (priority 5)
Added external repo centos7-extras to tag cloud7-openstack-ussuri-el7-build (priority 10)
Added external repo centos7-updates to tag cloud7-openstack-ussuri-el7-build (priority 15)
Added external repo centos7-os to tag cloud7-openstack-ussuri-el7-build (priority 20)
Using specific cloud/openstack options:
###
 BUILDROOT_DEFAULT="openstack-macros bash bzip2 coreutils cpio diffutils redhat-release findutils gawk gcc gcc-c++ grep gzip info make patch redhat-rpm-config rpm-build sed unzip util-linux-ng git which buildsys-tools xz"
 COMMON_INHERITANCE=false
###
amoralej

amoralej

2019-10-08 13:42

reporter   ~0035371

Hi,

According to https://cbs.centos.org/koji/taginfo?tagID=1798, cloud7-openstack-ussuri-el7-build is inheriting from buildsys and cloud7-openstack-ussuri-candidate, could you also add cloud7-openstack-ussuri-testing, similar to https://cbs.centos.org/koji/taginfo?tagID=1691. It should be:

cloud7-openstack-ussuri-el7-build
  ├─buildsys7
  ├─cloud7-openstack-ussuri-testing
  └─cloud7-openstack-ussuri-candidate
alphacc

alphacc

2019-10-09 11:32

developer   ~0035387

Hi :),

Do we real need that ? I ask because I'd rather fix the script to do it automatically.
It means that packages in -testing will have priority over packages in -candidate when building ?
alphacc

alphacc

2019-10-15 20:56

developer   ~0035492

ping ?
amoralej

amoralej

2019-10-16 08:05

reporter   ~0035499

Sorry for the delay, inheritance should be similar to train-el7-build:

cloud7-openstack-ussuri-el7-build
  ├─ buildsys7
  ├─ cloud7-openstack-ussuri-candidate
  └─ cloud7-openstack-ussuri-testing
apevec

apevec

2019-10-22 01:05

reporter   ~0035549

@amoralej should cloud7-openstack-rocky-el7-build and cloud7-openstack-stein-el7-build be fixed, they have -testing before -candidate ?
alphacc

alphacc

2019-10-22 06:35

developer   ~0035552

Last edited: 2019-10-22 06:36

View 2 revisions

ok ussuri is ready and I'll make a change to the SIG create script to always have those dependencies setup.

Let me know for rocky and stein ?

amoralej

amoralej

2019-10-22 08:19

reporter   ~0035553

@alphacc yes please, let's make candidate before testing. Thanks for checking!
alphacc

alphacc

2019-10-22 08:39

developer   ~0035554

Done all targets have the same inheritance now :

[koji@c1bf ~]$ koji taginfo cloud7-openstack-{stein,train,ussuri}-el7-build
Tag: cloud7-openstack-stein-el7-build [1619]
Arches: x86_64 ppc64le aarch64
Groups: build, srpm-build
Tag options:
This tag is a buildroot for one or more targets
Current repo: repo#329115: 2019-10-22 08:35:34.515677
Targets that build from this tag:
  cloud7-openstack-stein-el7
External repos:
    5 centos7-cr (http://mirror.centos.org/centos/7/cr/$arch/)
   10 centos7-extras (http://mirror.centos.org/centos/7/extras/$arch/)
   15 centos7-updates (http://mirror.centos.org/centos/7/updates/$arch/)
   20 centos7-os (http://mirror.centos.org/centos/7/os/$arch/)
Inheritance:
  10 .... cloud7-openstack-ussuri-candidate [1795]
  15 .... cloud7-openstack-ussuri-testing [1796]
  20 .... buildsys7 [6]

Tag: cloud7-openstack-train-el7-build [1691]
Arches: x86_64 ppc64le aarch64
Groups: build, srpm-build
Tag options:
This tag is a buildroot for one or more targets
Current repo: repo#328720: 2019-10-22 03:08:05.144014
Targets that build from this tag:
  cloud7-openstack-train-el7
External repos:
    5 centos7-cr (http://mirror.centos.org/centos/7/cr/$arch/)
   10 centos7-extras (http://mirror.centos.org/centos/7/extras/$arch/)
   15 centos7-updates (http://mirror.centos.org/centos/7/updates/$arch/)
   20 centos7-os (http://mirror.centos.org/centos/7/os/$arch/)
Inheritance:
  10 .... cloud7-openstack-ussuri-candidate [1795]
  15 .... cloud7-openstack-ussuri-testing [1796]
  20 .... buildsys7 [6]

Tag: cloud7-openstack-ussuri-el7-build [1798]
Arches: x86_64 ppc64le aarch64
Groups: build, srpm-build
Tag options:
This tag is a buildroot for one or more targets
Current repo: repo#329116: 2019-10-22 08:37:26.534552
Targets that build from this tag:
  cloud7-openstack-ussuri-el7
External repos:
    5 centos7-cr (http://mirror.centos.org/centos/7/cr/$arch/)
   10 centos7-extras (http://mirror.centos.org/centos/7/extras/$arch/)
   15 centos7-updates (http://mirror.centos.org/centos/7/updates/$arch/)
   20 centos7-os (http://mirror.centos.org/centos/7/os/$arch/)
Inheritance:
  10 .... cloud7-openstack-ussuri-candidate [1795]
  15 .... cloud7-openstack-ussuri-testing [1796]
  20 .... buildsys7 [6]

Issue History

Date Modified Username Field Change
2019-10-04 09:33 amoralej New Issue
2019-10-07 16:10 arrfab Note Added: 0035364
2019-10-07 20:48 alphacc Note Added: 0035366
2019-10-08 13:42 amoralej Note Added: 0035371
2019-10-09 11:32 alphacc Note Added: 0035387
2019-10-15 20:56 alphacc Note Added: 0035492
2019-10-16 08:05 amoralej Note Added: 0035499
2019-10-22 01:05 apevec Note Added: 0035549
2019-10-22 06:35 alphacc Note Added: 0035552
2019-10-22 06:36 alphacc Note Edited: 0035552 View Revisions
2019-10-22 08:19 amoralej Note Added: 0035553
2019-10-22 08:39 alphacc Status new => resolved
2019-10-22 08:39 alphacc Resolution open => fixed
2019-10-22 08:39 alphacc Note Added: 0035554