View Issue Details

IDProjectCategoryView StatusLast Update
0016560CentOS-8PackageKitpublic2019-10-09 20:17
Reporterliberodark 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionwon't fix 
Product Version8.0.1905 
Target VersionFixed in Version 
Summary0016560: No see packages informations
DescriptionHi,

On CentOS 8 no see information from packages update :

Other exemples and have open issue on my redhat account but im not sure that is a redhat issue :

[b]
Other Exemple Terminal with check_update on CentOS 7 :[/b]

[code]
./check_updates
The following packages are security updates:
apr-1.4.8-5.el7.x86_64 (SECURITY)
bind-libs-lite-32:9.11.4-9.P2.el7.x86_64 (SECURITY)
bind-libs-32:9.11.4-9.P2.el7.x86_64 (SECURITY)
bind-license-32:9.11.4-9.P2.el7.noarch (SECURITY)
bind-utils-32:9.11.4-9.P2.el7.x86_64 (SECURITY)
curl-7.29.0-54.el7.x86_64 (SECURITY)
elfutils-default-yama-scope-0.176-2.el7.noarch (SECURITY)
elfutils-libelf-0.176-2.el7.x86_64 (SECURITY)
elfutils-libs-0.176-2.el7.x86_64 (SECURITY)
ghostscript-9.25-2.el7_7.2.x86_64 (SECURITY)
kernel-headers-3.10.0-1062.1.2.el7.x86_64 (SECURITY)
kernel-tools-libs-3.10.0-1062.1.2.el7.x86_64 (SECURITY)
kernel-tools-3.10.0-1062.1.2.el7.x86_64 (SECURITY)
kernel-3.10.0-1062.1.2.el7.x86_64 (SECURITY)
libarchive-3.1.2-12.el7.x86_64 (SECURITY)
libcurl-7.29.0-54.el7.x86_64 (SECURITY)
libjpeg-turbo-1.2.90-8.el7.x86_64 (SECURITY)
libmspack-0.5-0.7.alpha.el7.x86_64 (SECURITY)
libsmbclient-4.9.1-6.el7.x86_64 (SECURITY)
libssh2-1.8.0-3.el7.x86_64 (SECURITY)
libtiff-4.0.3-32.el7.x86_64 (SECURITY)
libtirpc-0.2.4-0.16.el7.x86_64 (SECURITY)
libwbclient-4.9.1-6.el7.x86_64 (SECURITY)
mariadb-libs-1:5.5.64-1.el7.x86_64 (SECURITY)
mariadb-server-1:5.5.64-1.el7.x86_64 (SECURITY)
mariadb-1:5.5.64-1.el7.x86_64 (SECURITY)
nagios-common-4.4.3-1.el7.x86_64 (SECURITY)
nagios-4.4.3-1.el7.x86_64 (SECURITY)
ntp-4.2.6p5-29.el7.centos.x86_64 (SECURITY)
ntpdate-4.2.6p5-29.el7.centos.x86_64 (SECURITY)
pango-1.42.4-4.el7_7.x86_64 (SECURITY)
patch-2.7.1-11.el7.x86_64 (SECURITY)
polkit-0.112-22.el7_7.1.x86_64 (SECURITY)
python-libs-2.7.5-86.el7.x86_64 (SECURITY)
python-perf-3.10.0-1062.1.2.el7.x86_64 (SECURITY)
python-2.7.5-86.el7.x86_64 (SECURITY)
rsyslog-mysql-8.24.0-41.el7_7.x86_64 (SECURITY)
rsyslog-8.24.0-41.el7_7.x86_64 (SECURITY)
samba-client-libs-4.9.1-6.el7.x86_64 (SECURITY)
samba-client-4.9.1-6.el7.x86_64 (SECURITY)
samba-common-libs-4.9.1-6.el7.x86_64 (SECURITY)
samba-common-4.9.1-6.el7.noarch (SECURITY)
systemd-libs-219-67.el7_7.1.x86_64 (SECURITY)
systemd-sysv-219-67.el7_7.1.x86_64 (SECURITY)
systemd-219-67.el7_7.1.x86_64 (SECURITY)
unzip-6.0-20.el7.x86_64 (SECURITY)
vim-common-2:7.4.629-6.el7.x86_64 (SECURITY)
vim-enhanced-2:7.4.629-6.el7.x86_64 (SECURITY)
vim-filesystem-2:7.4.629-6.el7.x86_64 (SECURITY)
vim-minimal-2:7.4.629-6.el7.x86_64 (SECURITY)
UPDATE OK - Security-Update = 50 | 'Total Update' = 276
[/code]

Work

[b]Other Exemple Terminal with check_update on Redhat 8 :[/b]

[code]
./check_updates
The following packages are security updates:
bind-export-libs-32:9.11.4-17.P2.el8_0.1.x86_64 (SECURITY)
kernel-core-4.18.0-80.11.2.el8_0.x86_64 (SECURITY)
kernel-modules-4.18.0-80.11.2.el8_0.x86_64 (SECURITY)
kernel-tools-libs-4.18.0-80.11.2.el8_0.x86_64 (SECURITY)
kernel-tools-4.18.0-80.11.2.el8_0.x86_64 (SECURITY)
kernel-4.18.0-80.11.2.el8_0.x86_64 (SECURITY)
libnghttp2-1.33.0-1.el8_0.1.x86_64 (SECURITY)
python3-perf-4.18.0-80.11.2.el8_0.x86_64 (SECURITY)
vim-minimal-2:8.0.1763-11.el8_0.x86_64 (SECURITY)
UPDATE OK - Security-Update = 9 | 'Total Update' = 70
[/code]

Work

[b]Other Exemple Terminal with check_update on CentOS 8 :[/b]

[code]
./check_updates
The following packages are security updates:
WARN: Missing update detail for package bind-export-libs-32:9.11.4-17.P2.el8_0.1.x86_64
WARN: Missing update detail for package iptables-ebtables-1.8.2-9.el8_0.1.x86_64
WARN: Missing update detail for package iptables-libs-1.8.2-9.el8_0.1.x86_64
WARN: Missing update detail for package iptables-1.8.2-9.el8_0.1.x86_64
WARN: Missing update detail for package kernel-core-4.18.0-80.7.1.el8_0.x86_64
WARN: Missing update detail for package kernel-modules-4.18.0-80.7.1.el8_0.x86_64
WARN: Missing update detail for package kernel-tools-libs-4.18.0-80.7.1.el8_0.x86_64
WARN: Missing update detail for package kernel-tools-4.18.0-80.7.1.el8_0.x86_64
WARN: Missing update detail for package kernel-4.18.0-80.7.1.el8_0.x86_64
WARN: Missing update detail for package kmod-libs-25-11.el8_0.2.x86_64
WARN: Missing update detail for package kmod-25-11.el8_0.2.x86_64
WARN: Missing update detail for package libdnf-0.22.5-5.el8_0.x86_64
WARN: Missing update detail for package libnfsidmap-1:2.3.3-14.el8_0.x86_64
WARN: Missing update detail for package libsss_autofs-2.0.0-43.el8_0.3.x86_64
WARN: Missing update detail for package libsss_certmap-2.0.0-43.el8_0.3.x86_64
WARN: Missing update detail for package libsss_idmap-2.0.0-43.el8_0.3.x86_64
WARN: Missing update detail for package libsss_nss_idmap-2.0.0-43.el8_0.3.x86_64
WARN: Missing update detail for package libsss_sudo-2.0.0-43.el8_0.3.x86_64
WARN: Missing update detail for package microcode_ctl-4:20180807a-2.20190618.1.el8_0.x86_64
WARN: Missing update detail for package p11-kit-trust-0.23.14-5.el8_0.x86_64
WARN: Missing update detail for package p11-kit-0.23.14-5.el8_0.x86_64
WARN: Missing update detail for package platform-python-3.6.8-2.el8_0.0.1.x86_64
WARN: Missing update detail for package python3-hawkey-0.22.5-5.el8_0.x86_64
WARN: Missing update detail for package python3-libdnf-0.22.5-5.el8_0.x86_64
WARN: Missing update detail for package python3-libs-3.6.8-2.el8_0.0.1.x86_64
WARN: Missing update detail for package python3-perf-4.18.0-80.7.1.el8_0.x86_64
WARN: Missing update detail for package selinux-policy-targeted-3.14.1-61.el8_0.1.noarch
WARN: Missing update detail for package selinux-policy-3.14.1-61.el8_0.1.noarch
WARN: Missing update detail for package setup-2.12.2-2.el8.noarch
WARN: Missing update detail for package sssd-client-2.0.0-43.el8_0.3.x86_64
WARN: Missing update detail for package sssd-common-2.0.0-43.el8_0.3.x86_64
WARN: Missing update detail for package sssd-kcm-2.0.0-43.el8_0.3.x86_64
WARN: Missing update detail for package sssd-nfs-idmap-2.0.0-43.el8_0.3.x86_64
WARN: Missing update detail for package systemd-libs-239-13.el8_0.5.x86_64
WARN: Missing update detail for package systemd-pam-239-13.el8_0.5.x86_64
WARN: Missing update detail for package systemd-udev-239-13.el8_0.5.x86_64
WARN: Missing update detail for package systemd-239-13.el8_0.5.x86_64
(none)
UPDATE OK - Security-Update = 0 | 'Total Update' = 37
[/code]

Not Work (check_update says that there are no security updates but it's wrong it's only that there is no information about packages.)

Source of check_update : https://github.com/liberodark/nrpe-installer/wiki/Plugin-check_updates

https://www.centos.org/forums/viewtopic.php?f=57&t=71927
https://bugzilla.redhat.com/show_bug.cgi?id=1759565
Steps To Reproduceyum install -y cockpit cockpit-packagekit sos
systemctl enable --now cockpit.socket
firewall-cmd --permanent --zone=public --add-service=cockpit
firewall-cmd --reload

or

yum install -y PackageKit
systemctl start packagekit.socket
pkcon get-update-detail systemd
TagsNo tags attached.

Activities

TrevorH

TrevorH

2019-10-09 20:17

manager   ~0035418

CentOS has never included security errata in its yum repos. CentOS 7 didn't have it nor 5 or 6. If you need security related metadata in your yum repos then you need to run RHEL.

Issue History

Date Modified Username Field Change
2019-10-09 07:23 liberodark New Issue
2019-10-09 20:17 TrevorH Status new => closed
2019-10-09 20:17 TrevorH Resolution open => won't fix
2019-10-09 20:17 TrevorH Note Added: 0035418