View Issue Details

IDProjectCategoryView StatusLast Update
0016604CentOS-8libeditpublic2019-10-24 16:26
Reporterhirenvadalia 
PriorityimmediateSeverityblockReproducibilityalways
Status closedResolutionno change required 
Product Version8.0.1905 
Target VersionFixed in Version 
Summary0016604: libedit-devel package missing
DescriptionFrom Centos-8 repos, libedit-devel packages missing:
# dnf install libedit-devel
Failed to set locale, defaulting to C
CentOS-8 - AppStream 1.6 kB/s | 4.3 kB 00:02
CentOS-8 - Base 1.5 kB/s | 3.9 kB 00:02
CentOS-8 - Extras 269 B/s | 1.5 kB 00:05
Extra Packages for Enterprise Linux 8 - x86_64 901 B/s | 5.4 kB 00:06
No match for argument: libedit-devel
Error: Unable to find a match
Steps To Reproducednf install libedit-devel
TagsNo tags attached.

Activities

dnate

dnate

2019-10-16 17:17

reporter   ~0035506

try enabling the PowerTools repository

dnf config-manager --set-enabled PowerTools
dnate

dnate

2019-10-16 17:25

reporter   ~0035507

also it's now libedit-devel apparently
hirenvadalia

hirenvadalia

2019-10-16 17:55

reporter   ~0035511

Thanks @dnate, Now I am able to install libedit-devel.
But just wanted to know what is PowerTools repo? And why few devel packages are part of that repo and others are in base/AppStream repo?
dnate

dnate

2019-10-16 20:56

reporter   ~0035516

@hirenvadalia I'm afraid I don't have the answer to that, I just got lucky.
hirenvadalia

hirenvadalia

2019-10-17 03:51

reporter   ~0035519

No problem @dnate I was just curious to know, Looks like I found a reason for PowerTools repo, but not 100% sure about whether what I find is correct.

https://lists.centos.org/pipermail/centos-devel/2019-September/017788.html
https://developers.redhat.com/blog/2018/11/15/introducing-codeready-linux-builder/
hirenvadalia

hirenvadalia

2019-10-24 06:48

reporter   ~0035567

This can be closed as devel packages exists in PowerTools repo.

Issue History

Date Modified Username Field Change
2019-10-16 10:03 hirenvadalia New Issue
2019-10-16 17:17 dnate Note Added: 0035506
2019-10-16 17:25 dnate Note Added: 0035507
2019-10-16 17:55 hirenvadalia Note Added: 0035511
2019-10-16 20:56 dnate Note Added: 0035516
2019-10-17 03:51 hirenvadalia Note Added: 0035519
2019-10-24 06:48 hirenvadalia Note Added: 0035567
2019-10-24 16:26 toracat Status new => closed
2019-10-24 16:26 toracat Resolution open => no change required