View Issue Details

IDProjectCategoryView StatusLast Update
0016635CentOS-8kernelpublic2019-11-27 08:12
Reporterpseud 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version8.0.1905 
Target VersionFixed in Version 
Summary0016635: kernel wrongley id's iwlwifi as driver for intel wireless 3945
Description$ lspci -knn | grep 3945
10:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection [8086:4222] (rev 02)
$ grep 8086 /lib/modules/4.18.0-80.11.2.el8_0.x86_64/modules.* | grep 4222
/lib/modules/4.18.0-80.11.2.el8_0.x86_64/modules.alias:alias pci:v00008086d00000891sv*sd00004222bc*sc*i* iwlwifi

But:
https://wireless.wiki.kernel.org/en/users/drivers/iwlegacy
Says:
iwlegacy is the wireless driver for Intel's 3945 and 4965 wireless chips.
Steps To Reproduceinstall CentOS 8 on above hardware
Additional Informationhttps://www.centos.org/forums/viewtopic.php?f=54&t=72163#p303400
TagsNo tags attached.

Activities

toracat

toracat

2019-10-22 18:17

manager   ~0035557

Your device uses the iwl3945 driver. I'm going to enable both iwl3945 and iwl4965 in the next update to the centosplus kernel (kernel-plus).

You can of course install the kmod package that will be provided by ELRepo ( https://elrepo.org/bugs/view.php?id=959 ).
pseud

pseud

2019-10-23 20:38

reporter   ~0035564

Thank you
toracat

toracat

2019-10-23 22:30

manager   ~0035565

@pseud

I have built the plus kernel with iwl3945 and iwl4965 enabled. It is available for testing at:

https://people.centos.org/toracat/kernel/8/plus/bug16635/

(version 4.18.0-80.11.2.el8_0.centos.plus.bug16635)

Please give it a try and let us know if this kernel works for you.
toracat

toracat

2019-10-30 17:57

manager   ~0035610

@pseud

Did you have a chance to test the plus kernel?
pseud

pseud

2019-11-18 22:10

reporter   ~0035708

Hi toracat & pperry, thanks sooo much for your help. I can report success :-)

Here's the complete output from to set-up, go to woe, attached.

centos8_iwlegacy.txt (12,260 bytes)
$ sudo dnf install https://people.centos.org/toracat/kernel/8/plus/bug16635/kernel-plus-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64.rpm https://people.centos.org/toracat/kernel/8/plus/bug16635/kernel-plus-core-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64.rpm https://people.centos.org/toracat/kernel/8/plus/bug16635/kernel-plus-devel-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64.rpm https://people.centos.org/toracat/kernel/8/plus/bug16635/kernel-plus-modules-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64.rpm https://people.centos.org/toracat/kernel/8/plus/bug16635/kernel-plus-tools-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64.rpm https://people.centos.org/toracat/kernel/8/plus/bug16635/kernel-plus-tools-libs-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64.rpm
[sudo] password for admin: 
CentOS-8 - AppStream                                                                                2.1 kB/s | 4.3 kB     00:02    
CentOS-8 - Base                                                                                     2.4 kB/s | 3.9 kB     00:01    
CentOS-8 - Extras                                                                                   732  B/s | 1.5 kB     00:02    
CentOS-8 - PowerTools                                                                               2.1 kB/s | 4.3 kB     00:02    
Docker CE Stable - x86_64                                                                           3.2 kB/s | 3.5 kB     00:01    
ELRepo.org Community Enterprise Linux Repository - el8                                              1.2 kB/s | 2.9 kB     00:02    
Extra Packages for Enterprise Linux 8 - x86_64                                                       27 kB/s |  33 kB     00:01    
kernel-plus-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64.rpm                                    195 kB/s | 423 kB     00:02    
kernel-plus-core-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64.rpm                               1.6 MB/s |  25 MB     00:15    
kernel-plus-devel-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64.rpm                              2.4 MB/s |  13 MB     00:05    
kernel-plus-modules-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64.rpm                            2.4 MB/s |  21 MB     00:08    
kernel-plus-tools-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64.rpm                              569 kB/s | 641 kB     00:01    
kernel-plus-tools-libs-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64.rpm                         208 kB/s | 454 kB     00:02    
Error: 
 Problem 1: problem with installed package kernel-tools-4.18.0-80.11.2.el8_0.x86_64
  - package kernel-plus-tools-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64 conflicts with kernel-tools < 4.18.0-80.11.2.el8_0.centos.plus.bug16635 provided by kernel-tools-4.18.0-80.11.2.el8_0.x86_64
  - package kernel-plus-tools-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64 conflicts with kernel-tools < 4.18.0-80.11.2.el8_0.centos.plus.bug16635 provided by kernel-tools-4.18.0-80.1.2.el8_0.x86_64
  - package kernel-plus-tools-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64 conflicts with kernel-tools < 4.18.0-80.11.2.el8_0.centos.plus.bug16635 provided by kernel-tools-4.18.0-80.11.1.el8_0.x86_64
  - package kernel-plus-tools-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64 conflicts with kernel-tools < 4.18.0-80.11.2.el8_0.centos.plus.bug16635 provided by kernel-tools-4.18.0-80.4.2.el8_0.x86_64
  - package kernel-plus-tools-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64 conflicts with kernel-tools < 4.18.0-80.11.2.el8_0.centos.plus.bug16635 provided by kernel-tools-4.18.0-80.7.1.el8_0.x86_64
  - package kernel-plus-tools-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64 conflicts with kernel-tools < 4.18.0-80.11.2.el8_0.centos.plus.bug16635 provided by kernel-tools-4.18.0-80.7.2.el8_0.x86_64
  - package kernel-plus-tools-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64 conflicts with kernel-tools < 4.18.0-80.11.2.el8_0.centos.plus.bug16635 provided by kernel-tools-4.18.0-80.el8.x86_64
  - conflicting requests
 Problem 2: problem with installed package kernel-tools-libs-4.18.0-80.11.2.el8_0.x86_64
  - package kernel-plus-tools-libs-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64 conflicts with kernel-tools-libs < 4.18.0-80.11.2.el8_0.centos.plus.bug16635 provided by kernel-tools-libs-4.18.0-80.11.2.el8_0.x86_64
  - package kernel-plus-tools-libs-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64 conflicts with kernel-tools-libs < 4.18.0-80.11.2.el8_0.centos.plus.bug16635 provided by kernel-tools-libs-4.18.0-80.1.2.el8_0.x86_64
  - package kernel-plus-tools-libs-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64 conflicts with kernel-tools-libs < 4.18.0-80.11.2.el8_0.centos.plus.bug16635 provided by kernel-tools-libs-4.18.0-80.11.1.el8_0.x86_64
  - package kernel-plus-tools-libs-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64 conflicts with kernel-tools-libs < 4.18.0-80.11.2.el8_0.centos.plus.bug16635 provided by kernel-tools-libs-4.18.0-80.4.2.el8_0.x86_64
  - package kernel-plus-tools-libs-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64 conflicts with kernel-tools-libs < 4.18.0-80.11.2.el8_0.centos.plus.bug16635 provided by kernel-tools-libs-4.18.0-80.7.1.el8_0.x86_64
  - package kernel-plus-tools-libs-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64 conflicts with kernel-tools-libs < 4.18.0-80.11.2.el8_0.centos.plus.bug16635 provided by kernel-tools-libs-4.18.0-80.7.2.el8_0.x86_64
  - package kernel-plus-tools-libs-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64 conflicts with kernel-tools-libs < 4.18.0-80.11.2.el8_0.centos.plus.bug16635 provided by kernel-tools-libs-4.18.0-80.el8.x86_64
  - conflicting requests
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
[admin@frontserver tmp]$ sudo dnf install https://people.centos.org/toracat/kernel/8/plus/bug16635/kernel-plus-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64.rpm https://people.centos.org/toracat/kernel/8/plus/bug16635/kernel-plus-core-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64.rpm https://people.centos.org/toracat/kernel/8/plus/bug16635/kernel-plus-devel-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64.rpm https://people.centos.org/toracat/kernel/8/plus/bug16635/kernel-plus-modules-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64.rpm
[sudo] password for admin: 
Last metadata expiration check: 0:11:57 ago on Mon 18 Nov 2019 20:46:09 GMT.
kernel-plus-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64.rpm                                    116 kB/s | 423 kB     00:03    
kernel-plus-core-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64.rpm                               371 kB/s |  25 MB     01:07    
kernel-plus-devel-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64.rpm                              510 kB/s |  13 MB     00:25    
kernel-plus-modules-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64.rpm                            843 kB/s |  21 MB     00:25    
Dependencies resolved.
====================================================================================================================================
 Package                       Arch             Version                                                Repository              Size
====================================================================================================================================
Installing:
 kernel-plus                   x86_64           4.18.0-80.11.2.el8_0.centos.plus.bug16635              @commandline           423 k
 kernel-plus-core              x86_64           4.18.0-80.11.2.el8_0.centos.plus.bug16635              @commandline            25 M
 kernel-plus-devel             x86_64           4.18.0-80.11.2.el8_0.centos.plus.bug16635              @commandline            13 M
 kernel-plus-modules           x86_64           4.18.0-80.11.2.el8_0.centos.plus.bug16635              @commandline            21 M

Transaction Summary
====================================================================================================================================
Install  4 Packages

Total size: 59 M
Installed size: 125 M
Is this ok [y/N]: y
Downloading Packages:
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                                                                            1/1 
  Installing       : kernel-plus-core-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64                                          1/4 
  Running scriptlet: kernel-plus-core-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64                                          1/4 
  Installing       : kernel-plus-modules-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64                                       2/4 
  Running scriptlet: kernel-plus-modules-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64                                       2/4 
  Installing       : kernel-plus-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64                                               3/4 
  Installing       : kernel-plus-devel-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64                                         4/4 
  Running scriptlet: kernel-plus-devel-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64                                         4/4 
  Running scriptlet: kernel-plus-core-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64                                          4/4 
  Running scriptlet: kernel-plus-devel-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64                                         4/4 
  Verifying        : kernel-plus-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64                                               1/4 
  Verifying        : kernel-plus-core-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64                                          2/4 
  Verifying        : kernel-plus-devel-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64                                         3/4 
  Verifying        : kernel-plus-modules-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64                                       4/4 

Installed:
  kernel-plus-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64                                                                      
  kernel-plus-core-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64                                                                 
  kernel-plus-devel-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64                                                                
  kernel-plus-modules-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64                                                              

Complete!
$ sudo nmcli radio
[sudo] password for admin: 
WIFI-HW  WIFI     WWAN-HW  WWAN    
enabled  enabled  enabled  enabled 
$ sudo nmcli device
DEVICE      TYPE      STATE         CONNECTION            
nm-bridge1  bridge    connected     br1                   
virbr0      bridge    connected     virbr0                
ens1        ethernet  connected     Ethernet connection 1 
vnet0       tun       connected     vnet0                 
wlp16s0     wifi      disconnected  --                    
lo          loopback  unmanaged     --                    
virbr0-nic  tun       unmanaged     --                    
$ sudo nmcli device wifi rescan
$ sudo nmcli device wifi list
IN-USE  SSID          MODE   CHAN  RATE        SIGNAL  BARS  SECURITY    
        OpenWrt0      Infra  1     130 Mbit/s  89      ▂▄▆█  WPA2        
        OpenWrt0      Infra  11    195 Mbit/s  77      ▂▄▆_  WPA2        
        Virgin Media  Infra  1     130 Mbit/s  55      ▂▄__  WPA2 802.1X 
        VM7352710     Infra  1     130 Mbit/s  54      ▂▄__  WPA1 WPA2   
        VM7352710     Infra  1     130 Mbit/s  44      ▂▄__  WPA1 WPA2   
        BTHub5-8FZF   Infra  6     130 Mbit/s  32      ▂▄__  WPA2        
$ sudo nmcli device wifi connect OpenWrt0 password [my-wifi-pword]
Device 'wlp16s0' successfully activated with '5a8b0527-e9f1-4561-a9d6-075abab02b6e'.
$ uname -r
4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64
centos8_iwlegacy.txt (12,260 bytes)
pseud

pseud

2019-11-18 22:13

reporter   ~0035709

The only problem was the conflict with kernel-plus-tools-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64.rpm and kernel-plus-tools-libs-4.18.0-80.11.2.el8_0.centos.plus.bug16635.x86_64.rpm
toracat

toracat

2019-11-18 23:01

manager   ~0035710

@pseud

Glad to hear the plus kernel is working.

Regarding the kernel-plus-tools-xxx packages, by design they conflict with the ones from distro kernel. You'd need to remove the distro ones if you want to install the plus kernel version.

Issue History

Date Modified Username Field Change
2019-10-21 19:01 pseud New Issue
2019-10-22 18:04 toracat Status new => acknowledged
2019-10-22 18:17 toracat Note Added: 0035557
2019-10-23 20:38 pseud Note Added: 0035564
2019-10-23 22:30 toracat Note Added: 0035565
2019-10-30 17:57 toracat Status acknowledged => feedback
2019-10-30 17:57 toracat Note Added: 0035610
2019-11-18 22:10 pseud File Added: centos8_iwlegacy.txt
2019-11-18 22:10 pseud Note Added: 0035708
2019-11-18 22:10 pseud Status feedback => assigned
2019-11-18 22:13 pseud Note Added: 0035709
2019-11-18 23:01 toracat Note Added: 0035710
2019-11-27 08:12 toracat Status assigned => resolved
2019-11-27 08:12 toracat Resolution open => fixed